[Résolu] lazy-gallery -wordpress 2 (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #447006
    jean-noel
    Membre
    Initié WordPress
    6 contributions

    bonjour

    j’ai installé le plugin lazy-gallery avec wordpress dernière version mais lorsque j’active le lien /lazy-index.php la page affiche deux erreurs :

    Warning: opendir(): open_basedir restriction in effect. File(/var/alternc/bureau/wordpress/wp-gallery/) is not within the allowed path(s):

    et open dir: Operation not permitted in… etc

    le serveur n’accepte pas une autre permission si je coche execution dans la propriété du dossier

    quelle opération pour corriger ou une adresse de plugin pour mettre les dossiers images sous forme de galerie avec wordpress 2

    vous remerciant cordialement jean-noel

    #569878
    Oo
    Membre
    Maître WordPress
    2484 contributions

    Hum hum,

    Je ne vois pas trop d’où cela peut provenir !

    Espèrons que ce message puisse relever l’information et attirer l’oeil de certain pro de WP ! 😋

    :D

    #569879
    damino
    Participant
    Maître WordPress
    1243 contributions

    Et alors un lien, le nom de ton hébergeur ???
    T’es chez Free ou quoi ?
    Je dis peut-être une connerie mais avec un certain script php sur free j’ai du créer un répertoire ‘sessions’ à la racine et hop mes problèmes de droits ont été résolus.

    #569880
    jean-noel
    Membre
    Initié WordPress
    6 contributions

    Bonjour,
    j’ai supprimé Lazy et remplacé par lazyest-gallery

    j’ai activé le plugin et mis le lien dans la sidebar.
    Les galleries apparaissent bien mais seul problème elles s’affichent sans le css du blog

    comment configurer pour qu’elles s’affichent convenablement
    merci encore bien cordialement

    #569881
    damino
    Participant
    Maître WordPress
    1243 contributions

    Un lien vers ton “problème” peut-être …
    Comme toujours donnez-nous quelques clées si vous voulez de l’aide … Merci.😋

    #569882
    jean-noel
    Membre
    Initié WordPress
    6 contributions
    #569883
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Si j’en juge par le code source affiché par cette page
    http://www.desyeuxpourvoir.net/wordpress/lazyest-index.php?file=/galerie-acqme/acqme-7.jpg
    tu n’importes pas le fichier d’entête de ton blog. C’est lui qui contient les appels CSS, donc formcément…
    Place un p’tit get_header(); en haut du fichier…

    #569884
    jean-noel
    Membre
    Initié WordPress
    6 contributions

    dans le fichier laziest-index get_header se trouve à la ligne 22.

    J’ai essayé de remedier au problème par l’import de la feuille de style du thème à laquelle j’ai ajouté le style de la galerie.

    en modifiant le style galerie marge de 200 px
    pour firefox la galerie s’affiche correctement mais pour IE le header et footer s’affiche à droite et la galerie se place à gauche (puisque elle prend la marge à partir du corps)

    Donc cette solution me semble pas la bonne. POURQUOI la redirection de la galerie ne prend pas le style du blog ?

    #569885
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Il faut afficher le header.php dès la première ligne (et accéssoirement le footer.php à la dernière), sinon ton codes HTML est largement incomplet.
    Just see the difference :
    http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.desyeuxpourvoir.net%2Fwordpress%2Flazyest-index.php%3Ffile%3D%2Fgalerie-acqme%2Facqme-7.jpg
    http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.desyeuxpourvoir.net%2Fwordpress%2F
    Tout ce qui est doctype, titre, balises meta, appels css et autres est stocké dans le header. Arrange-toi donc pour avoir ce header au début de ton lazyest-index.php. Tu dis qu’il y est, apparemment il n’est pas appellé vu que son contenu n’est pas appellé (ou alors, ton template ne comporte pas de header.php ?). Fait alors un require_once(“header.php”);, par exemple.

    #569886
    jean-noel
    Membre
    Initié WordPress
    6 contributions

    j’ai déplacé header puis crée require mais toujours le même problème….

    #569887
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Tu ne devrais pas avoir à déplacer le header, je pense.
    Regarde le code source d’une de tes page photo : tu vois bien qu’il manque les en-têtes par rapport à ton blog. C’est cette section-là qu’il faut charger.

    En gros, il te manque ça au début

    
    
    
    	
    	<title>jean d’en haut</title>
    	 <!-- leave this for stats please -->
    	
    		@import url( http://www.desyeuxpourvoir.net/wordpress/wp-content/themes/connections/style.css );
    		
    	
    	
    
    	
        	
    	
    	

    et ça à la fin

    </div>

    Idéalement tu devrais donc faire appel aux fichiers header.php et footer.php de WP, étant donné qu’ils lient correctement les CSS – mais je ne sais pas comment sont organisés tes fichiers…

    #569888
    jean-noel
    Membre
    Initié WordPress
    6 contributions

    j’ai intégré le code html dans le fichier lazyest-index.php et effectivement les galeries s’affichent correctement avec fire fox et opéra avec >IE la galerie est décalée vers la droite mais dans la page.

    La seule ombre au tableau c’est qu’il a fallu inclure le style de la galerie avec le style du thème et faire la modification du fichier en important la feuille de style du theme.

    Et aussi dans options [wordpress] la configuration de lazyest-gallery je n’ai pas intégré la barre de navigation. sinon dans le cas sidebar : right elle s’affiche de part et d’autres de la page en ne respectant pas les caractères et graphisme de la barre de navigation

    J’avais installé précédement lazy-gallery avec wordpress 1.5 et tout fonctionnait en activant le plugin puis en configurant la lazy dans option.

    Avec lazyest-gallery et wordpress 2 le problème de la configuration de la galerie me semble plus hasardeux. j’ai changé de thème, pour essayer, mais le problème reste identique.

    Mais bon cela fonctionne j’en reste là…Grand merci encore pour tes conseils…
    cordialement

    #569889
    xavier
    Gestionnaire du forum
    Maître WordPress
    2126 contributions

    Résolu, donc

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.