[Résolu] Insertion d’image impossible sous 3.1 possible sous 3.0.5 (Créer un compte)

  • Statut : non résolu
15 sujets de 46 à 60 (sur un total de 63)
  • Auteur
    Messages
  • #760546
    Li-An
    Participant
    Maître WordPress
    28496 contributions

    Il y a une phrase qui m’interpelle:  » que l’on a évacué une défaillance de l’hebergeur ». Je considère toujours que le problème vient de Free (les bugs rétroactifs par propagation, je n’y crois pas trop).
    À mon avis, il faut regarder du côté de Spip. Il me semble que Joomla et Free, ça ne le fait pas trop. Ou alors Dotclear qui doit tourner sous Free.

    #760547
    dex
    Participant
    Padawan WordPress
    85 contributions
    Li-An wrote:
    Il y a une phrase qui m’interpelle:  » que l’on a évacué une défaillance de l’hebergeur ». Je considère toujours que le problème vient de Free (les bugs rétroactifs par propagation, je n’y crois pas trop).
    À mon avis, il faut regarder du côté de Spip. Il me semble que Joomla et Free, ça ne le fait pas trop. Ou alors Dotclear qui doit tourner sous Free.

    +1 🙂

    #760548
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Un article qui va dans le sens d’une remise en cause de Free pour cette erreur : WordPress et Free.

    Aucune idée de la valeur de l’article, je ne suis pas chez Free et n’utilise WordPress que depuis 2 mois.

    #760549
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Bonjour,
    Pour en avoir le coeur net, j’ai posé la question suivante sur le newsgroup des pages perso de FREE :
    « Bonjour,
    Je tiens un site WordPress sur lequel il y a 3 pages de photos que je met régulièrement à jour. Lorque je suis passé de WordPress 3.0.5 à 3.1, l’insertion de photos est devenue impossible. Tout click sur l’icone d’insertion de photos n’ayant aucune action sur la page.
    Alors, j’ai été contraint de reste sous 3.0.5 pour pouvoir continuer d’insérer des photos. Mais l’erreur s’est propagée à WordPress 3.0.5 puis à toutes les versions de WordPress 3.0.x.
    J’ai du alors pour insérer des photos migrer en version 2.9.2 et comme cette version n’a pas de menus personalisés, migrer à nouveau vers 3.0.
    Depuis hier, l’insertion de photos est impossible sous 2.9.x et pour inserer des phtos je suis contraint de migere temporairement sous 2.8.6.
    Dans les forums, on me dit que le problème vient de FREE !
    Ma question est la suivante quel CMS dois-je installer sur les pages perso de FREE pour ne pas avoir de problèmes ? »

    Je vous tiendrais au courant de la réponse de FREE !

    #760550
    Li-An
    Participant
    Maître WordPress
    28496 contributions

    J’espère que ce n’est pas le même genre de réponse que par téléphone (du vécu):
    « ma connexion a un gros problème aujourd’hui » »ah, c’est parce que votre ordi est probablement vérolé » »ça me parait difficile à croire » »ça vient de votre ordi monsieur ». Le lendemain, on savait que c’était un problème technique qui impactait une partie de ma ville. Bravo le service technique.

    #760551
    keokeo123
    Membre
    Initié WordPress
    2 contributions

    J’ai la même difficulté, après avoir lu votre discussion, je suis arrivé à le faire,
    merci pour votre assistance


    Voyage VietnamVietnam TourVoyage CambodgeCambodia Tour

    #760552
    luciole135
    Participant
    Maître WordPress
    13714 contributions
    keokeo123 wrote:
    J’ai la même difficulté, après avoir lu votre discussion, je suis arrivé à le faire,
    merci pour votre assistance

    Qu’avez-vous fait pour résoudre votre problème ? cela m’intéresse !

    Aujourd’hui, j’ai vidé le cache du navigateur et j’ai pu insérer une photo sous WP 3.0, je n’ai pas pu en insérer une deuxième ! J’ai vidé à nouveau le cache, cela n’a eu aucun effet.
    J’ai alors essayé sous 2.9.x, en vain, j’ai alors migré sous 2.8.6 et j’ai pu insérer la deuxième.

    Vraiment c’est une erreur qui n’a aucune logique et pour du code informatique, c’est un comble !

    #760553
    Li-An
    Participant
    Maître WordPress
    28496 contributions

    Il y a une logique et c’est l’hébergement. Mais visiblement, je prêche dans le désert. Sans compter que le downgrade d’un site WP doit faire bizarre au niveau de la base de données.

    #760554
    luciole135
    Participant
    Maître WordPress
    13714 contributions
    Li-An wrote:
    Il y a une logique et c’est l’hébergement. Mais visiblement, je prêche dans le désert. Sans compter que le downgrade d’un site WP doit faire bizarre au niveau de la base de données.

    J’entends bien que vous dites que c’est à cause de FREE, mais comme je ne paiuerais jamais pour informer les fumeurs comment arrêter de fumer (ce serait un comble que je doive payer pour informer GRATUITEMENT ceux qui se droguent volontairement) je reste avec FREE faute d’autre solution…Cela n’empêche que le code informatique a une logique et que cette erreur n’en a pas…ce qui est pour le moins étrange !

    #760555
    Li-An
    Participant
    Maître WordPress
    28496 contributions

    Il y a d’autres hébergeurs gratuits un peu plus performants que Free mais plutôt situés à l’étranger. Je pense qu’il y a une logique cachée quand même: l’hébergeur accepte un premier upload qui sature sa mémoire et bloque au second upload. J’imagine que vos diverses manip remettent le compteur à zéro ce qui permet un nouvel envoi suivi d’un blocage.

    #760556
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Ben, maintenant, même sous 2.8.6 après 5 insertions, je ne peux plus insérer de photos, j’ai réussi sous 2.7, mais au prix de multiples erreurs 500, d’une « vous n’avez pas les droits suffisants pour accéder à cette page » lors de la connection à l’admin et j’en passe.

    Comment expliquer la propagation d’une erreur progressivement sous toutes les versions de WP ?

    Je ne peux pas migrer vers Drupal et Joomla puisqu’ils sont en PHP 5.2 et FREE est en 5.1.3, SPIP et Dotclear ont une communauté si réduite qu’il n’y a pratiquement pas d’extensions disponibles, notamment les antispams ne sont pas dispo…

    #760557
    Li-An
    Participant
    Maître WordPress
    28496 contributions

    À mon avis le serveur sur lequel tu es situé est défectueux ou a des problèmes ou tu le partages avec un site qui pose des problèmes.

    #760558
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Je ne sais pas si WordPress supporte les allers et retours de versions, d’après ce que je lis depuis quelques jours, il y a en eu beaucoup.
    Je pensais préférable d’analyser le problème, je crains que ces downgrade n’aient empiré les choses.
    Est-ce que tu connais quelqu’un ayant un hébergement qui pourrait importer ton site et faire des tests validant une des hypothèses (défaillance de la base de données, défaillance de l’hébergeur ou autre…). L’import/export prend du temps, mais je crois que tu en perds pas mal en ce moment en naviguant un peu à l’aveuglette.

    #760559
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Malheureusement, je ne connais personne qui pourrait faire ces tests.
    J’ai personnellement beaucoup de difficultés à comprendre une erreur qui se propage petit à petit comme un cancer ! Je suis habitué à des erreurs logiques qui intervient après des conditions (If else) ou autres instructions mal programmées, mais là cela défie toute logique !
    Je vais être contraint de tout réinstaller sous WordPress pour ne pas perdre les commentaires, donc au minimum réimoprter les articles et les commentaires, malheureusement, lors d’une importation des articles je vais être contraint de réuploader toutes les images une par une et il y en a plus de 200 : grosse galère.

    Quelle sorte de problème peut avoir la BD ? Si je savais, je regarderais, mais comme je ne sais pas où regarder !

    Merci de t’intéresser à ce problème !

    #760560
    Guy
    Participant
    Maître WordPress
    14817 contributions

    Je pense que la propagation de l’erreur est due aux manipulations sur la base de données en changeant de versions (ce n’est qu’une supposition).
    Je veux bien essayer de t’aider pour les tests, je peux ajouter un site sans probleme dans mon hebergement dans un sous domaine.
    Par contre je ne suis pas du tout au point pour les exports/imports, si quelqu’un peut donner des indications. En gros, est ce que c’est une véritable importation qui modifie les chemins d’acces aux images, à la base de données, etc… ou est ce que c’est juste une copie, que faut il transferer?

    Avant de le faire et pour ne pas faire de bétises, j’aurai besoin d’un bon tuto la dessus.

15 sujets de 46 à 60 (sur un total de 63)
  • Vous devez être connecté pour répondre à ce sujet.