[Résolu] Impossible d’uploader des médias (images) et autres (Créer un compte)

  • Statut : non résolu
15 sujets de 31 à 45 (sur un total de 49)
  • Auteur
    Messages
  • #1049212
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Je me permets de rajouter un autre élément qui me semble lié.

    Je viens d’aller voir dans les outils WP et notamment la page backup et j’ai cette alerte en haut :

    Backup
    WARNING: Your backup directory is NOT writable! We cannot create the backup files.
    You can try to correct this problem by using your FTP client to delete and then re-create the backup directory: /tmp/
    WARNING: Your backup directory is NOT writable!

    Ce qui confirme me semble-t-il qu’il y a bien un problème sur le serveur ! Mais si je veux par exemple essayer de créer ce répertoire /tmp/ je fait comment, et surcout je trouve ça ou sur le ftp ?

    #1049213
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions
    Li-An wrote:
    Il faut que vous contactiez OVH. Le message est clair, ce sont des fonctions php qui ne fonctionnent pas.

    Un problème avec la version de PHP ou un problème de serveur ? (voir mon message juste au dessus).

    J’ai envoyé un message à l’assistance OVH, s’il le faut je téléphone demain (s’ils répondent).

    #1049214
    Li-An
    Modérateur
    Maître WordPress
    24354 contributions

    C’est peut-être lié.

    #1049215
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bon, on va bien voir demain.
    Merci encore et à suivre donc !

    #1049216
    PhiLyon
    Modérateur
    Maître WordPress
    26446 contributions

    Bonsoir.

    Regardes chez OVH les travaux en cours http://travaux.ovh.net/

    Ou alors j’ai trouvé ça ici https://forum.shost.ca/viewtopic.php?f=6&t=3408 à rajouter dans le wp-config.php

    define(‘WP_TEMP_DIR’,’/home/VOTREURL.TLD/tmp’);

    Le problème c’est que ce n’est pas chez OVH et l’arborescence n’est peut-être pas correcte, notamment le home.

    Mais c’est au-dessus de mes compétences, quelqu’un sait sûrement.

    🙂

    #1049217
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Ok ! Pour les travaux chez OVH, j’ai déjà regardé (je fais que ça d’ailleurs :D), mais bon, rien de clair, je ne sais pas exactement ce qu’il faut que je regarde.

    Pour la modif dans le fichier wp-config.php, je vais, pour le moment m’abstenir d’y toucher avant d’avoir d’autres avis.

    Je pense que le VOTREURL.TLD c’est l’adresse du blog (sans le http avant), mais le TLD, sais pas ce que ça peut-être !

    Et puis en effet, pas certain que ça fonctionne avec un hébergement OVH !
    De toute manière, je ne vais pas y passer la nuit !
    Merci à vous, je repasse demain ! Que la nuit vous soit bonne !
    Merci encore.

    #1049218
    PhiLyon
    Modérateur
    Maître WordPress
    26446 contributions

    Le TLD, tous les domaines peut-être.

    Mais tu as raison, attends demain, un ” expert ” sera peut-être passé par là.

    🙂

    #1049219
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    Bonsoir, bonjour,

    TLD = top-level domain
    c’est-à-dire ce qui suit le point d’une adresse web. Pour Sardequin, le TLD est .info
    Explications https://fr.wikipedia.org/wiki/Domaine_de_premier_niveau

    Il faudrait donc adapter le code cité par PhiLyon de cette manière

    define(‘WP_TEMP_DIR’,’/home/joseph-isola.info/tmp’);

    le home étant à peut-être remplacer selon les usages OVH.

    #1049220
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bonjour,

    Je crois que OVH vient de réinventer le courant alternatif ! Un coup ça marche pas, un coup ça remarche, un coup ça marche plus, un coup ça re-fonctionne.

    Donc ce matin, upload de nouveau opérationnel !

    La mise à jour du plugin (qui avait échoué hier soir) est faite, j’ai uploader deux images et un fichier audio, pas de soucis.

    Ce qu’on peut en conclure, c’est que le problème vient forcément du serveur OVH, pas de WordPress. Un problème de version PHP ? En tout cas, ce matin, l’incident semble réglé, mais pour tout dire, je vais quand même laisser mon ticket d’incident ouvert chez OVH, on ne sait jamais.

    Je vais aussi éviter de bidouiller le fichier wp-config.php, mais bon, je garde la ligne de code sous le coude. De toute manière, il faudra, si elle doit servir, l’adapter pour OVH et pour la configuration de mon installation wordpress.

    Merci pour l’écoute !

    À suivre, ce soir en rentrant du boulot, je teste à nouveau.

    #1049221
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Juste pour ajouter une information, j’ai eu un message sur le forum OVH (oui, j’ai pu réussir à y poster un sujet, et j’ai même eu des réponses).

    Bonjour,

    Au vu du message je dirais qu’un autre utilisateur à saturé le /tmp (en ouvrant trop de session, en exécutant un backup de son site via un plugin utilisant le /tmp, …) du coup, celui-ci étant mutualisé il ne vous est pas possible de l’utiliser. Un solution est d’utiliser votre espace client personnel plutôt que le /tmp.

    Cdt,
    Ludovic,
    DevOps @ WebHosting (a.k.a. Mutu)

    #1049222
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    De nouveau en rade depuis midi ! Franchement, ça devient pénible.

    OVH n’a toujours pas répondu à mon ticket d’incident, même si sur le forum ove (oui, miracle, j’ai eu des réponses), des membres de la team OVH ont posté des réponses (voir au dessus) et une demande de précision. On verra bien, en attendant, c’est toujours en rade !
    J’ai contourné le problème, j’ai pu mettre à jour les plugins par ftp et j’ai aussi déniché un plugin qui permet de faire apparaitre les médias uploadés dans la bibliothèque de médias de WP !

    #1049223
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    PAS :résolu: DU TOUT ! :fouet:

    #1049224
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Quelques nouvelles de mon souci d’upload toujours pas résolu.

    OVH a reconnu qu’il y avait un souci au niveau du serveur, et qu’ils avaient pu reproduire le phénomème. Donc, c’est clairement un souci de serveur. Ils essayent de mettre en place un correctif (dans la journée en principe).
    Ce qui est pénible, c’est que la panne est totalement aléatoire. Ce matin tôt, le fonctionnement était parfait, et depuis midi, plus possible d’uploader le moindre média. Et c’est comme ça depuis le début de l’incident.

    #1049225
    Li-An
    Modérateur
    Maître WordPress
    24354 contributions

    La beauté de l’informatique.

    #1049226
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Et la perversité des pannes aléatoires ! :fouet:

15 sujets de 31 à 45 (sur un total de 49)
  • Vous devez être connecté pour répondre à ce sujet.