[Résolu] Important !!! A lire avant de mettre à jour vers WordPress 2.3

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 62)
  • Auteur
    Messages
  • #454187
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Avant tout

    Faites une sauvegarde de vos fichiers et de votre base de données.

    Mise à jour différente

    Cette mise à jour est différente des précèdentes car elle modifie GRANDEMENT le shéma de base de données.
    Ce qui veut dire que beaucoup de plugins auront besoin d’une mise à jour !

    Conclusion: Désactivez tous vos plugins avant de mettre à jour !!!

    Méthode de mise à jour

    – Effacer les anciens fichiers. Important pour cette version !
    Sauf le fichier wp-config.php, .htaccess et le dossier wp-content/

    Attention, si vous avez modifier le thème par défault, il vous faut renommer son dossier (en themeperso par exemple) et éventuellement changer le nom du thème dans le fichier style.css

    – Envoyer les nouveaux fichiers sur votre FTP

    – Connecter sur votre blog à l’adresse de l’admin

    http://monblog.fr/wp-admin/
    Il vous demande de mettre à jour votre base de données
    Faites le.

    Les plugins

    Réactivez les 1 par 1 et vérifier qu’il n’existe pas de mise à jour.

    Par exemple: Google SiteMaps possède une mise à jour dans sa version 3 beta 10 !!!

    Edit: Bien entendu les personnes qui n’écoutent pas nos recommandations et modifie les fichiers propres à WordPress pour arriver à leur fins sont dans l’obligation de réappliquer leur modifications (si elles le sont toujours possible)

    #610160
    SCN
    Membre
    Chevalier WordPress
    265 contributions

    Merci pour l’info, y a seulement le dernier point qui gêne un peu !

    T’as pas une idée sur les fichiers modifiés dans le wp-admin stp ?

    Merci d’avance.

    #610161
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Euh, je dirai 90% des fichiers ont été modifié. Voire plus.

    Les quelques modifications:
    http://trac.wordpress.org/changeset?old_path=tags%2F2.2.3%2Fwp-admin&old=6163&new_path=trunk%2Fwp-admin&new=6163

    Ca va du CSS, aux fonctions jusqu’au vues ^^

    #610162
    julien2k
    Membre
    Initié WordPress
    28 contributions

    Merci pour ces informations 🙂

    #610163
    LinkO
    Membre
    Initié WordPress
    28 contributions

    Remarque Importante

    Si vous utilisez du jQuery dans votre thème, ne charger plus le fichier jquery.js inclus dans le blog à wp-includes/js/jquery/ !

    Cela génère un conflit depuis la mise à jour…

    Télécharger la bibliothèque à http://jquery.com/ , et mettez là dans l’endroit idéale, le dossier de votre thème !

    #610164
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Bah disons qu’on utilise la version 1.1.2
    Et que la dernière jQuery est la 1.2

    Ca pose un problème existentielle ?

    #610165
    Daniel Calin
    Participant
    Initié WordPress
    5 contributions

    Lors du processus de mise à jour, pourtant fait dans les règles, j’ai eu ce message d’erreur (anonymé) :

    Fatal error: mysql_num_fields(): supplied argument is not a valid MySQL result resource in /mnt/147/sda/1/5/mon.nom/wordpress/wp-includes/wp-db.php on line 232

    Fatal error: ob_end_flush() [ref.outcontrol]: failed to delete and flush buffer. No buffer to delete or flush. in /mnt/147/sda/1/5/mon.nom/wordpress/wp-includes/functions.php on line 1416

    J’ai relancé le processus, qui a semblé cette seconde fois aller jusqu’à son terme, sans message d’erreur. J’ai pu alors accéder à mon blog, mais avec un problème : plus d’affichage des liens. A la place, ce message d’erreur (anonymé) :

    Erreur de la base de données de WordPress : [Table ‘ma_base.wp_categories’ doesn’t exist]

    Avec en dessous cette fenêtre :

    SELECT DISTINCT
    cat_name, category_id
    FROM wp_categories
    INNER JOIN
    wp_link2cat ON
    wp_categories.cat_id=wp_link2cat.category_id

    Dans la page d’administration, pourtant, dans le panneau “Blogoliste”, y compris dans “Catégories”, tout semble normal – même quand j’effectue des modifications !

    Ceci, dans ma base SQL, je n’ai effectivement pas de table “wp_categories”.

    Y a-t-il un remède, docteur ?

    ________________________________________________________________________________

    Ah, j’ai trouvé le truc : j’utilise habituellement le très joli thème “Freshy”. Si je repasse sur le thème par défaut, je n’ai plus de problème. Comme il n’y a pas de mise à jour de Freshy, je dois probablement renoncer à ce thème.

    A moins que quelqu’un ait une idée ???

    #610166
    dlo
    Participant
    Maître WordPress
    1852 contributions

    Les tables categories, link2cat et post2cat n’existent plus dans la version 2.3 (cf. post de AmO)

    C’est sûrement un plugin qui fait des siennes. Essaye en les désactivant un par un… et il serait bon de lire un peu la documentation avant de faire des mises à jour !!!! :fouet:

    Cordialement

    #610167
    Daniel Calin
    Participant
    Initié WordPress
    5 contributions

    Waouh, rapide !
    Effectivement, c’est un problème de thème… :(

    #610168
    zoph
    Participant
    Initié WordPress
    3 contributions
    Erreur de la base de données de WordPress : [Table ‘wordpress.wp_post2cat’ doesn’t exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM `wp_posts` p LEFT JOIN `wp_post2cat` pc ON p.ID = pc.post_id LEFT JOIN `wp_categories` c ON pc.category_id = c.cat_ID WHERE post_status = ‘publish’ GROUP BY cat_ID
    
    Erreur de la base de données de WordPress : [Table ‘wordpress.wp_post2cat’ doesn’t exist]
    SELECT cat_ID AS ID, MAX(post_modified) AS last_mod FROM `wp_posts` p LEFT JOIN `wp_post2cat` pc ON p.ID = pc.post_id LEFT JOIN `wp_categories` c ON pc.category_id = c.cat_ID WHERE post_status = ‘publish’ GROUP BY cat_ID
    
    Warning: Cannot modify header information – headers already sent by (output started at /var/www/wp/wp-includes/wp-db.php:161) in /var/www/wp/wp-includes/pluggable.php on line 390

    Salut, j’ai ce message, quand je post un billet ou alors quand j’en modifie un, alors que le post s’ajoute, et se modifient correctement…

    Voilà, merci de votre aide.

    à Bientôt.

    #610169
    dlo
    Participant
    Maître WordPress
    1852 contributions
    zoph wrote:
    Salut, j’ai ce message, quand je post un billet ou alors quand j’en modifie un, alors que le post s’ajoute, et se modifient correctement…

    Non mais, zoph, c’est sûrement une blague ? 😉 La réponse, donnée il y a 10 mn, est deux posts au-dessus du tien !!! 😡

    #610170
    zoph
    Participant
    Initié WordPress
    3 contributions

    Ok, c’est GoogleSiteMaps qui déconne

    #610171
    dlo
    Participant
    Maître WordPress
    1852 contributions

    Tu n’as plus qu’à aller faire un tour ici pour la solution.

    Et qu’on ne t’y reprenne plus à ne pas vérifier avant de migrer ! :fouet:

    Cordialement

    #610172
    Qwindoo
    Modérateur
    Maître WordPress
    2866 contributions

    Whohoho, ça tape dur ici 😋

    #610173
    le pompier
    Membre
    Initié WordPress
    7 contributions

    Salut,

    C’est la premiere fois que je fais une mise à jour de WordPress et il me faut quelques infos :

    -Que ce que le FTP ?

    -Comment désactiver et réactiver les plugins ?

    -Je ne comprend pas quand tu dis il vous demande de mettre à jour ?

    -Je prend quelle partie du cocument que j’ai télécharger ?

    Le pompier

15 sujets de 1 à 15 (sur un total de 62)
  • Vous devez être connecté pour répondre à ce sujet.