[Résolu] Gros problème de cache

Suite à la migration du forum, chaque utilisateur devra lancer une procédure de réinitialisation du mot de passe pour pouvoir se connecter. Merci !

  • Statut : non résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Articles
  • #520931

    Lavie
    Membre
    Initié WordPress
    43 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.5 français
    – Version de PHP/MySQL : Version MySQL5.5.28-cll Version PHP5.3.18
    – Thème utilisé : Leaf
    – Extensions en place : Custom Meta Widget, Easy FancyBox, Velvet Blues Update URLs, WordPress Tinymce visual editor buttons, WP Anti Spam,WP Super Cache
    – Nom de l’hebergeur : GREAT HEBERG
    – Adresse du site : http://pech.great-heberg.eu/wordpress/

    Problème(s) rencontré(s) :
    Je n’arrive pas à avoir un « refresh » immédiat en travaillant sur le site. J’ai fait une pause de quelques semaines, mais il me semble que je n’avais pas ce problème auparavant.

    Par exemple, j’ai installé un plug-in « média sociaux », et puis ça ne me convient pas. J’ai beau par la suite vider la cache des navigateurs, désactiver/supprimer le plug-in etc. ce dernier continue à apparaître. Du coup, c’est impossible de travailler… Est-ce que ça peut-être un problème au niveau de l’hébergement ?

    #880541

    Lavie
    Membre
    Initié WordPress
    43 contributions

    P.S la mise-à-jour finit toujours pas se faire, mais ça prends environ 30 minutes à chaque fois

    #880542

    Lavie
    Membre
    Initié WordPress
    43 contributions

    Ça semble aléatoire et avant tout lié à Chrome… rien n’y fait, même après une heure la cache reste en place. Je vais passer à Firefox le temps que ça soit corrigé…

    #880543

    Lavie
    Membre
    Initié WordPress
    43 contributions

    Pareil sur Firefox, ça semble aléatoire. Donc j’imagine que c’est lié à l’hébergement ? (bien que je ne vois pas du tout pourquoi)… Je devais changer d’hébergeur de toute façon, je confirmerai si ça règle le problème.

    #880544

    Olivier C
    Participant
    Chevalier WordPress
    412 contributions

    Bonsoir,

    Cela provient sans doute de l’extension WP Super Cache (je l’utilise aussi).

    Une simple désactivation du plugin ne suffit pas, il faut auparavant détruire les pages mises en cache (option disponible dans l’admin à partir de l’onglet du plugin).

    #880545

    Lavie
    Membre
    Initié WordPress
    43 contributions

    Salut ! merci pour ta réponse.

    Il me semble avoir vidé la cache avant d’avoir désactivé… et je viens de refaire l’opération (c’est-à-dire réactiver le plug-in, supprimer la cache et désactiver le plug-in à nouveau) sans résultat sous Chrome (après F5 et Ctrl-F5 et vidage de cache via les options) et pourtant la mise-à-jour s’est fait sous Firefox.

    Par contre, je viens de tester une modification sur un article et pas de problème. On dirait que ça concerne davantage les modifications sur les « plug-in »… ou par exemple hier ça a prit un bon 2 heures avant de voir une modification mineure sur un fichier de traduction .PO…. et je tournais en rond sans comprendre pourquoi ça ne fonctionnait pas.

    En sommes, je suis rassuré de voir que les articles (c’est-à-dire les futurs utilisateurs) ne sont pas concernés par ce problème…

    Je vais quand même garder un oeil du côté de WP Super Cache. Est-ce que tu le désactives systématiquement pour travailler sur ton site, ou tu vides la cache en cas de problème ?

    #880546

    Lavie
    Membre
    Initié WordPress
    43 contributions

    P.S. Je viens de regarder un peu ton site en lien. J’aime bien la présentation et le « slider » me paraît mieux que celui de « Leaf ». Quel thème est utilisé (si ce n’est pas indiscret) ?

    #880547

    Lavie
    Membre
    Initié WordPress
    43 contributions

    Bonjour !

    Le problème est résolu, ça venait effectivement WP Super Cache… Désactiver non pas le plug-in ne suffit pas, il faut désactiver la cache à partir des options du plug-in (c’est plutôt idiot – en tout cas pas du tout intuitif -mais enfin…)

    P.S. Je vois que certain message ont été marqué comme [résolu], mais je ne vois pas comment on peut éditer nos messages ?

    #880548

    Lavie
    Membre
    Initié WordPress
    43 contributions

    . Désactiver non pas le plug-in ne suffit pas, il faut désactiver la cache à partir des options du plug-in (c’est plutôt idiot – en tout cas pas du tout intuitif -mais enfin…)

    Petite précision : supprimer la cache dans les options de « WP Super Cache » ne suffit pas non plus, il faut vraiment et supprimer la cache et désactiver la cache.

    #880549

    Olivier C
    Participant
    Chevalier WordPress
    412 contributions
    Lavie wrote:
    P.S. Je viens de regarder un peu ton site en lien. J’aime bien la présentation et le « slider » me paraît mieux que celui de « Leaf ». Quel thème est utilisé (si ce n’est pas indiscret) ?

    J’ai codé mon thème moi même, le slider aussi (je n’utilise aucun plugins à part « WP Super Cache » et « Google XML Sitemaps »). Je l’ai entièrement codé à partir de zéro, mais j’ai quelques heures de travail derrière moi…

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.