[Résolu] Flux RSS qui ne se met pas à jour sur les agrégateurs (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #544042
    LouDB
    Participant
    Initié WordPress
    40 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.0
    – Version de PHP/MySQL : 5.4.30 / 5.1.73
    – Thème utilisé : Thème perso
    – Extensions en place : Akismet, Cookie Notice, Hellocoton, List category posts, Simple Share Buttons Adder, WordPress Related Posts, SEO WordPress (Yoast)
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.notuxedo.com

    Problème(s) rencontré(s) :

    Hello tout le monde,

    Je m’arrache les cheveux sur un problème de flux RSS… Mon flux est valide mais les adresses de type example.com/feed/ ont brutalement arrêté de fonctionner sur les agrégateurs externes type Feedburner, Feedbucket & co.

    J’ai déjà essayé à peu près tout ce qui m’est passé par la tête :
    – désactivation de tous les plugins
    – remettre un thème WordPress natif
    – vider le htaccess
    – refaire la dernière mise à jour de WordPress
    – nettoyer la BDD (options obsolètes, etc)
    – reping & resync des feeds sur Feedburner
    – modifier wp_feed_cache_transient_lifetime dans les functions
    – vider le cache de mon navigateur
    – utiliser le flux Atom au lieu du flux RSS

    Je n’ai pas de plugin de cache WordPress. Je viens de trouver une piste de solution après 2 jours de troubleshooting : j’ai enfin pu mettre à jour Feedburner mais en utilisant l’adresse de flux example.com/feed/?format=xml au lieu de “example.com/feed/” tout court.

    A votre avis, à quoi est dû ce problème ? Pourquoi “/feed/” tout court ne marche plus d’un seul coup ? Et surtout, dois-je forcer la redirection de l’un vers l’autre ?

    Merci d’avance !

    #981844
    Anonyme
    Invité
    Maître WordPress
    34104 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #981845
    LouDB
    Participant
    Initié WordPress
    40 contributions

    Non le lien d’origine ne se met toujours pas à jour sur Feedburner, seul le lien avec ?format=xml fonctionne désormais… et j’ai entre temps quitté OVH pour Nuxit 🙂

    #981846
    Anonyme
    Invité
    Maître WordPress
    34104 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #981847
    LouDB
    Participant
    Initié WordPress
    40 contributions

    En fait le flux lui-même a toujours fonctionné parfaitement… mais utiliser l’adresse notuxedo.com/feed dans Feedburner ne fonctionnait pas, même en faisant un ping/resync du feed. Il n’affichait pas les derniers posts. J’ai donc enregistré l’adresse notuxedo.com/feed/?format=xml dans Feedburner et depuis, tout fonctionne, idem sur d’autres agrégateurs.

    Je n’ai aucune redirection du flux en place. Au moins deux autres utilisateurs de WordPress m’ont signalé le même problème au même moment, à savoir :
    – aucun changement majeur apporté à leur blog.
    – flux qui arrête subitement d’être mis à jour sur les agrégateurs externes tout en restant valide et à jour sur l’adresse example.com/feed/

    Difficile de savoir à quoi c’est dû… et je me demande si je dois mettre en place une redirection 301 de “notuxedo.com/feed” à “notuxedo.com/feed/?format=xml”… dans le sens où si quelqu’un essaie de récupérer le flux directement, l’adresse notuxedo.com/feed/ risque de ne pas se mettre à jour comme il faut.

    #981848
    Anonyme
    Invité
    Maître WordPress
    34104 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #981849
    LouDB
    Participant
    Initié WordPress
    40 contributions

    Dans ce cas, je vais mettre en place cette redirection, comme ça pas de risque que les uns entrent l’adresse /feed/ et les autres l’adresse Feedburner 🙂

    En fait, avant je n’utilisais pas Feedburner, juste le flux de base. C’est quand on m’a signalé qu’il ne se mettait plus à jour sur les agrégateurs que j’ai commencé à utiliser Feedburner pour tester 🙂 Je vais donc rester sur cette solution ! Merci beaucoup !

    #981850
    LouDB
    Participant
    Initié WordPress
    40 contributions

    Update : la redirection via htaccess ci-dessus ne marchait pas… mais j’ai réussi à rediriger via cette fonction : http://www.gabfirethemes.com/how-to-redirect-wordpress-rss-feed-feedburner-without-plugin/

    Tout marche à merveille 🙂 Voilà un week-end qui commence bien ^^

    #981851
    Anonyme
    Invité
    Maître WordPress
    34104 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #981852
    LouDB
    Participant
    Initié WordPress
    40 contributions

    J’ai ajouté le code à mon htaccess et ça ne redirigeait pas le flux.

    #981853
    Anonyme
    Invité
    Maître WordPress
    34104 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #981854
    Anonyme
    Invité
    Maître WordPress
    34104 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

    #981855
    LouDB
    Participant
    Initié WordPress
    40 contributions

    Et voilà !

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.