[Résolu] Erreur de syntaxe php dans header.php (origami theme) (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #513386
    ISIS
    Participant
    Initié WordPress
    29 contributions

    Bonjour,

    – Ma configuration WP actuelle : site
    – WordPress : 3.4.1.
    – Version de PHP/MySQL : PhpMyAdmin 3.4.9
    – Thème : Origami
    – Extensions en place : WP Super Cache ; DB Cache Reloaded Fix ; Akismet
    – Nom de l’hébergeur : OVH
    – Adresse du site : http://www.emeliegilson.com

    Problème(s) rencontré(s) :
    Bonjour,

    Je suis encore débutante pour le php, et je me retrouve face à une erreur de syntaxe que je n’arrive pas à résoudre sur mon éditeur de theme, impossible pour moi de comprend d’où ça vient. Je sollicite votre aide si vous le pouvez, ce serait avec un grand merci.

    Quand je veux accéder à mon site, c’est affiché : Parse error: syntax error, unexpected ‘:’ in /homez.398/emeliegi/www/wp-content/themes/origami/header.php on line 24

    Je mets le code de la partie concernée en dessous.
    Merci, vraiment

    23 24 if (get_header_image)
    25 { http:// emeliegilson.com /wp-admin/theme-editor.php?file=header.php&theme=origami}
    26 ?>

    Merci

    #849040
    Theme wordpress francais
    Membre
    Maître WordPress
    687 contributions

    Bonjour, pourquoi as tu changer le code d’origine ?

    #849041
    ISIS
    Participant
    Initié WordPress
    29 contributions

    Justement le problème est là je n’y ai pas touché! je voulais juste intégrer une image favicon qui doit se situer entre les balises finalement ça n’a pas marché et j’ai enlevé mon code, et là est apparu ce problème qui est situé après le balise 😕
    Je pense que le problème vient de get_header_image car on m’a dit que ce n’était pas du php mais je ne sais pas par quoi la remplacer… Pouvez-vous m’aider?

    #849042
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Le problème vient de votre ligne 25 le http:// n’est pas une instruction PHP, or les : de ce http:// sont des caractères réservés en PHP, d’où l’affichage de l’erreur !

    Il n’est pas possible qu’un thème présente ce code, vous l’avez forcement modifié.

    #849043
    Theme wordpress francais
    Membre
    Maître WordPress
    687 contributions

    Je ne sais pas trop ce qui te reste du code mais voici le code d’origine pour la partie « logo »

    <div id="logo">
    <a href=" » title= » » class= »logo-link »>
    <img src=" » height= »height; ?> » width= »width; ?> » alt= » » />
    <h1 class="logo"></h1><br />
    <h3 class="logo"></h3>

    </a>

    </div>

    Pour ta favicon …

    <link rel="icon" type="image/png" href="/favicon.ico » />

    A mettre après <meta name="viewport ….. (vers la ligne 6)

    #849044
    ISIS
    Participant
    Initié WordPress
    29 contributions

    Dans ce cas, je retire entièrement la ligne ? Je vous promet que je n’ai pas touché cette ligne. Et pourquoi l’erreur m’indique la ligne 24 et non la 25 ?

    #849045
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Parce que l’instruction IF débute ligne 24 et termine à la 25

    #849046
    ISIS
    Participant
    Initié WordPress
    29 contributions

    Merci beaucoup pour vos conseils !! j’ai recopié le code originel, et tout remarche, ouf! c’est bizarre qu’une erreur se soit glissé comme ça, enfin merci beaucoup 🙂

    #849047
    Theme wordpress francais
    Membre
    Maître WordPress
    687 contributions

    Pas de probleme…

    #849048
    LaurieComci
    Membre
    Initié WordPress
    1 contributions

    Bonjour j’ai le même problème, mon site affiche ceci :

    Parse error: syntax error, unexpected ‘?’ in /homepages/8/d444606895/htdocs/wp-content/themes/mono/header.php on line 96

    et mes codes ressemble actuellement à ca :

    // Grab custom settings
    global $cudazi_theme_options;
    $logo_upload = cudazi_get_option( get_option_tree(‘logo_upload’, $cudazi_theme_options, false, false ), get_template_directory_uri() . ‘/images/logo.png’, false );
    $logo_url = cudazi_get_option( get_option_tree(‘logo_url’, $cudazi_theme_options, false, false ),  », false );
    $logo_text_based = cudazi_get_option( get_option_tree(‘logo_text_based’, $cudazi_theme_options, false, false ),  », false );

    // $disable_header_search = cudazi_get_option( get_option_tree(‘disable_header_search’, $cudazi_theme_options, false, false ),  », false );
    ?>




    <html xmlns="http://www.w3.org/1999/xhtml&quot; > <!–



    <meta http-equiv="Content-Type" content="text/html; charset= » />


    <link type="text/css" rel="stylesheet" href="/css/screen.css » media= »screen » />

    <link rel="stylesheet" type="text/css" media="all" href=" » />

    <?php
    // Load Javascript
    if ( is_singular() && get_option( ‘thread_comments’ ) ) { wp_enqueue_script( ‘comment-reply’ ); }
    wp_enqueue_script(« jquery »);
    wp_enqueue_script(« slides », get_template_directory_uri() . « /js/libs/slides.min.jquery.js »);
    wp_enqueue_script(« superfish », get_template_directory_uri() . « /js/libs/superfish-combined.js »);
    wp_enqueue_script(« cudazi_general », get_template_directory_uri() . « /js/script.js »);
    wp_head(); // do not remove this
    ?>


    <link type="text/css" rel="shortcut icon" href="/favicon.gif » />
    <link type="text/css" rel="apple-touch-icon" href="/apple-touch-icon.png » />

    <body >


    <?php if ( is_active_sidebar( 'body-top' ) ) { dynamic_sidebar( 'body-top' ); } ?

    Est-ce possible de retrouver les codes d’origines svp???

    #849049
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions

    Bonjour,

    ton problème n’a sans doute rien à voir
    Merci de créer ton propre fil, de mettre le code dans la balise code (le C noir) pour qu’il soit lisible

    #849051
    idiotinfo
    Membre
    Initié WordPress
    1 contributions

    Bonjour,
    c’est mon premier message sur ce forum. J’ai un gros problème avec le thème Twenty Thirteen, et notamment les sous-menus et sous-sous-menus qui ne s’affichent pas sur tablette et smartphone… Est-ce normal ou ai-je fait une mauvaise manip’ ? Est-ce que quelqu’un a une idée pourquoi ce thème par défaut de wordpress ne serait pas responsive !!!
    Merci de m’aider, car sinon je trouve ce thème pas mal du tout… même que je m’y fait très bien et que je ne me vois pas du tout changer, mais alors pas du tout. Ma question est donc de la plus haute importance…

    #849050
    Lumiere de Lune
    Participant
    Maître WordPress
    20531 contributions

    Bonjour, merci de lire le message juste au dessus du votre

13 sujets de 1 à 13 (sur un total de 13)
  • Le sujet ‘[Résolu] Erreur de syntaxe php dans header.php (origami theme)’ est fermé à de nouvelles réponses.