[Résolu] Erreur 404 sur articles quand les permaliens réglés sur “Nom article”

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #559128
    spip93
    Participant
    Padawan WordPress
    53 contributions

    Bonjour à tous et à toutes,

    Ma configuration WP actuelle
    – Version de WordPress : 4.4.1
    – Version de PHP/MySQL : 5.5.12
    – Thème utilisé : Explicit
    – Extensions en place :
    – Avanced Custom Fields pro
    – Akismet
    – CodeStyling Localization
    – Contact Form 7
    – Custom Post Type UI
    – Latest Custom Post Type Updates
    – Recent Posts Widget Extended
    – Table of contents plus
    – UserPro
    – WP Export Categories and Taxonomies
    – WP-Utilisateur-Avatar
    – Nom de l’hebergeur : Aucun, c’est en local

    Problème(s) rencontré(s) :

    Bonjour à tous et à toutes,

    Comme indiqué ci-dessus, je développe un site en local avec le thème WordPress Explicit.
    J’ai un souci avec les permaliens :
    Lorsque, dans les Options de permaliens je mets Nom de l’article, j’ai une erreur 404 quand je veux afficher mes articles.
    En revanche, quand je mets Simple (toujours dans dans les Options de permaliens) je peux à nouveau afficher mes articles.

    Savez-vous pourquoi et surtout ce qu’il faut faire pour que je puisse afficher mes articles avec l’option Nom de l’article ?

    D’avance merci.
    Bonne journée à vous.

    #1041895
    Flobogo
    Modérateur
    Maître WordPress
    15866 contributions

    Bonjour,

    Vous parlez de l’affichage d’Articles ou de Custom Posts Types ?

    #1041896
    spip93
    Participant
    Padawan WordPress
    53 contributions

    L’affichage d’articles. Mais, c’est vrai que je n’ai pas testé avec mes types contenus personnalisés.

    #1041897
    spip93
    Participant
    Padawan WordPress
    53 contributions

    Je viens de désactiver les modules :
    – Custom Post Type UI
    – Latest Custom Post Type Updates
    – Recent Posts Widget Extended

    Mais ça ne fonctionne toujours pas. J’ai toujours Erreur 404 quand je veux afficher mes articles.

    #1041898
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    Et vous avez bien activé le mod rewrite dans votre installation ?

    #1041899
    spip93
    Participant
    Padawan WordPress
    53 contributions

    Je ne sais pas, je ne sais plus 🙂
    Où on l’active/désactive SVP ?

    #1041900
    PhiLyon
    Modérateur
    Maître WordPress
    24147 contributions
    #1041901
    spip93
    Participant
    Padawan WordPress
    53 contributions

    C’est bon, je viens de trouver la solution !!:D
    J’ai cliqué sur WampServer (comme je suis en local) > Apache > Modules Apache et j’ai coché Rewrite_module

    Merci Lumière de Lune de m’avoir mis sur la voie 👏

    #1041902
    spip93
    Participant
    Padawan WordPress
    53 contributions

    J’oubliais de préciser qu’après avoir coché Rewrite_module, WampServer avait redémarré et qu’ensuite j’étais allé dans le Tableau de bord de WordPress > Réglages > Permaliens et que j’ai remis Nom de l’article.
    J’espère que ça aidera d’autres personnes dans mon cas. 🙂

    #1041903
    Lumiere de Lune
    Participant
    Maître WordPress
    19385 contributions

    :D

    #1041904
    Flobogo
    Modérateur
    Maître WordPress
    15866 contributions

    Mais c’est … bon sang, mais c’est bien sûr ! WAMP est le coupable ! :fouet:

    @ Spip93 : vous aviez bien précisé que vous étiez en local, mais pas que c’était avec WAMP.
    Et comme en ce moment je suis branchée “Custom Post Type”, je me suis laissée prendre à votre liste de plugins en pensant que le coupable était caché là …

    WAMP fonctionne (presque) impeccablement, dommage que le rewrite_module ne soit pas activé automatiquement dès l’installation. C’est quelque chose qui m’échappe … :rolleyes:

    #1041905
    spip93
    Participant
    Padawan WordPress
    53 contributions

    Désolé si je sors du sujet, mais comme il est résolu…:hs:

    @Flobogo : Puisqu’en ce moment vous êtes branchée “Custom Post Type”, est-ce que vous auriez un plugin qui affiche, en page d’accueil, dans la partie centrale (pas en barre latérale) genre “les contenus personnalisés les mieux notés“, “les contenus personnalisés de telle catégorie“, “les 10 derniers contenus personnalisés“… ?
    Je m’explique : J’ai créé un contenu personnalisé, mais je n’arrive pas à les mettre en page d’accueil comme les articles. J’ai trouvé comment les mettre en barre latérale sous forme de texte et même d’images, mais pas en partie centrale de la page d’accueil.
    J’ai la possibilité, avec le thème installé, de construire ma page (avec un page builder) sous forme de “shortcodes” qui va m’afficher “les articles de telle catégorie”, “les 10 articles personnalisés”, “les articles les mieux notés”…
    Mais comme ce sont les articles qui sont privilégiés (normal), je me suis dit que j’allais mettre les mains dans le cambouis, modifier le code et remplacer “post(s)” par mon contenu personnalisé. “Je me suis juste dit”, parce que… :rolleyes: mes connaissances en programmation sont assez limitées et que je n’ai pas trouvé où remplacer le code.:(
    Du coup…, bah j’ai changé mon fusil d’épaule et j’ai transformé/transféré mes contenus personnalisés en articles. Ça me convient moyen parce que finalement, c’est par dépit que je l’ai fait.:(
    D’où ma question : est-ce que vous avez un plugin qui fasse genre un page builder mais avec des contenus personnalisés ou quelque chose s’en approchant ?

    P.S : (Absolument rien à voir) :hs: : Y’a pas moyen de modifier les messages qu’on a posté sur ce forum ?!! Si non, c’est vraiment mal foutu:fouet:

    #1041906
    Flobogo
    Modérateur
    Maître WordPress
    15866 contributions

    Oui, je suis branchée “Custom Post Type”, mais en (essayant) de coder moi-même. J’ai passé l’étape création du CPT, affichage dans un template dédié, j’en suis aux “catégories spécifiques” (Custom Taxonomy) …

    Mais n’ayant pas le même besoin que vous, non, je ne connais pas de plugin permettant de faire ce que vous souhaitez. :(
    Votre plugin”Latest Custom Post Type Updates” ne peut pas faire ce genre d’affichage ?
    Il faudrait chercher des plugins similaires à celui-là …

    Sinon, si vous avez réussi à les mettre en colonnes latérales, il “suffit” de mettre les mains dans le code de la page d’accueil pour y créer une sidebar (zone de widgets) qu’on peut très bien appeler à la suite (ou avant) le reste du contenu.
    Allez voir ma page d’accueil, les 2 grandes zones, puis les 3 en-dessous sont des zones de widgets.

    Mais le mieux serait d’ouvrir un nouveau topic, car en effet, celui-ci est résolu et surtout n’a rien à voir.
    Un sujet par topic, cela facilite les futures recherches de ceux qui auraient le même problème (erreur 404)

    Et non, on ne peut pas éditer nos messages (seuls les modérateurs le peuvent), car il y a des abus de personnes effaçant leurs messages une fois qu’ils avaient la réponse à leur problème … ce qui n’est vraiment pas cool sur un forum de partage de connaissances.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.