[Résolu] Erreur 404 après mise à jour manuelle (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #548005
    bcroezeen
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle :

    – Version de WordPress : 4.1.1
    – Version de PHP/MySQL : 5.5.12-2ubuntu4.2 /
    – Thème utilisé : basketball scoreboard and shoe spj004
    – Extensions en place : Akismet (3.0.4), Daily Cleaner & Optimizer Lite (1.2), Disqus Comment System (2.84), Event Organiser (2.12.1), Facebook Like Box (2.7), Forum_wordpress_fr (3.9), Jetpack by WordPress.com (3.3.2), LeagueManager (3.9.1.1), Manage BasketClub (1.2), mPress Image Refresh (0.3), WordPress SEO (1.7.3.3), WP-Memory-Usage (1.2.2), YOP Poll (5.6)
    – Adresse du site : http://bcroezeen.olympe.in
    – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

    Tout d’abord j’ai voulu faire la MAJ wordpress 4.1 vers 4.1.1 en automatique (comme d’habitude) mais j’avais un échec à chaque tentative (100% sure que ça vient de mon hébergeur )
    Donc je décide de la faire manuellement, visiblement aucun soucis sauf que depuis j’ai un problème de page 404 sur mes articles mais ils apparaissent bien sur l’index.

    De plus je ne peux pas les modifier également, dans le panneau admin quand je clic sur modifier sur un article ça me renvoi sur une page avec comme message : Erreur 404 – Aucun fichier trouvé.

    Complément d’information :
    je suis en permaliens
    et j’ai ajouté ça dans mon .htaccess (bien avant le problème)


    order allow,deny
    deny from all

    # BEGIN WordPress

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]


    # END WordPress

    Voilà n’hésiter pas à me poser d’autres questions qui pourrait m’aider à résoudre mon problème

    #998288
    noixdecoco
    Participant
    Chevalier WordPress
    279 contributions

    Bonjour,
    Enlève

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    sauvegarde
    réessaie

    #998289
    bcroezeen
    Participant
    Initié WordPress
    6 contributions

    Bonjour,
    c’est pire mais je m’en doutais vue que sans ce morceaux de code je ne peux pas faire le permalien.

    Merci quand même 😉

    #998290
    noixdecoco
    Participant
    Chevalier WordPress
    279 contributions

    Ha, bien… Je n’ai pas de fichiers .htaccess et mes permaliens fonctionnent !
    Tant pis

    #998286
    bcroezeen
    Participant
    Initié WordPress
    6 contributions

    Merci quand même.

    Je viens de faire un test :
    crée un brouillon puis ensuite le supprimer, jusque là cela fonctionne.
    Mais quand je veux restaurer le brouillon de la poubelle vers mes articles j’ai de nouveau « pas non trouvé »

    donc visiblement, les permaliens peuvent être écarté.

    Ce qui est chiant, c’est qu’il n’y a pas de message d’erreur ou de fichier error log qui se créent donc pas facile de trouver pour un débutant en WP.

    note : je viens de vérifier sur mon FTP : tout les fichiers ont bien été écrasés.

    Personne n’a une piste ? c’est pas arrivé à quelqu’un lors d’une mise à jour manuelle ? J’ai oublié une étape lors de la mise à jour manuelle ?

    #998287
    mathieu789
    Participant
    Maître WordPress
    1082 contributions

    je viens d’essayer les liens du menu et de la page d’accueil et je n’ai pas trouvé de problème
    quel URL pose problème ?

    #998285
    bcroezeen
    Participant
    Initié WordPress
    6 contributions

    Bonjour,

    le problème intervient sur la partie administration.

    je ne peux pas éditer un article ou restaurer un article ça m’envoi sur cette page :

    http://bcroezeen.olympe.in/wp-admin/post.php?post=376&action=edit

    comme si je n’avais pas l’autorisation de l’éditer.
    (ps : j’ai bien accès au panel admin )

    #998284
    bcroezeen
    Participant
    Initié WordPress
    6 contributions

    Info complémentaire (vu qu’on peut pas éditer ses messages)

    J’ai desactivé tout mes extensions et j’ai mis un thème par défaut, et le problème persiste, une idée SVP ???

    #998283
    mathieu789
    Participant
    Maître WordPress
    1082 contributions

    est ce que le fichier post.php existe bien dans répertoire « wp-admin » ?

    #998282
    bcroezeen
    Participant
    Initié WordPress
    6 contributions

    Non, bien vue !!!

    Un grand Merci !!!

    #2468894
    Damo Dembele
    Participant
    Initié WordPress
    1 contributions

    Apres la mise a jour de version php de mon site wordpress. Toutes mes pages retournent des erreurs 404 not found. et il y’a ces erreurs qui continuent de s’afficher
    <b>Notice</b>: WP_Block_Type_Registry::register est appelée de la mauvaise manière. Les noms de types de bloc doivent contenir un préfixe d’espace de nom. Exemple : mon-extension/mon-bloc-personnalise Veuillez lire Débogage dans WordPress (en) pour plus d’informations. (Ce message a été ajouté à la version 5.0.0.) in <b>/var/www/vhosts/eurosecurite.ravendt.net/httpdocs/wp-includes/functions.php</b> on line <b>5231</b>

     

    <b>Warning</b>: Undefined property: stdClass::$plugin in <b>/var/www/vhosts/eurosecurite.ravendt.net/httpdocs/wp-includes/class-wp-list-util.php</b> on line <b>159</b>

    <b>Warning</b>: Undefined property: stdClass::$plugin in <b>/var/www/vhosts/eurosecurite.ravendt.net/httpdocs/wp-includes/class-wp-list-util.php</b> on line <b>159</b>

    #2468934
    Lucass
    Participant
    Chevalier WordPress
    398 contributions

    Bonjour,
    WP 4.1.1 date de 2015.
    – Faire une sauvegarde du site.
    – Mettre à jour les extensions.
    – Désactiver les extensions.
    – Mettre un thème de WP par défaut.
    – Faire la mise à jour de WP.

    #2468968
    Flobogo
    Modérateur
    Maître WordPress
    20116 contributions

    Bonjour,


    @lucass
    : c’est le topic qui date de 2015 ! Il était résolu, et @damo-dembele l’a fait remonter … Il faut tout lire avant de répondre.


    @damo-dembele
    : comme vous le voyez, inutile de remonter un vieux topic, qui concerne une mise à jour de WordPress d’une vieille version, alors que vous, vous parlez d’une mise à jour PHP. Merci d’ouvrir votre propre topic, en détaillant votre configuration, si vous voulez avoir des réponses adaptées.

    Je clôture ici, puisque ce topic était résolu en 2015.

13 sujets de 1 à 13 (sur un total de 13)
  • Le sujet ‘[Résolu] Erreur 404 après mise à jour manuelle’ est fermé à de nouvelles réponses.