[Résolu] Enlever “index.php” dans les permaliens

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 16)
  • Auteur
    Messages
  • #467540
    Damienfr
    Participant
    Initié WordPress
    34 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.7.1
    – Thème utilisé : Vector Lover
    – Plugins en place :
    – Nom de l’hebergeur : Niloo
    – Adresse du site : [url=”http://www.e-life.niloo.fr
    “]http://www.e-life.niloo.fr[/url]
    Problème(s) rencontré(s) :

    Salut à tous,

    J’ai installé mon blog wordpress dernièrement sous l’hébergeur Niloo, j’ai activé les permaliens en structure personnalisé, mais wordpress m’a rajouté dans ces permaliens un “/index.php/”, j’ai contacté l’administrateur du site pour savoir si y’avais pas un blocage (comme sur Free) de son serveur, il m’a répondue que non.

    J’aimerais savoir comment enlever ce “index.php” dans les permaliens mais sans engendrer d’erreur 500 comme il arrive souvent

    Sur ce,

    Bonne soirée,

    A+

    #662396
    Environnement-France
    Participant
    Maître WordPress
    1115 contributions

    Tu as mis quoi dans permalien?

    #662397
    Damienfr
    Participant
    Initié WordPress
    34 contributions

    Mes permaliens sont en “date et titre : /index.php/%year%/%monthnum%/%day%/%postname%/”

    #662398
    Environnement-France
    Participant
    Maître WordPress
    1115 contributions
    Damienfr wrote:
    Mes permaliens sont en “date et titre : /index.php/%year%/%monthnum%/%day%/%postname%/”

    Tu as ta réponse!

    Tu vas dans perso et met :

    /%year%/%monthnum%/%day%/%postname%/

    😉

    #662399
    jeanmichel
    Membre
    Chevalier WordPress
    145 contributions

    Ah, c’est donc ça !
    Je suis chez free et je viens de changer la structure des permaliens de “défaut” à “numérisé”.
    Maintenant, j’ai erreur 500.
    Je ne sais même pas comment je vais faire pour revenir en arrière si je ne peux plus accéder à mon site.

    Est-ce que ce changement est consigné dans un php de wp-admin ? Si oui, lequel ?
    Dans ce cas, je pourrais faire la modif en dur directement sur mon serveur.

    Au secours !

    EDIT : Bon, on ne s’affole pas, jm. Je suis en train de lire l’article sur cette erreur récurrente chez Free. Je viens de supprimer htaccess. Voyons la suite.

    Oups, je n’avais pas vu que tu avais répondu, Environnement France.

    #662400
    Environnement-France
    Participant
    Maître WordPress
    1115 contributions
    #662401
    jeanmichel
    Membre
    Chevalier WordPress
    145 contributions

    Le problème, c’est que je fais bien les changements préconisés, avec /index/php et le reste. Mais dès que je veux valider, pof, ça recommence. Et le fichier htaccess repousse tout seul.

    Bon, ben, rien n’y fait. L’erreur revient toujours, le fichier htaccess renaît chaque fois de ses cendres, tel le Phoenix. Me reste plus qu’à tout réinstaller et repartir de zéro. :(

    Je vais quand même essayer l’astuce n°2 en passant par la BD, mais j’en ai pour un moment car je ne sais même pas où elle est.
    En plus, je suis sûr que le résultat sera le même.

    Bon, ben, je vais commencer à copier-coller tous mes articles.

    #662402
    jeanmichel
    Membre
    Chevalier WordPress
    145 contributions

    Bon, finalement, je suis passé par la base de données, y’avait pas moyen, autrement.
    J’ai remis les valeurs par défaut dans la BD
    Et seulement alors, j’ai rajouté /index.php en option personnalisée.

    Je touche du bois, ça a l’air de marcher.

    En tous cas, la solution (tranquillou) de passer par l’interface ne semble pas marcher pour tout le monde.
    Enfin, ça m’a donné l’occasion de faire connaissance avec ma base de données.

    #662403
    Damienfr
    Participant
    Initié WordPress
    34 contributions

    Merci de flooder mon post pour partir vers un autre problème et merci beaucoup au modérateur d’avoir mis mon post en [résolu] alors que JE n’ai même pas résolu mon problème.

    @JeanMichel : Ton problème est un autre problème, je n’ai aucune erreur 500 en changeant les permalien car je ne suis pas chez Free, si tu avait un problème, merci de faire un nouveau post.

    Pour revenir à MON problème, j’ai tenter de changer la structure des permaliens…et je me retrouve avec une jolie erreur 404 sur les pages des articles (pas sur le home).

    Un détail me choque, dans mon administration WordPress, dans la partie “permalien”, j’ai :

    Valeur par défaut	http://e-life.niloo.fr/?p=123
    Date et titre	http://e-life.niloo.fr/index.php/2009/02/22/sample-post/
    Mois et titre	http://e-life.niloo.fr/index.php/2009/02/sample-post/
    Numérique	http://e-life.niloo.fr/index.php/archives/123
    Structure personnalisée

    L’index.php est présent même dans les structure les plus courante, alors que d’habitude il n’y ait pas.

    D’ou cela peut venir d’après vous ?

    #662404
    jeanmichel
    Membre
    Chevalier WordPress
    145 contributions

    😳
    Désolé, Damien, c’est une malheureuse confusion de ma part. Au moment où j’ai lu ton premier post, j’étais en train de consulter tous les posts et tous les articles consacrés au problème dont j’ai parlé (permaliens-free-erreur 500).
    Du coup, la fatigue aidant, j’ai fait l’amalgame entre les deux, sans vérifier qui était ton hébergeur.

    Donc, en effet, ton problème est totalement différent et n’est pas résolu.

    Pour y revenir, quand tu dis “d’habitude, il n’y est pas”, tu veux dire y compris dans 2.7.1 ?
    (je pense à la possibilité que ce soit une nouveauté de cette version que je ne connais pas encore).

    #662405
    Damienfr
    Participant
    Initié WordPress
    34 contributions

    Ce n’est pas grave JM 😉, c’est surtout que le post est passé en [résolu] alors qu’il n’est pas résolu.

    Je dit d’habitude, car sur une autre configuration de mon blog sur un autre hébergeur je n’ai pas de choix avec “index.php” sur les permaliens.

    Pas de nouveauté de cette version, enfin je ne pense pas.

    [EDIT] Un ami à moi à le même problème :http://twitpic.com/1mnva il est sur le même hébergeur que moi aussi

    #662406
    jeanmichel
    Membre
    Chevalier WordPress
    145 contributions

    Ecoute, je ne suis sûr de rien, vu que je début et que je manque de connaissances en php.

    En tous cas, voilà
    Dans mon fichier wp-admin/options_permalinks.php, il y a cette portion de code

    if ( ! got_mod_rewrite() )
    	$prefix = ‘/index.php’;
    
    $structures = array(
    	”,
    	$prefix . ‘/%year%/%monthnum%/%day%/%postname%/’,
    	$prefix . ‘/%year%/%monthnum%/%postname%/’,
    	$prefix . ‘/archives/%post_id%’
    	);
    ?>

    Alors, encore une fois je peux me tromper, mais je me demande les trois premières lignes ne signifient pas
    si le module mod_rewrite n’est pas présent (ou pas activé?), le préfixe devient alors xxxxx/index.php
    mod_rewrite est un module de Apache qui permet de réécrire les URL

    Je rappelle que je suis sous 2.7 mais ce doit être la même chose sous .1

    #662407
    Damienfr
    Participant
    Initié WordPress
    34 contributions

    Donc il faudrait que je supprime cette ligne ?

    #662408
    jeanmichel
    Membre
    Chevalier WordPress
    145 contributions

    Déjà, il faudrait être sûr qu’elle dit bien ce que je soupçonne.

    A mon avis, cette ligne est faite pour le cas où mod_rewrite ne serait pas activé sur ton serveur (ce qui est le cas chez free, d’où les pbs).

    A ta place, j’attendrais des réponses plus éclairées. avant de faire quoi que ce soit dont je ne serais pas certain de maîtriser es conséquences. 🙂

    A défaut de règler to pb, ce post aura au moins l’avantage de faire remonter le sujet.

    #662409
    Damienfr
    Participant
    Initié WordPress
    34 contributions

    J’ai eu les réponses de l’admin, mod_rewrite est bien activée sur le serveur, le problème viendrait d’un fichier .htaccess absent de la racine de mon site, l’admin m’a passé le sien, j’ai essayer de le modifier, mais cela provoque une erreur 500 sur le serveur (surement qu’il est mal configuré),

    Si quelqu’un a un exemple de Htaccess fait pour l’URL rewriting, je prend ! 🙂

15 sujets de 1 à 15 (sur un total de 16)
  • Vous devez être connecté pour répondre à ce sujet.