[Résolu] En rade : http 500 erreur interne au serveur ! (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 25)
  • Auteur
    Messages
  • #446632
    koz
    Participant
    Chevalier WordPress
    309 contributions

    😮 Hello ! J’ai voulu modifier la structure des permaliens. J’ai copié/collé l’exemple de structure donné dans le panneau d’admin et ça m’a donné une page à l’allure étrange. J’ai fait « voir le site » et j’ai eu une 1ère erreur 500… Puis j’ai supprimé la structure que j’avais indiquée et là, c’est carrément tout le site, panneau d’admin compris qui est inaccessible… 😮

    HELP.

    Dans le pire des cas, j’ai fait une sauvegarde de BDD hier mais je ne sais plus si c’était avant ou après mon dernier billet… Et j’y perdrais 30 commentaires…

    #567181
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Bon, apparemment, je me suis un peu vite affolé… Le temps de refaire une sauvegarde de BDD qui, visisblement est accessible tout de même dans un cas comme ça (oui, je sais, je suis une bille), je me suis dit que je devrais re-uploader index.php. Et, en regardant les fichiers, j’ai vu qu’il y a avait un tout nouveau .htaccess… Je l’ai supprimé et ça fonctionne de nouveau.

    Question : il me semble que ce .htaccess vient de ma tentative d’installation d’un plugin. Mais il semblerait que ça ne m’ait pas planté tout de suite… C’est possible ou est-ce que mon erreur 500 est en fin de compte une « coïncidence » ?

    #567182
    xavier
    Participant
    Maître WordPress
    2124 contributions

    Je crois que Free refuse le mod_rewrite, d’où l’erreur 500.
    En gros, tu ne peux pas personnaliser tes URLs.

    #567183
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Erreur, après une brève éclaircie, j’ai refait un tour sur le panneau d’admin, revu la page avec la structure des permalinks, resupprimer la nouvelle structure et reperdu la main… 😡

    euh, quand je dis « erreur », c’est en rapport à mon précédent message.. 😉

    #567184
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Bizarre, tout ça : j’ai refermé mon client ftp, rouvert, et il y avait de nouveau un fichier .htaccess … Je l’ai donc de nouveau supprimé et ça fonctionne. Seul problème : maintenant j’ai les boules de passer sur cette page « permaliens » !!! 😉

    #567185
    benkenobi
    Participant
    Maître WordPress
    4069 contributions

    Correction !

    Tu peux les modifier… Même avec avec Free… j’y suis arrivé moi.

    Après beaucoup de tentatives mais j’y suis arrivé. J’ai supprimé le htaccess qui se créé, j’ai remis les permaliens par défault à leur état d’origine… J’ai enregistré… Si un nouveau htaccess est recréé ici, tu supprime de nouveau… tu remets la structure que tu veux (sans oublier de mettre « index.php » devant 😉 ) tu réenregistre et normalement cela fonctionne.

    Edit > Je poste trop tard… j’avais clqiuer sur « répondre » avant que tu ne réponde justement et je ne valide que maintenant !! 😉

    #567186
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Bon, alors, je vais essayer parce que, pour le moment, c’est la m… : en fait, il n’y a que l’ancienne structure qui fonctionne. Les billets sont accessibles avec l’ancienne. Mais, tous les liens qui sont affectés par les permaliens sont plantés… Et puis, cette saloperie de .htaccess qui se recrée en permanence…

    En revanche, je n’avais pas mis index.php devant ! Je teste.

    #567187
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Oh, Ben, I loooove You !
    Effectivement, ça a beau être indiqué sur la page d’options permaliens (Pour que tout ceci fonctionne, vous devez avoir mod_rewrite installé sur votre serveur (demandez à votre hébergeur). Si ce n?est pas le cas, vous pouvez préfixer la structure avec /index.php/. C?est d?ailleurs la méthode recommandée si vous utilisez un serveur web autre qu?Apache.), n’y connaissant rien, je n’avais même pas tenté de mettre index.php …

    Bon, ben, un ptit coup de flippe mais c’est reparti.

    #567188
    benkenobi
    Participant
    Maître WordPress
    4069 contributions

    Quant au .htaccess, il est normal donc une fois que tes permaliens fonctionnent tu le laisses, sinon replantage… et tout est à refaire. 😉

    #567189
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Merci de la précision. Au point où j’en suis, l’idée aurait pu me traverser l’esprit :rolleyes::lol:

    #567190
    clansco
    Participant
    Initié WordPress
    13 contributions

    merci Ben,
    je suis en train d’essayer de comprendre un site wp qui s’étale sur plusieurs URI,
    et les .htaccess me laissaient pantois.
    il me reste à comprendre ce que signifient les [QSA,L] et [R,L]
    mais grâce à toi j’ai déjà fait un grand pas.

    ma plus grosse interrogation c’est : comment ils ont fait ?
    (le webmestre est momentanément absent depuis un certain temps)
    un seul wp avec des fichiers disséminés sur diverses URI ?
    c’est faisable ?
    ou un wp cloné ?

    #567191
    benkenobi
    Participant
    Maître WordPress
    4069 contributions

    Je viens de me rendre compte d’une chose… à l’instant même mon fichier .htaccess a disparu et je ne m’en était pas rendu compte !! Mes permaliens sont toujours là… serait-ce qu’il disparait tout seul ????
    Alors que je pensais que la modif des permaliens en avait créé un ?

    Clansco > Quelle est l’adresse du site dont tu parles ? et où as tu vu ces [QSA,L] et [R,L] ?

    Koz > Peux tu me dire si après la validation de tes permaliens le fichiers htaccess est encore là ?

    Je deviens fou ou quoi ??

    #567192
    koz
    Participant
    Chevalier WordPress
    309 contributions

    Eh bien non, a plus de fichier .htaccess.
    En revanche, je ne sais pas si cela doit te rassurer sur ta santé mentale :D

    #567193
    xavier
    Participant
    Maître WordPress
    2124 contributions
    BenKenobi wrote:
    Je viens de me rendre compte d’une chose… à l’instant même mon fichier .htaccess a disparu et je ne m’en était pas rendu compte !! Mes permaliens sont toujours là… serait-ce qu’il disparait tout seul ????
    Alors que je pensais que la modif des permaliens en avait créé un ?

    Je peux me tromper, mais je crois que tu tu fais une url du type /index.php/categorie/bidule, ce n’est plus .htaccess qui entre en jeu, mais WP qui gère la chaîne suivant index.php de son mieux. Once again, je peux me tromper.

    #567194
    xavier
    Participant
    Maître WordPress
    2124 contributions
    clansco wrote:
    il me reste à comprendre ce que signifient les [QSA,L] et [R,L]

    C’est dans la doc de mod_rewrite : http://httpd.apache.org/docs/1.3/mod/mod_rewrite.html
    Il s’agit de « drapeaux » (flags) qui précisent l’action ou la porté de la règle RewriteRule.

    In addition, you can set special flags for url-new by appending one or more flag arguments. The flag argument is actually a comma-separated list of the following flags:
    redirect (or R) to force an HTTP redirect;
    forbidden (or F) to forbid access;
    gone (or G) to eliminate the URL;
    proxy (or P) to pass the URL to mod_proxy;
    last (or L) to stop processing;
    next (or N) to start the next round of processing;
    chain (or C) to chain the current rule with the following one;
    type (or T) to force a particular MIME type;
    nosubreq (or NS) to ensure that the rule applies only if no internal sub-request is performed;
    nocase (or NC) to force the URL matching to be case-insensitive;
    qsappend (or QSA) to append a query string part in url-new to the existing one instead of replacing it;
    passthrough (or PT) to pass the rewritten URL through to other Apache modules;
    skip (or S) to skip the next rule;
    – and env (or E) to set an environment variable.

    For more details, see the mod_rewrite online documentation.

    http://www.apacheref.com/ref/mod_rewrite/RewriteRule.html

15 sujets de 1 à 15 (sur un total de 25)
  • Vous devez être connecté pour répondre à ce sujet.