[Résolu] de l’utilisation de la mailing-list…

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 24)
  • Auteur
    Messages
  • #448307
    La_bulle
    Membre
    Initié WordPress
    33 contributions

    Bonjour, bonjour,

    Décidément, installer un blog WordPress n’est pas si simple. Et comme je travaille sur 3 blogs en même temps (histoire d’avoir le même moteur sur tous les sites) c’est pas de tout repos…

    Donc, pour faire simple, sur un des blogs installé en 2.0.4 (serveur 1and1), je dois utiliser un plugin de mailing-list afin de tenir au courant les membres des nouveaux ajouts automatiquement. Pour ce faire, j’ai installé le plugin Mailing-List de Gérard Ly dans sa version 4.0béta car c’est semble t’il la seule version qui marche avec WordPress en version 2.

    Seul hic, j’ai cette erreur qui apparaît lorsque je publie l’article, et pourtant l’article est bien publié et le mail bien envoyé… 🙂

    Warning: Invalid argument supplied for foreach() in /homepages/21/d146189479/htdocs/baloeff/islandia/wp-content/plugins/mailing-list.php on line 647

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/21/d146189479/htdocs/baloeff/islandia/wp-content/plugins/mailing-list.php:647) in /homepages/21/d146189479/htdocs/baloeff/islandia/wp-includes/pluggable-functions.php on line 272

    Quelqu’un a t’il rencontré le même problème ??

    Je précise, pour les connaisseurs, que le mail envoyé contient ces variables :

    Un nouvel article intitulé « [TITLE] » sur Islandia est visible en cliquant sur le lien suivant [PERMALINK]

    Variables liées au plugin et qui sont classiques car proposées d’office dans le corps du message lorsqu’on installe le plugin.

    Voilà, merci de votre aide !

    #577950
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Je pense que le plus simple, c’est de demander au concepteur du plugin !
    J’ai regardé rapidement, j’ai pas vu d’erreur grossière.. à voir avec le créateur :happy:

    #577951
    La_bulle
    Membre
    Initié WordPress
    33 contributions

    J’ai fait partir un mail au concepteur. Je vous tiens au courant de la réponse, ça peut servir à d’autres… 🙂

    #577952
    Eric
    Participant
    Padawan WordPress
    56 contributions

    Le problème que je rencontre est le suivant. Tout se passe bien question installation mais lors de la récéption du message, j’ai une suite de caractères et de chiffres à la place dudit message. quelqu’un a t il une idée ? Merci

    #577953
    La_bulle
    Membre
    Initié WordPress
    33 contributions

    Hello !

    Toujours rien de la part du concepteur du plugin (il doit être en vacances…)

    Eric, peux tu nous mettre un exemple de ce que tu reçois ?

    #577954
    Eric
    Participant
    Padawan WordPress
    56 contributions

    Bien sur , voici le premier message : qui signigie test :

    LS0tLS0tLT05NjVmZTMyYmFjMzU2MWQ3MWQ3NDJlZmFjNzMyMjNiYg0KQ29udGVudC1UeXBlOiB0
    ZXh0L3BsYWluOyBjaGFyc2V0PSJVVEYtOCINCkNvbnRlbnQtVHJhbnNmZXItRW5jb2Rpbmc6IDhi
    aXQNCg0KVGVzdCBkZSBuZXdzDQotLS0tLS0tPTk2NWZlMzJiYWMzNTYxZDcxZDc0MmVmYWM3MzIy
    M2JiLS0NCg==

    Faut le savoir 😉

    un autre avec une fichier attaché donne :

    LS0tLS0tLT0yYjE5Njk1M2FjYzRkMTBjZmYzNDAzMmQzNjdmZTZjMA0KQ29udGVudC1UeXBlOiB0
    ZXh0L2h0bWw7IGNoYXJzZXQ9IlVURi04Ig0KQ29udGVudC1UcmFuc2Zlci1FbmNvZGluZzogOGJp
    dA0KDQo8aHRtbD4KPGhlYWQ+Cjx0aXRsZT5GZWRlcmF0aW9uIEJlbGdlIGRlIEtpbi1CYWxsPC90
    aXRsZT4KPC9oZWFkPgo8Ym9keT4KCnRlc3QgdW5lIGZvaXMgZGUgcGx1czxiciAvPjxiciAvPjxi
    ciAvPklmIHlvdSB3YW50IHRvIGVuYWJsZSBvciBkaXNhYmxlIHRoZSBuZXdzbGV0dGVyIGJ1dCBz
    dGlsbCB3YW50IHRvIHJlY2VpdmUgYWRtaW4gbm90aWZpY2F0aW9ucyB0aGVuIHVzZSB0aGlzIGxp
    bms6IDxhIGhyZWY9Imh0dHA6Ly93d3cua2luLWJhbGwuYmUvZmVkZXJhdGlvbi9zdWJzY3JpYmUu
    cGhwP2FjdGlvbj1uZXdzbGV0dGVyIj5odHRwOi8vd3d3Lmtpbi1iYWxsLmJlL2ZlZGVyYXRpb24v
    c3Vic2NyaWJlLnBocD9hY3Rpb249bmV3c2xldHRlcjwvYT48YnIgLz5JZiB5b3Ugbm8gbG9uZ2Vy
    IHdpc2ggdG8gcmVjZWl2ZSBhZG1pbidzIG9yIG5ld3MgcG9zdHMgbm90aWZpY2F0aW9ucyB0aGVu
    IHBsZWFzZSB1bnN1YnNjcmliZTogPGEgaHJlZj0iaHR0cDovL3d3dy5raW4tYmFsbC5iZS9mZWRl
    cmF0aW9uL3N1YnNjcmliZS5waHA/YWN0aW9uPXVuc3Vic2NyaWJlIj5odHRwOi8vd3d3Lmtpbi1i
    YWxsLmJlL2ZlZGVyYXRpb24vc3Vic2NyaWJlLnBocD9hY3Rpb249dW5zdWJzY3JpYmU8L2E+Cgo8
    L2JvZHk+CjwvaHRtbD4KDQotLS0tLS0tPTJiMTk2OTUzYWNjNGQxMGNmZjM0MDMyZDM2N2ZlNmMw
    LS0NCg==

    Voilà. JE penche pour un problème de codage UTF-8 qui devrait peut etre etre emplacé en ISO mais n’y connaissant pas grand chose en progra, je ne vois pas où je peux redéfinir cela.

    #577955
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Ca ressemble pas à un probleme d’encodage :s

    #577956
    Lucialoo
    Membre
    Initié WordPress
    32 contributions

    Je profite de ce post pour poser ma petite question aussi lol !

    J’ai installé le plugin, j’ai réussi à m’envoyer une newsletter, par contre je ne sais pas quoi mettre dans la sidebar pour qu’il y ait une case pour s’inscrire à la newsletter. Et faut-il mettre le fichier subscribe.php à un endroit précis ?

    #577957
    Andy
    Participant
    Chevalier WordPress
    109 contributions

    La_bulle Es-tu sûr(e) de ne pas avoir introduit d’espace quelque part dans ton fichier avant ou après les tags php soit <? ou ?

    Eric On dirait du MD5. Cela pourrait être l’encodage des adresses e-mail pour les cacher des spammeurs. Si tu as pris la version 4 du plugin, n’oublie pas qu’il est en béta. Ca pourrait être un bug. As-tu essayé de désactiver tous tes plugins puis réactiver celui-ci et tenter un essai alors qu’il est seul activé ? Ensuite, réactives tes plugins un à un en refaisant un test à chaque fois. S’il s’agit d’un conflit entre deux plugins, il apparaîtra à un moment donné. Il est possible que ce soit un conflit dont l’auteur n’est pas au courant.

    Lucialoo Le dossier subscribe et le fichier subscribe.php vont dans le répertoire racine de ton WP. Le fichier subscribe.php est en fait le formulaire d’inscription/désinscription. Il te faut l’intégrer à ton thème soit par un lien, soit par la création d’une page spécifique (template) dans ton thème avec un « include » ou bien avec des iframes.

    L’auteur aurait pu inclure des instructions d’installation !

    #577958
    Lucialoo
    Membre
    Initié WordPress
    32 contributions

    merci andy, mais je suis un peu novice, donc pour faire simple, comment je crée un lien dans mon thème ?

    j’avais tapé dans le fichier sidebar, mais ce n’est visiblement pas ça…

    #577959
    Andy
    Participant
    Chevalier WordPress
    109 contributions

    Désolé, il s’agit d’un lien HTML classique comme ceci :
    Inscrivez vous (ceci sera probablement entouré de

  • en fonction de ton fichier sidebar.php

#577960
Lucialoo
Membre
Initié WordPress
32 contributions

génial ! merci beaucoup Andy !

#577961
Eric
Participant
Padawan WordPress
56 contributions

MErci pour l’info Andy je teste ça de suite et te tiens au courrant

#577962
Eric
Participant
Padawan WordPress
56 contributions

Voila lre sultat, après avoir essayé les solutions proposées, rien n’a changé, j’ai envoyé un mail au concepteur mais je pense qu’il est en congés. Si par le hasard des choses quelqu’un à une idée; je suis preneur. Merci

#577963
Andy
Participant
Chevalier WordPress
109 contributions

Eric désolé, ce n’était pas des solutions mais plutot une méthode de déboggage. Tu es sûr de n’avoir jamais touché au code de ce fichier ?
Parfois, on commet des erreurs en voulant traduire. Une petite espace peut rendre un plugin inutilisable. Mais il y a aussi les « mystères internet » où ça marche très bien en anglais et on ne comprend jamais pourquoi la traduction n’a pas fonctionné.
A ta place, je commencerai à considérer le temps passé. Est-ce que ça vaut le coup de persister à vouloir ce plugin à tout prix ? Après tout, il y en a plusieurs qui remplissent les mêmes fonctions.

15 sujets de 1 à 15 (sur un total de 24)
  • Vous devez être connecté pour répondre à ce sujet.