[Résolu] Créer sa propre page d’accueil avec effet parallax (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 19)
  • Auteur
    Messages
  • #525982
    anlorp
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.5.2
    – Version de PHP/MySQL : PHP 5.2.17
    – Thème utilisé : Portfolio-Press
    – Extensions en place : Portfolio Post Type, Dolly, Askimet
    – Nom de l’hebergeur : MAMP
    – Adresse du site : pas encore en ligne

    Problème(s) rencontré(s) :

    Je débute dans la création de site web. Je souhaite allier un porfolio (réalisé avec thème Portfolio-Press) avec une page d’acceuil que j’ai realisé en code html un effet parallax.
    J’ai tenté de relié cette page d’acceuil à mon blog wordpress. J’ai donc inséré une balise php qui la définit comme page d’acceuil. Or lorsque j’enregistre cette page au format php, elle ne fonctionne plus, les images ne s’affichent plus.
    Est-ce que l’effet parallax est incompatible avec le format php ?
    Existe-t-il un moyen de configurer une page d’acceuil au format html au lieu de php dans wordpress ?

    J’espère que ce que je dit à un sens car je n’y connais pas grand chose en développement web.

    Merci d’avance pour votre aide,
    Anne-Laure

    #901436
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Parallax est compatible avec php, je ne vois pas de contre-indication.

    Avez-vous bien déclaré le

    ?

    #901437
    YannC
    Membre
    Chevalier WordPress
    295 contributions

    Celui qui convient , je veux dire.

    #901438
    anlorp
    Participant
    Initié WordPress
    8 contributions

    Oui je l’ai bien déclaré.
    J’ai dit une erreur : en fait la page fonctionne quand je l’ouvre directement dans mon navigateur. Mais quand j’affiche la page d’accueil depuis WordPress, seul le texte apparait…

    Est-ce qu’il faut installer un plugin ou je ne sais quoi pour que WordPress comprenne le parallax ?

    Merci

    #901439
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    @YannC

    Euh!… Il me semble qu’il y a une erreur dans votre signature, il me semble que WordPress vient de fêter ses 10 Ans d’existence (si je ne me trompe pas) ou est-ce voulu ??

    :hs:

    #901440
    Guy
    Participant
    Maître WordPress
    14817 contributions

    non non, il n’y a pas d’erreur, il existait une version beta marchant à la vapeur et utilisant le protocole pigeon voyageur 2.0 ( le httpv).

    #901441
    anlorp
    Participant
    Initié WordPress
    8 contributions

    J’ai déclaré :

    c’est que que Dreamweaver m’a affiché automatiquement en créant ma page. Comment savoir si c’est ce qui convient ?

    #901442
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    J’ai jamais été très douée en histoire, surtout les dates !! 🙂


    @anlorp

    Peux-être que le chemin des images n’est pas correcte.

    #901443
    Guy
    Participant
    Maître WordPress
    14817 contributions

    normalement, si ta page en html fonctionne, il suffit de la renommer en front-page.php, de la copier dans le répertoire du thème, ajuster le chemin des images et… ca roule.

    #901444
    anlorp
    Participant
    Initié WordPress
    8 contributions

    Oui effectivement …. ! je suis allée chercher beaucoup trop loin, désolée pour la perte de temps. En tout cas ça fonctionne, merci beaucoup !

    #901445
    YannC
    Membre
    Chevalier WordPress
    295 contributions
    Guy wrote:
    non non, il n’y a pas d’erreur, il existait une version beta marchant à la vapeur et utilisant le protocole pigeon voyageur 2.0 ( le httpv).

    Oui, c’est à cette version là que je pensais 🙂

    L’ironie, Ouistiti, l’ironie 😉 Puisque ça ne peut pas être, c’est donc que c’est faux. Ma signature est volontairement délirante, quoi.


    @anlorp
    : content que ça fonctionne.

    #901446
    ouistiti.net
    Participant
    Maître WordPress
    1879 contributions

    Rien de méchant…. j’ai soupçonné un moment donné une faute de frappe. D’où ma question ??:D

    #901447
    anlorp
    Participant
    Initié WordPress
    8 contributions

    Rebonjour,

    J’ai une nouvelle question.
    J’ai bien réussi à créer ma propre page d’accueil et à la relier à mon portfolio wordpress.
    Par contre avec le theme portfolio-press, je n’arrive pas à afficher la totalité de mes images en tant que « page d’arrivée » sur mon portfolio. On arrive sur un article vide (erreur 404), et on peut cliquer les catégories contenant les différentes images.
    Lorsque que mon portfolio était configuré en tant que page d’accueil, j’avais bien toutes mes images qui apparaissaient.
    Quelqu’un voit ce qu’il faut faire ?
    Merci

    #901448
    Guy
    Participant
    Maître WordPress
    14817 contributions

    je vais charger le thème et regarder cela ce soir. Je n’ai pas d’idée précise de ce qui se passe sur le moment.

    #901449
    anlorp
    Participant
    Initié WordPress
    8 contributions

    Merci mais c’est bon j’ai trouvé la solution 🙂 J’avais simplement fait une erreur dans mon lien de redirection…

15 sujets de 1 à 15 (sur un total de 19)
  • Vous devez être connecté pour répondre à ce sujet.