[Résolu] Compatibilité plugin avec la version 2.7 (Créer un compte)

  • Statut : non résolu
15 sujets de 31 à 45 (sur un total de 55)
  • Auteur
    Messages
  • #653892
    Du
    Participant
    Initié WordPress
    6 contributions

    Merci Li-an
    J’ai jeté le plugin mais toujours impossible de se connecter en tant qu’admin.
    J’ai changé de mot de passe, pas mieux … :(
    J’ai eu ce souci suite à l’activation du plugin, j’en déduis que ça a certainement un rapport.

    #653893
    Li-An
    Modérateur
    Maître WordPress
    24864 contributions

    Un peu étrange… Il faudrait peut-être retenter une installation.
    Ah, essaie de supprimer le fichier fr_FR.php dans wp-contentlanguages d’abord.
    Il pose des problèmes avec plusieurs plugins sous WP 2.7

    #653889
    Du
    Participant
    Initié WordPress
    6 contributions

    … je crois que je vais faire une réinstallation.

    #653894
    Li-An
    Modérateur
    Maître WordPress
    24864 contributions

    C’est aussi une solution qui peut se révéler fort efficace 🙂

    #653895
    Du
    Participant
    Initié WordPress
    6 contributions

    Après réinstallation, Akismet fonctionne à présent.🙂

    Maintenant, je rencontre un problème avec CformsII.
    Je n’arrive pas à envoyer le formulaire et à être redirigé. Est-ce qu’il y’ a quelque chose en particulier à configurer pour que le mail arrive à destination ? Est-ce qu’il y’ a un problème d’adresses ?

    Bref, je ne sais pas trop quoi faire.

    #653896
    Li-An
    Modérateur
    Maître WordPress
    24864 contributions

    Il vaudrait mieux que tu ouvres un autre sujet vu que le problème a l’air différent…

    #653897
    merlinbreizh
    Membre
    Padawan WordPress
    63 contributions

    Cool ca solutionne aussi mon problème, en installant Theme Test Drive, mon accès à ma page d’admin m’était refusé, soit disant que je n’avais pas les permissions ! Non, mais. J’ai viré le fichier fr_FR.php dans le dossier language et ça roule sur des roulettes !

    #653898
    FascinantJapon
    Participant
    Initié WordPress
    37 contributions

    Voila ma solution pour le problème de non-connexion a l’admin a cause des plugins après la maj.
    Je pense que c’est mieux que d’effacer un fichier qui pourrait peut-être servir.
    J’ai déjà mis la solution dans deux autres threads mais en fait j’aurai du commencer par ici! 😉

    1. Récupérer les fichiers wp/wp-config.php et wp/wp-content/languages/fr_FR.php (adapter le chemin à votre installation si besoin)
    2. Aller à l’adresse suivante: http://api.wordpress.org/secret-key/1.1/ et copier les 4 clés générées
    3. Les coller dans wp-config.php comme ci-dessous:
    cle-config.jpg
    4. Ouvrir le fichier fr_FR.php et remplir la clé avec l’une des quatre déjà générée ou alors avec une nouvelle clé:
    cle-francais.jpg
    5. Recharger les 2 fichiers par ftp dans les bons dossiers

    Voila. Maintenant, le backup de la base de données, ainsi que l’envoi par email en cliquant sur le bouton ou a heure fixe marche. De la même manière, l’extension wordbook qui ne marchait plus, remarche.

    #653899
    Li-An
    Modérateur
    Maître WordPress
    24864 contributions

    Ben ça a l’air de marcher au moins pour la connexion 🙂 On va voir pour le back up programmé…

    #653900
    Supporter
    Membre
    Padawan WordPress
    50 contributions
    FascinantJapon wrote:
    4. Ouvrir le fichier fr_FR.php et remplir la clé avec l’une des quatre déjà générée ou alors avec une nouvelle clé:
    http://friefrench.free.fr/stuff/cle-francais.jpg

    Surtout pas !!!!

    La $wp_default_secret_key a toujours comme valeur:
    ‘put your unique phrase here’
    Il y a defaut dedans, donc ca n’a rien avoir avec les keys personnalisés que vous reneignés dans le fichier wp-config.php.
    Dans le fichier wp.config vous renseignez la secret_key et non la $wp_default_secret_key.

    La $wp_default_secret_key est aussi indiqué dans le fichier wp-settings.php:

    /**
    * Should be exactly the same as the default value of SECRET_KEY in wp-config-sample.php
    * @since 2.5.0
    */
    $wp_default_secret_key = ‘put your unique phrase here’;

    et c’est bien spécifier que cette valeur doit être: ‘put your unique phrase here’
    car la même valeur que dans le fichier wp-config-sample.php et non celle que vous avez mis dans le fichier wp-config.php

    Donc:
    Edition du fr_FR.php et remplacer:

    <?php
    $wp_default_secret_key = ‘mettez ici une phrase unique’;
    ?>

    Par:

    <?php
    $wp_default_secret_key = ‘put your unique phrase here’;
    ?>

    #653901
    Li-An
    Modérateur
    Maître WordPress
    24864 contributions

    Si j’ai bien compris on peut aussi remplacer ‘put your unique phrase here’ par un mot de passe perso. Bon, je teste la manip (mais vous nous fichez les chocottes).

    #653902
    Supporter
    Membre
    Padawan WordPress
    50 contributions

    Non !!!

    Le fichier fr_FR.php doit contenir exactement ceci ( sans aucune modification):

    <?php
    $wp_default_secret_key = ‘put your unique phrase here’;
    ?>

    Il faut remplacer ‘put your unique phrase here’ par des clés persos dans le fichier wp-config.php et non dans le fichier fr_FR.php !!!

    #653903
    Li-An
    Modérateur
    Maître WordPress
    24864 contributions

    Ah, c’est une précision qui me semble importante.

    #653904
    arnaudt
    Participant
    Initié WordPress
    42 contributions

    WordPress Database Backup 2.2.1 déconne chez moi. Essayé plusieurs fois avec le même résultat : en l’activant, mon Dashboard devient inaccessible “Error Internal server”.
    Erreur qui disparait quand je le désactive à nouveau.

    Il est pourtant indiqué comme compatible sur http://codex.wordpress.org/Plugins/Plugin_Compatibility/2.7#U_-_Z

    Une idée ?
    Merci.

    #653905
    arnaudt
    Participant
    Initié WordPress
    42 contributions

    Viper’s Video Quicktags 6.1.16 me produit exactement le même résultat : Error 500 Internal Server Error, qui apparaît quand je l’active et disparaît quand je le désactive.
    Bizarre.

    Une piste ? 🙂

15 sujets de 31 à 45 (sur un total de 55)
  • Vous devez être connecté pour répondre à ce sujet.