[Résolu] Changement de forme de permaliens —>blog cassé

  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #448791
    nerv
    Membre
    Initié WordPress
    3 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.0.4 :
    – Thème utilisé : K2 :
    – Plugins en place : Extreme video plugin (activé) + plugins par defaut (non activés) :
    – Nom de l’hebergeur : Free.fr 😕 :

    Voila, tout d’abord je me présente, nouveau sur ce forum et tout nouveau bloger avec wordpress que je trouve fantastique :wp:

    Pour le moment, le blog ne ressemble à rien, je le présenterais quand j’en serais fier 🙂.

    Et en plus voila ce qui m’ammène, hier poussé par la soif de découverte de cette fabuleuse blog engine, j’ai voulu tenter de modifier la forme des permaliens, passer de la forme par defaut (http://monblog.com/?p=X) en http://monblog.com/weblog/XXXX . Et là, c’est le drame. 😮

    Tout de suite en cliquant sur le bouton du bas de la page: “internal server error, erreur 500”
    Et oui, free.fr n’autorise pas l’url rewriting et du coup le .htaccess fait tout planter.

    Je supprime le .htaccess et le blog remarche, mais dorenavent les liens sont en http://monblog.com/weblog/XXX
    y compris pour les nouveaux articles que je crée.

    Si je tape un ancien lien http://monblog.com?p=x manuellement dans la barre d’adresse de mon navigateur, ça marche, j’accède à l’article, mais si je clic sur le lien pour accéder à l’article depuis la page d’acceuil de mon blog, il m’envoie sur http://monblog.com/weblog/xxxx page inexistante .

    Donc je retourne dans les options du blog, je retourne sur la page de gestion des permaliens, et quand j’éssaye de remètre l’option par defaut, au moment ou je clic sur “mettre à jours les permaliens” : érreur 500. le .htaccess est de nouveau crée et rien n’a changé, la structure est toujours sous la forme http://monblog.com/weblog/xxx.

    Je suppose qu’il y a quelquechose à changer dans ma base de données, mais autre probleme (lié ou non à ce dernier?) quand avec phpmyadmin je lance une recherche dans la db j’otiens une érreur 1064 :( (voir image en bas)
    Bref deux bon problèmes.

    Si quelqun à une idée pour regler le premier problème, ce serais déja ça, merci à tous, et merci de m’acceuilir parmis vous 🍺

    😋
    5cc1f3b69c1b7118016a494b042ecaa0.jpg

    #581147
    AmO
    Participant
    Maître WordPress
    4452 contributions

    A tout hazard… as tu lu :
    http://www.wordpress-fr.net/faq/index.php?sid=5745&lang=fr&action=artikel&cat=4&id=6&artlang=fr

    Si ca n’est pas le cas :fouet:

    😎

    Edit : Et puis :search:

    #581148
    nerv
    Membre
    Initié WordPress
    3 contributions

    Bonsoir,

    Merci pour la réponse rapide 🙂
    Sisi, j’ai lu cette explication, mais quand je reviens sur la page d’admin des permaliens, et je met sur defaut, je valide, j’ai tout de suite une erreur 500, et la modif n’est pas prise en compte :(
    Je suppr le .htaccess pour avoir accés de nouveau au blog, sinon error 500, et quand je vais dans options/permaliens, c’est toujours sur “personnalisé”, c’est pas pris en compte quoi.

    Merci

    Edit : et puis :search: ne m’a pas aidé 😕 c’est pour ça que j’ai posté

    ReEdit : nerv = :boulet: J’avais pas lancé ma recherche intélligement : http://www.wordpress-fr.net/support/viewtopic.php?id=1947

    Voila, toute mes excuses, ce méssage peut-être supprimé, il ne polueras pas le paysage.

    Merci encore :D

    #581149
    AmO
    Participant
    Maître WordPress
    4452 contributions

    je le laisse 😉
    Ca peut etre utile pour les autres :D

    :wp:

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.