[Résolu] Bug IE lors de l’affichage d’une photo (Créer un compte)

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #446827
    lapinot
    Membre
    Initié WordPress
    24 contributions

    bonjour,
    j’utilise pour ma part Firefox. Lors de l’ajout d’une photo, aucun probleme ! mais c’est la cata sous I.E. !
    la photo prend toute la place decalant tout le menu de droite (theme standard, version WP2)
    quelqu’un a t il rencontré ce problème car peu de personnes utilisent firefox, snif !

    #568784
    damino
    Participant
    Maître WordPress
    1243 contributions

    Salut Lapinot, je me répète et me répète et me répète, nous sommes tous bénévoles, avec comme motivation juste l’envie de rendre service. Donc merci d’en dire un peu plus et un lien vers le site pour pouvoir le code est plus qu’utile.
    On sait que IE n’est pas complètement conforme aux standards W3C et qu’il faut donc parfois ruser dans les feuilles de style pour afficher correctement (pas identiquement mais correctement !) dans les navigateurs respsectueux des standards et IE.

    Il y a quelques posts sur ce sujet sur les forums ici … (recherche …)

    #568785
    lapinot
    Membre
    Initié WordPress
    24 contributions

    ok, en le prenant comme ça ! mais je me suis tapé tous les forums……..ET je n’ai trouvé aucun sujet explicite sur les bug IE, alors autant pour moi si je suis passé à travers….mais je vais me debrouiller.
    pour info : donc je repete moi aussi mais je ne sais que dire de plus : ma photo prend toute la place du menu de droite du theme standard (version WP 2 francais) et decale le menu de droite (archives, catégories, lien) vers le bas. voilà.

    #568783
    damino
    Participant
    Maître WordPress
    1243 contributions

    Faut pas le prendre mal lapinot, c’est juste que l’on répète souvent la même chose alors qu’il est parfois simple de trouver une solution.

    Et encore une fois, tu aura vu que sur ce forum même si j’ai des paroles parfois un peu sèches, je m’efforce toujours d’aider ceux qui le demande.

    Donc je me répète 😉, un petit lien vers ton site (pour étude du code) serait la bienvenue. Comme tous les thèmes (et donc les CSS et fichiers HTML) présentent des différences, il est impossible de t’apporter une solution toute cuite sans donner un minimum d’infos. Même si tu nous dis qu tu utilises le thème standard, il y a pu y avoir des modifs de ta part. Donc un lien vers ton problème STP (c’est aussi indiqué dans les Règles de ce forum ).

    Merci.

    #568782
    lapinot
    Membre
    Initié WordPress
    24 contributions

    je le prends pas mal mais je t’assure que j’ai essayer de tout lire avant de poster..j’utilise Php web gallery (petite pub au passage, c’est genial) et donc je sollicite aussi les personnes sur le forum…donc je commence à etre habituer…
    voici l’adresse xxxxxxx désolé j’évite les liens directs je préfère….
    je rappelle que le bug à lieu que sous I.E. version 6…et pas sous firefox….et pour l’instant juste je commence à vouloir personnaliser donc j’ai rien modifié (ou presque juste le fichier index.php du template défaut pour avoir le nom de l’auteur à coté du billet (trois utilisateurs pour l’instant).

    #568786
    damino
    Participant
    Maître WordPress
    1243 contributions

    1-Avec quoi insères-ty tes images ? en codant à la main dans ton article ou via un post ?
    2-Ton image fait 709 px de large alors que ton conteneur n’en fait que 450 px.
    Ton code actuel dans la CSS :

    .widecolumn {
    	padding: 10px 0 20px 0;
    	margin: 5px 0 0 150px;
    	width: 450px;
    	}

    Donc dèjà il y a un problème ici que FireFox semble surmonter mais pas IE. Essaye déjà de réduire la largeur de ton image pour qu’elle soit inférieure à 450 px.

    En effet il semble que le

    p img {
    	padding: 0;
    	max-width: 100%;
    	}

    utilisé dans la feuille de style pour permettre d’obliger une image de largeur supérieure à on conteneur puisse le “remplir” entièrement (cf le 100 %) ne fonctionne pas sous IE.

    Une petite recherche me le confirme ici et ici.

    Alors après ça si on dit encore que je suis un gros vilain. En plus je ne suis même pas un geek !

    #568787
    lapinot
    Membre
    Initié WordPress
    24 contributions

    bon ok merci je teste demain…pour aujourd’hui ça suffit, je fais une pause.
    pour insérer la photo, je debute dans wordpress…je le fais par insertion photo lors de l’écriture d’un post en donnant l’url de la photo (j’ai crée un dossier photo)…c’est peut etre pas la meilleure méthode, faut que je paufine ça….
    et si on mets dans la css :

    .widecolumn {
    padding: 10px 0 20px 0;
    margin: 5px 0 0 150px;
    max-width: 100%;
    }

    ça ne reglerait pas le probleme sous I.E. ?
    et j’ai pas dit que t’etait un gros vilain….

    #568788
    damino
    Participant
    Maître WordPress
    1243 contributions

    Ta proposition n’est pas correcte car si tu as bien lu c’est la propriété max-width qui pose problème avec IE.
    Donc si la forme actuelle de ton blog te convient (tu gardes ton conteneur à 450 px de large) et insére des images qui rentrent dans ces dimansions (en utilisant Photoshop, Photofilter ou imagewell pour mac).

    Ou alors tu rajoutes l’attribut width=450px à ta balise (je crois que ça fonctionne).

    Petite précision : tu utilises donc la balise HTML img que tu codes directement dans ton article ?

    #568789
    lapinot
    Membre
    Initié WordPress
    24 contributions

    oui j’utilise la malise
    demain j’essai tes conseils !
    merci pour tout.

    #568790
    lapinot
    Membre
    Initié WordPress
    24 contributions

    bon j’ai changé la taille de l’image : problème réglé.
    je suis sous WordPress2….l’insertion d’une image a légèrement changé….on verra tout ça en 2006….reveillon a préparé….bonnes fêtes à tous et merci à toi.

    #568791
    damino
    Participant
    Maître WordPress
    1243 contributions

    Tant mieux que le problème soit résolu. je me demande juste pourquoi ton site est si confidentiel … 🙂
    Tant pis nous ne pourrons pas profiter de tes réalisations.

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.