[Résolu] Bug des apostrophes suite à la mise à jour !

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 44)
  • Auteur
    Messages
  • #510828
    Loutre
    Membre
    Initié WordPress
    10 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.4
    – Version de PHP/MySQL :
    – Thème utilisé : Arras
    – Extensions en place :
    – Nom de l’hebergeur : OVH
    – Adresse du site :

    Problème(s) rencontré(s) :

    Bonjour/Bonsoir,

    Mon problème est des plus simples : je viens d’installer la mise à jour WordPress 3.4, sans aucun soucis (si ce n’est le fameux problème avec DB Cache qu’il fallait supprimer/réinstaller).

    Sauf qu’à l’arrivée, je me retrouve avec un bug sur le texte :

    => les apostrophes sont maintenant précédées d’un espace :fire: Exemple ici…

    http://lestoilesheroiques.fr/2012/06/captain-america-2-la-suite-sest-trouvee-ses-realisateurs.html

    Dans le code source par exemple, on a donc ça : L ’Agence

    C’est le cas pour les titres, le texte, les commentaires, bref toute ma base de données y est passé. Quelqu’un aurait-il une idée pour corriger ce disgracieux bug ? 😇

    Merci !

    #837993
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    J’ai le même problème. As-tu réglé le tien, je ne vois plus tes espaces maintenant?

    #837994
    Loutre
    Membre
    Initié WordPress
    10 contributions

    Malheureusement non.

    Je ne sais pas pourquoi c’est revenu à la normale sur cette alors, que sur sur pleins d’autres (ex : http://lestoilesheroiques.fr/2012/06/iron-man-3-le-premier-poster-du-film-la-nouvelle-armure-diron-man-mark-viii.html ), ce n’est pas le cas.

    Vu que je ne suis pas le seul à avoir ce problème, j’espère que quelqu’un à une explication solution…

    #837995
    Loutre
    Membre
    Initié WordPress
    10 contributions

    Oups, des mots sont passés à la trappe dans mon précédent post.

    Manifestement, il y a aussi la notion de navigateur à prendre en compte : sur Internet Explorer, il n’y a quasiment pas d’espace (sauf pour certaines pages récentes) / sur Firefox c’est un peu moins bien / et sur Chrome c’est un espace partout avant l’apostrophe.

    Vraiment moche comme bug.

    #837996
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Regarde en enlevant les extensions et en mettant le thème par défaut si le problème persiste, je n’ai jamais constaté cela dans la version 3.4.

    #837997
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Je ne pense pas que les extensions ou le thème par défaut soient en cause.
    Le même problème d’affichage est présent sur le site de WordPress France : http://fr.wordpress.org/ .

    #837998
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    C’est confirmé : remettre le thème par défaut et désactiver les extensions ne règle pas le problème chez moi.

    #837999
    Guy
    Participant
    Maître WordPress
    14833 contributions

    En effet, mais.. il faut donc voir quels sont les points communs.

    As tu essayé quand même avec le thème par défaut au moins, le doc type est différent de ce lui que tu utilises et de celui du site de wordpress fr.

    #838000
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Oups, les réponses se sont croisées, est ce que tu peux regarder dans la base de données comment les textes sont écris, ont ils cet espace?

    #838001
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    J’ai essayé avec le « WordPress Default par Michael Heilemann ».

    #838002
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Je parlais du thème TwentyElven en version 1.4, celui de la version 3.4 de WordPress.

    #838003
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Je n’ai jamais regardé dans une base de données…
    Je vais voir comment le faire et après je te réponds. 🙂

    #838004
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Même problème avec TwentyEleven.

    #838005
    Guy
    Participant
    Maître WordPress
    14833 contributions

    Essais tout de même twentyeleven, WordPress default est assez ancien.

    #838006
    angeliquesoleil
    Participant
    Initié WordPress
    17 contributions

    Bon, les messages sont en désordre : j’ai eu le même problème avec TwentyEleven.

15 sujets de 1 à 15 (sur un total de 44)
  • Vous devez être connecté pour répondre à ce sujet.