[Résolu] Bloquer l’enregistrement automatique (Créer un compte)

  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #452883
    nephastef13
    Membre
    Initié WordPress
    31 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : wordpress-mu-1.2.1

    Problème(s) rencontré(s) :

    Bonjour,

    je prépare pour la rentrée scolaire 2007-2008, un multiblog, après avoir testé b2evolution et wpmu, je me suis orienté sur wpmu. Je risque donc de vous ennuyer avec des questions à répétitions 😇

    Voilà mon premier souci, comme nous en sommes en milieu scolaire, je dois pouvoir bloquer l’inscription automatique, seul l’admin doit avoir le droit d’ouvrir de nouveaux blogs. Dans Administration / Options il y a bien une rubrique pour réserver l’enregistrement à certains domaines mais pas pour bloquer l’enregistrement automatique, ou alors je ne l’ai pas trouvé!

    J’ai bien pensé à mettre un domaine bidon (ou mon domaine perso) mais la personne obtient un message disant que l’adresse n’est pas valable, je préférerai un message disant que l’inscription automatique est désactivée.

    Est-ce que ça suffit si je modifie, remplace la page wp-signup.php? par une page disant que l’inscription automatique n’est pas possible? Est-ce qu’il y a d’autres pages à modifier? Pour l’instant je n’ai rien tenté de peur de mettre le souk!

    Avec mes remerciements
    Stéphane

    PS : de mettre mon domaine j’y ai pensé en écrivant la question. Si je trouve des solutions en posant des questions je risque d’abuser :D

    #604291
    bmzoom
    Participant
    Maître WordPress
    937 contributions

    Pendant des essais , il faut mettre en ligne un domaine provisoire .

    Garder le définitif en local . Voilà justement un retour ( est ce que wpmu s’installe en local ? j’ai essayé avec esayphp , et après un refus , je n’ai pas insisté … )

    :D

    #604292
    SCN
    Membre
    Chevalier WordPress
    265 contributions

    Pour installer wpmµ en local, il faut que tu active le mod_rewrite sur easyphp et toucher la bdd en modifiant le password de l’admin qui doit être envoyé par email (ce qui ne peut pas arriver en local ) pour pouvoir l’administrer.

    #604293
    bmzoom
    Participant
    Maître WordPress
    937 contributions

    🙂 Résolu

    #604294
    nephastef13
    Membre
    Initié WordPress
    31 contributions
    bmzoom wrote:
    Pendant des essais , il faut mettre en ligne un domaine provisoire .

    Garder le définitif en local . Voilà justement un retour ( est ce que wpmu s’installe en local ? j’ai essayé avec esayphp , et après un refus , je n’ai pas insisté … )

    :D

    Heu, je ne comprends pas bien la réponse. J’ai besoin, de façon permanente, de bloquer les enregistrements automatiques, pas seulement pendant les essais en local.

    Stéphane

    #604295
    bmzoom
    Participant
    Maître WordPress
    937 contributions

    Ce besoin de bloquage de l’enregistrement … C’est bien l’administrateur de wpmu qui dans admin / blogs / supprime ou créé des blogs .

    En local , je ne vois pas où est ce problème ?

    😐

    #604296
    SCN
    Membre
    Chevalier WordPress
    265 contributions

    Si j’ai bien compris le probléme, tu veux qu’aucun visiteur ne s’inscrit afin qu’il crée un blog sauf si l’administrateur de la plateforme des blogs ajoute ce dernier, ca peut parraitre bête mais si tu supprime le fichier wp-signup.php ou tu le modifie pour qu’il affiche un message disant que les inscriptions sont fermées ça peut marcher non ?!

    #604297
    bmzoom
    Participant
    Maître WordPress
    937 contributions

    C’est pas mon problème , mais il me semble que :

    1 – Supprimer le lien # Créer un nouveau blog , c’est une ligne à trouver et à supprimer du thème
    2 – Modifier signe-up et rediriger vers la page d’accueil complète ( 1 )

    🙂

    #604298
    AmO
    Participant
    Maître WordPress
    4449 contributions

    http://mu.wordpress.org/forums/topic.php?id=4937 (en anglais)

    Moi je te conseille de supprimer, les liens relatifs à l’inscription, ainsi que les fichiers :
    wp-signup.php
    wp-activate.php

    et de éditer le fichier wpmu-settings.php
    de supprimer les lignes :

    if( defined( “WP_INSTALLING” ) == false ) {
    	if( $current_site && $current_blog == null ) {
    		header( “Location: http://{$current_site->domain}{$current_site->path}wp-signup.php?new=” . urlencode( $blogname ) );
    		die();
    	}
    	if( $current_blog == false || $current_site == false )
    		is_installed();
    }

    Et normalement, même en cas de mauvaise URL, il repointe vers la page d’erreur classique de WP, et non la page de création de WPmu !

    #604299
    nephastef13
    Membre
    Initié WordPress
    31 contributions

    Merci à tous, je vais essayer vos solutions à mon retour de vacances.
    😎

    #604300
    thenorth
    Membre
    Initié WordPress
    12 contributions
    AmO wrote:
    de éditer le fichier wpmu-settings.php et de supprimer les lignes :

    if( defined( “WP_INSTALLING” ) == false ) {
    	if( $current_site && $current_blog == null ) {
    		header( “Location: http://{$current_site->domain}{$current_site->path}wp-signup.php?new=” . urlencode( $blogname ) );
    		die();
    	}
    	if( $current_blog == false || $current_site == false )
    		is_installed();
    }

    Et normalement, même en cas de mauvaise URL, il repointe vers la page d’erreur classique de WP, et non la page de création de WPmu !

    Salut AmO,

    je viens de suivre ta démarche et cela ne fonctionne pas chez moi…malgré avoir supprimer ces lignes, la page de création de blog apparaît quand même..ce que je ne souhaite pas..

    As tu une idée ?

    merci à toi..

    🍺
    Thenorth

    #604301
    SCN
    Membre
    Chevalier WordPress
    265 contributions

    Un petit copie/coller de 2 message de ce sujet 😋

    1 – Supprimer le lien # Créer un nouveau blog , c’est une ligne à trouver et à supprimer du thème
    2 – Modifier sign-up.php et rediriger vers la page d’accueil complète

    3 – Modifier wp-activate.php pour que ce fichier renvoi vers l’accueil par exemple.

    Cordialement,
    SCN

    #604302
    thenorth
    Membre
    Initié WordPress
    12 contributions

    Merci SCN pour ta réponse..

    je vais suivre tes conseils..

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.