[Résolu] Besoin de retourner en 4.4.2 car Visual Composer n’est pas compatible (Créer un compte)

  • Statut : non résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #562165
    Rekiem
    Membre
    Initié WordPress
    22 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.5
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place : Visual Composer 4.8.1
    – Nom de l’hebergeur : 1and1
    – Adresse du site : http://www.isolation-et-design.fr

    Problème(s) rencontré(s) :

    Je travaille actuellement sur 2 sites WordPress que j’ai mis à jour en 4.5.
    Le soucis est que pour le premier, je n’est pas effectué de sauvegarde et pour le second, je n’arrive pas à réinstaller la DB de mon back-up.

    Le problème est que Visual Composer n’est pas compatible avec la version 4.5 de WordPress. Je me sert exclusivement des back-end et front-end pour réaliser mes pages mais son chargement tourne dans le vide.

    Je ne dispose donc pas de sauvegardes de mes sites en 4.4.2 (via Updraft backup/restore), la dernière restauration a eu directement sa db passé en 4.5
    J’ai d’ailleurs perdu pas mal d’avancement sur l’autre site car le back-up datait un peu :(

    J’ai téléchargé WordPress en 4.4.2 mais comment l’installer tout en conservant mes plugins, db, et fichiers ?

    Merci d’avance !

    #1052243
    Li-An
    Modérateur
    Maître WordPress
    25401 contributions

    La dernière version de Visual Composer date du 16 avril et j’ai du mal à croire qu’il n’est pas compatible avec WP 4.5 ???
    Un petit tour sur la page du plugin confirme en effet ce plantage.
    Il faut que vous tiriez une leçon: WP 4.5 est en beta depuis des mois et il n’est pas normal qu’un plugin payant populaire ne soit pas compatible à la sortie. Ce genre de plugins devrait être interdit à mon sens – en cas de plantage, tout le contenu d’un site construit avec est carrément mort. Posez vous sérieusement la question de l’utilité d’un tel plugin sur votre site et cherchez des solutions alternatives plus pérennes.

    Ensuite, sur votre problème: il vous suffit de renvoyer les fichiers de WP en écrasant ceux qui existent. Le contenu de votre site ne sera pas affecté. Seul GROS problème: en passant à WP 4.5, il y a peut-être eu de subtiles modifications de base de données et rien ne nous assure à 100% que tout va fonctionner pour le mieux en WP 4.4.2. Je vous conseille donc de conserver une sauvegarde de votre base de données avant toute manip.

    Mais à moyen terme, il faudra peut-être vous passer de Visual Composer, ce qui ne serait pas une mauvaise chose de mon point de vue.

    #1052244
    Rekiem
    Membre
    Initié WordPress
    22 contributions

    Merci de ton retour Li-An

    J’ai résolu mon problème, comme j’avais notifié, ma version installé de Visual Composer était la 4.8.1 est cette version n’était pas compatible avec WP 4.5
    J’ai trouvé la dernière version en 4.11.2 qui elle, est compatible avec la dernière version WP.

    J’ai également résolu mon problème sur mon site qui avait du être restauré avec une db trop vieille (et donc sans mes nombreuses modifications de pages) car mon extension de backup Updraft ne m’affichait que les 3 dernières sauvegardes (dont 1 ne comportait même pas la db).
    Mais ma fallu simplement me rendre en ftp dans le dossier des backups pour récupérer la dernière sauvegarde de la db et de l’installer manuellement via phpMyAdmin.

    Bref c’est un énorme soulagement d’avoir réussi à résoudre ses problèmes extrêmement gênant !

    P.S: Tu peux passer le topic en résolu stp 🙂

    #1052245
    Li-An
    Modérateur
    Maître WordPress
    25401 contributions

    OK. Merci pour les précisions.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.