[Résolu] Activation structure de Permalink –> plus acces au site (Créer un compte)

  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #447657
    Danloreye
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    Alors que mon blog tounait vaille que vaille depuis quelques temps j’ai eu la (mauvaise) idée d’activer les permalinks dans l’onglet options de panel admin.
    Depuis j’ai une erreur interne 80 sur mon site

    J’ai essayé à travers mySql de remettre à blanc le champ structure_permalink mais cela ne change rien.

    Avez vous une idée ?

    Merci

    #573996
    onzeweb
    Membre
    Padawan WordPress
    73 contributions

    Indépendament des bricolages SQL, il faut virer le fichier .htaccess.

    Une fois ton problème réglé, tu trouveras un moyen de créer des liens plus sympa dans cette réponse que j’avais déjà apporté ailleurs : http://www.wordpress-fr.net/support/viewtopic.php?pid=7968#p7968

    #573997
    Danloreye
    Participant
    Initié WordPress
    3 contributions

    merci je regarderai ce sior dès que j’aurai acces par ftp.

    cela veut il dire que WP modifie « à la volée » mon .htaccess ?
    parce que je n’ai que cliqué sur bouton dans le panel admin?

    mon htaccess existait avant deja (pour le page 404)

    #573998
    z720
    Membre
    Maître WordPress
    578 contributions

    Oui mais free ne permet pas d’utiliser toutes les fonctions possible dans un htaccess et, surtout, pas la redirection d’adresse…

    #573999
    benkenobi
    Participant
    Maître WordPress
    4069 contributions

    Une recherche sur le forum t’aurait donné des réponses à tes questions… De plus, une recherche dans notre FAQ aurait même pu te répondre plus rapidement encore. 😉

    #574000
    Danloreye
    Participant
    Initié WordPress
    3 contributions
    #574001
    TeleK
    Membre
    Initié WordPress
    7 contributions

    Je viens de provoquer le m^me problème !

    et c’est réparré ! merci ^^

    #574002
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Salut à toutes et à tous,

    Heuuu, petite question …
    Lisant votre post, j’ai voulu jouer les grands et faire de beaux liens comme vous.
    Quand j’ai changé mon permalien dans les options, j’ai reçu une superbe erreur 404, quelque soit le choix de permalien que j’ai pris. Seule le permalien « de base » a l’air de fonctionner.
    Dans le bas je reçois un message avec les changements que je dois faire dans mon .htaccess

    Est ce qu’un .htaccess est indispensable ?
    Si oui, qu’est ce qui est indispensable dedans ?
    Est-ce que je peux me contenter de créer un htaccess avec ne bloc note et juste les infos du permalien puis le pousser sur le serveur (à la racine de wordpress, je suppose) ?

    Merci de vos z’avis z’avisés,
    Jean-Marc

    #574003
    benkenobi
    Participant
    Maître WordPress
    4069 contributions

    As-tu essayer de mettre /index.php/ devant ta nouvelle structure de permalines ?

    #574004
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Dans le bas de la page des options de permaliens, il était écrit ce que je devais mettre dans le .htaccess. J’ai donc créé un .htaccess avec juste ces lignes et tout s’est remis en place.
    Dans la ligne des options de permaliens il n’y avait pas d’index.php (J’avais choisi le second bouton radio intitulé « Basé sur la date et l’?heure » et il a écrit tout seul « /%year%/%monthnum%/%day%/%postname%/ » dans le champs structure personnalisée.
    Une fois le .htacces créé et sur le serveur, tout s’est bien passé et le index.php figure dans la chaîne dans la barre d’adresse.
    Le .htaccess sert donc, de base, sans faire la structure personnalisée (qui est la même avec l’index.php), à ajouter le index.php dans la chaîne.

    Jean-Marc

    #574005
    benkenobi
    Participant
    Maître WordPress
    4069 contributions

    Donc ton problème semble résolu, non ?

    #574006
    Jean-Marc
    Membre
    Chevalier WordPress
    142 contributions

    Oui, je pense.
    En tout cas pour moi, on peut écrire « Résolu » dans le titre du sujet.

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.