Réparation base de données – wp_options en mauvais état. (Créer un compte)

  • WordPress :5.2
  • Statut : hors support
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #2300597
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bonjour,

    Ma configuration WP actuelle :
    – Version de WordPress : 5.3.2
    – Version de PHP/MySQL : 7.3.12 / 5.1.73
    – Thème utilisé : Sydney (gratuit)
    – Thème URI : https://athemes.com/theme/sydney
    – Extensions en place : Akismet Anti-Spam (4.1.3), Atomic Blocks – Gutenberg Blocks Collection (2.6.0), Forum_wordpress_fr (4.2), Google Analytics Dashboard for WP (GADWP) (6.0.2), Google XML Sitemaps (4.1.0), Jetpack by WordPress.com (8.2.3), Media from FTP (11.05), TinyMCE Advanced (5.3.0), UpdraftPlus – Backup/Restore (1.16.22), Wordfence Security (7.4.6), WP-Optimize – Clean, Compress, Cache (3.0.16), WP Fastest Cache (0.9.0.3)
    – Adresse du site : http://joseph-isola.info/Sardequin (hébergé chez OVH)

    Problème(s) rencontré(s) :

    Bonjour,

    Ce matin, message d’erreur en ouvrant mon Blog WP, problème de base de données endommagée. J’ai donc modifié le fichier wp-config.php en ajoutant la commande conseillée (define(‘WP_ALLOW_REPAIR’, true);) !

    J’ai relancé la page qui s’affichait et effectuée une réparation. Celle-ci s’est déroulée correctement, mais avec un problème non réparé de la table wp_options annoncée en mauvais état (voir fichier joint).

    Message d’erreur après la réparation : wp_options: Table is marked as crashed

    Le blog s’affiche, j’arrive à accéder à la page administration. Ma question est donc la suivante, que faire pour réparer cette table endommagée ? Sachant que j’ai une sauvegarde (quotidienne) udraftplus qui date d’hier matin (le 28), peut-être avec, je l’espère, un base en bon état ! Je n’ai pas tenté d’écrire ou d’éditer un billet pour le moment).

    Merci de votre aide.

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2300601
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bon, je reviens vers vous, j’ai, à tout hasard relancé la page de réparation (je l’avais laissé ouverte) et le résultat est différent :

    La table wp_users est correcte.

    La table wp_usermeta est correcte.

    La table wp_posts est correcte.

    La table wp_comments est correcte.

    La table wp_links est correcte.

    La table wp_options est correcte.

    La table wp_postmeta est correcte.

    La table wp_terms est correcte.

    La table wp_term_taxonomy est correcte.

    La table wp_term_relationships est correcte.

    La table wp_termmeta est correcte.

    La table wp_commentmeta est correcte.

    Réparations effectuées. Veuillez retirer la ligne suivante de votre fichier wp-config.php, pour empêcher que cette page soit utilisée par des utilisateurs non autorisés.

    define('WP_ALLOW_REPAIR', true);

     

    Je suppose que tout fonctionne correctement, et que le problème est réglé ? Merci de me rassurer !

    Bon week-end à toutes et tous !

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.