[Résolu] Remplacement du thème obsolète (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2417796
    Schmol44
    Participant
    Initié WordPress
    37 contributions

    Bonjour,

    Ma configuration WP actuelle : 6.2

    • Version de PHP/MySQL : 7.4.30
    • Thème utilisé : Aqua Blue
    • Extensions en place : Akismet V.5.0  – Really Simple SSL V5.3.3 – WP-Optimise V3.2.6
    • Nom de l’hébergeur : o2Switch
    • Adresse du site : https://blog.henri-cheli.fr/

    Problème(s) rencontré(s) :

    Bonjour,

    Ce qui précède concerne mon Blog en ligne.

    En local, sur Wamp, après être passé en PHP8, j’ai installé le Thème « Twenty Sixteen, » à la place de « Aqua-blue ».

    Voulant le mettre en ligne, est-ce que la solution de le compresser en Zip donnée ci-dessus me concerne ?

    D’avance merci pour la réponse

    #2417817
    momofr@free.fr
    Modérateur
    Maître WordPress
    4921 contributions

    Salut, de quelle solution de compression parles-tu ?

    Pour migrer les sites j’utilise All In One Migration.

    #2417821
    Schmol44
    Participant
    Initié WordPress
    37 contributions

    Bonsoir @momofr@free.fr,

    Je ne veux pas migrer mon site, je souhaite seulement transférer le Thème que j’ai mis au point en local sur une sauvegarde avec Wamp vers mon site en ligne qui pour l’instant à un thème qui fonctionne sous PHP7.4, mais qui est obsolète avec PHP8.

    Je parlais de la réponse de @Lumiere-de-Lune du 31 Août 2022-18h53 à @Sharco 303 du 31 Août 2022-19h46.

    • Cette réponse a été modifiée le il y a 2 semaines et 4 jours par Flobogo. Raison: ajout du lien
    #2418035
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Bonjour,

    Oui, comme l’a indiqué @lumiere-de-lune dans sa réponse sur l’autre sujet, il vous suffit de « zipper » le dossier contenant votre nouveau thème pour pouvoir ensuite l’ajouter dans vos thèmes sur le site en ligne, onglet « Thèmes » > « Ajouter » et choisir l’option « à partir d’une archive au format .zip »

    Mais il faudra probablement passer votre site en ligne en PHP 8 si vous voulez avoir la même configuration qu’en local.

    #2418208
    Schmol44
    Participant
    Initié WordPress
    37 contributions

    Bonsoir @Flobogo,

    Entre-temps, j’ai fait des essais, toujours en local.

    J’ai effectivement transféré le dossier Thème « wp-content/thèmes/Twenty Sixteen sans le « zippé, puisque j’ai enregistré 2 sauvegardes différentes dans « Wamp »pour voir comment ça se passait.

    J’ai fait en sorte de faire 2 dossiers semblables, mais je constate des différences, car dans la seconde installation, je ne retrouve pas le moyen de réinstaller « Meta » et son contenu, ni « Catégories » et son contenu, bref , à force de recherches, j’ai fait une page d’accueil qui ne ressemble pas à la première. La question principale est de reproduire la page d’accueil avec le contenu de « Meta », des Catégories,

    Voir « Blog1 » et « Blog2 »

    Si il y a une solution, je suis preneur.

    D’avance merci pour la réponse.

     

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2418555
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    Je ne comprends pas bien comment vous pouvez avoir 2 résultats différents dans 2 installations de WAMP, si tous les paramètres sont les mêmes.

    Dans ce cas, copiez l’intégralité de la base de données du site de « départ » vers celle du site « destination », si tout le reste est identique.

    #2418630
    Schmol44
    Participant
    Initié WordPress
    37 contributions

    Bonjour @Flobogo,

    Merci pour votre réponse, j’avoue que moi aussi je ne comprends pas …

    Avant de changer de « Thème », j’avais remis un peu d’ordre dans les catégories et également dans la page statique d’Accueil en me servant de la même base.

    Je vais recommencer mes essais, et je vous tiendrai au courant une fois mon blog en ligne en version PHP8  avec son nouveau thème, après avoir beaucoup parcouru les différents tutos. (Entre-temps, j’ai retrouvé le Widget Meta ), j’ai également beaucoup de widgets désactivés)

    Je crois que la solution est par là.

    #2418960
    Schmol44
    Participant
    Initié WordPress
    37 contributions

    Bonsoir @Flobogo,

    J’ai trouvé mon erreur, en fait les bases MySql n’avait pas le même nom. Là, j’ai fait la manip sur 2 pc différents, c’est OK.

    Je suis arrivé à faire mon site, il me reste à le mettre en ligne et peut-être faire quelques finitions.

    #2419148
    Flobogo
    Modérateur
    Maître WordPress
    18599 contributions

    OK, merci d’avoir donné l’explication. Mystère résolu 🙂

9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.