Rediriger vers indexold.php en attendant mise en ligne du site wordpress: erreur

  • WordPress :5.2
  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2280837
    vins1892
    Participant
    Chevalier WordPress
    115 contributions

    Bonsoir à tous,

    je travaille sur la migration d’un site web construit en php vers du wordpress.

    Afin que l’ancien site reste accessible pendant le construction du nouveau site, j’ai renommé le fichier index.php en indexold.php.
    J’ai ensuite modifié le .htaccess en y ajoutant DirectoryIndex indexold.php.

    L’installation de wordpress s’est bien passée.
    Lorsque je veux me connecter au site wordpress, j’ai l’arborescence de fichier, mais pas la console admin.
    Si je supprime ” DirectoryIndex indexold.php ” du .htaccess, j’ai accès à la console admin.

    Avez-vous une idée de comment je peux laisser l’ancien site disponible tout en travaillant sur le nouveau sous wordpress?

    Merci pour votre aide.

    #2281899
    vins1892
    Participant
    Chevalier WordPress
    115 contributions

    Bonjour à tous,

    j’ai toujours le souci ci-dessus.

    J’ai modifié le fichier htaccess comme suit:

    # Page de maintenance
    RewriteEngine on
    RewriteCond %{REQUEST_URI} !/indexold.php$
    RewriteCond %{REMOTE_ADDR} !^109\.88\.xxx\.xxx
    RewriteRule $ /indexold.php [R=302,L]

    Mais cela ne fonctionne pas, on tombe toujours sur le site en construction et pas celui situé à  indexold.php.

    J’ai trouvé mon adresse IP sur https://mon-ip.io/
    Lorsque je me cherche via cmd –> ip config, je ne retrouve rien de similaire à 109.88.xxx.xxx …
    J’ai par contre des adresses IP différentes sous les rubrique Adresse IPv4 ou Masque de sous-réseau, …

    Merci pour votre aide.

     

    #2282109
    vins1892
    Participant
    Chevalier WordPress
    115 contributions

    Bon, j’avance: je suis bien redirigé vers indexold.php, mais le site apparait sans formatage et chaque lien de menu pointe vers la même page indexold.php …

    Voici pour htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Options +FollowSymlinks
    RewriteEngine on
    RewriteCond %{REQUEST_URI} !/indexold.php$
    RewriteCond %{REMOTE_HOST} !^192\.168\.xxx\.xxx

    RewriteRule $ /indexold.php [R=302,L]

    # END WordPress

    Personne pour m’aider?

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.