« Publier » ne fonctionne pas (Créer un compte)

  • WordPress :5.7
  • Statut : non résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #2375484
    hugo38
    Participant
    Initié WordPress
    16 contributions

    Bonjour,
    <div id= »fwf_content »>Ma configuration WP actuelle :

    • – Version de WordPress : 5.7.1
    • – Version de PHP/MySQL : 7.3.27 / 5.5.5
    • – Thème utilisé : Astra
    • – Thème URI : https://wpastra.com/
    • – Extensions en place : Forum_wordpress_fr (4.2), Insert Pages (3.6.0), Media File Sizes (1.8), Polylang (3.0.3), Post Types Order (1.9.5.6), UpdraftPlus – Backup/Restore (1.16.53), WPS Cleaner (1.6.4)
    • – Adresse du site : https://hu.go.yo.fr
    • – Nom de l’hébergeur : Apache

    </div>
    <div></div>
    Problème(s) rencontré(s) :

    Lorsque je crée une page (ou un article) ou que j’en édite une, il arrive que le bouton « publier » sois sans  effet : rien ne se passe, la page n’est pas créée. La même action à un autre moment fonctionne parfaitement. Est-ce quelque-chose d’expliquabet et/ou que je peux améliorer ?

    #2375492
    Li-An
    Participant
    Maître WordPress
    28497 contributions

    Bonjour, il nous manque le nom de l’hébergeur. Vous pourriez faire des tests en désactivant les extensions sauf une extension de maintenance mais il y a de fortes chances que ce soit un problème lié à l’hébergement de votre base de données. Vérifiez quand même que vous n’avez pas atteint votre quota pour la base de données et/ou les fichiers.

    #2375496
    hugo38
    Participant
    Initié WordPress
    16 contributions

    Merci, c’est fort possible car c’est un hébergement gratuit ¨PlanetHoster » dont je viens de trouver l’outil de statistique. Bizarrement j’ai 2 bases de données de 3 et 13 MB alors que je ne fais tourner qu’un seul site wordpress. Je ne trouve pas l’info sur le quota alloué mais je vais chercher ça.

    #2375499
    Loraga
    Participant
    Chevalier WordPress
    121 contributions

    Bonjour,

    Une fois que vous aurez trouvé le quota de votre base de données, vous pourrez le comparer avec la taille du volume de vos données en allant, depuis l’admin WordPress, dans le menu Outils > Santé du site puis l’onglet central « Informations ».

    Sur cette page, vous aurez un onglet « Répertoires et tailles » et notamment la ligne « Taille de la base de données » qui vous indiquera le volume qu’occupe actuellement WordPress dans sa base de données. Ça peut servir… 🙂

    #2375501
    Li-An
    Participant
    Maître WordPress
    28497 contributions

    En même temps, je vous déconseille fortement de faire tourner un WP sur un hébergeur « gratuit ». Il ne faut pas vous attendre à ce que ça tourne nickel tout le temps. Si c’est le serveur de la base qui déconne, vous n’y pouvez rien… et vous ne pouvez même pas râler.

    #2375503
    Loraga
    Participant
    Chevalier WordPress
    121 contributions

    Si c’est le serveur de la base qui déconne, vous n’y pouvez rien… et vous ne pouvez même pas râler.

    Quand on paie pour un service on a au moins le privilège de pouvoir râler sur leur service client haha

    Effectivement, il ne faut pas trop en attendre de la part d’un hébergeur gratuit, mais bon, un service, qu’il soit gratuit ou non à quand même le devoir de fonctionner convenablement… en théorie ^^

    #2375506
    hugo38
    Participant
    Initié WordPress
    16 contributions

    Merci beaucoup,

    Je ne sais toujours pas où en sont les quotas spécifiques des BDD mais je pèse pas bien lourd :
    Taille du répertoire de WordPress 50,01 Mo

    Taille du répertoire des téléversements 10,48 Mo

    Taille du répertoire des thèmes 23,14 Mo

    Taille du répertoire des extensions 36,11 Mo

    Taille de la base de données 3,36 Mo

    Taille totale de l’installation 123,11 MoAprès en utilisation disque j’en suis à 164.71 MB / 750MB Espace Disque donc en principe j’ai encore de la marge.

    • Cette réponse a été modifiée le il y a 3 années et 2 mois par hugo38. Raison: suppression du code html mal interprété
    #2375595
    hugo38
    Participant
    Initié WordPress
    16 contributions

    Bon visiblement je n’aurai pas le fin mot de l’histoire mais il semble qu’en changeant de navigateur je puisse à nouveau mettre à jour mes articles. Si quelqu’un à une idée du pourquoi ce sera intéressant, mais dans l’immédiat je vais m’en contenter.

    #2375597
    Li-An
    Participant
    Maître WordPress
    28497 contributions

    Il n’y a pas de raison particulière. Si vous appuyez sur le bouton, ça fait la même chose au niveau du moteur php (et donc du serveur). Ou alors votre navigateur est tout pourri et ne reconnait pas normalement les boutons 🙂

    #2375615
    hugo38
    Participant
    Initié WordPress
    16 contributions

    Ben c’est curieux : rien ne se produisait sous chrome, puis ça a marché depuis un autre PC, donc j’ai réessayé mais toujours rien depuis mon PC principal, alors j’ai tenté sous Edge et ça marchait, jusqu’à ce que je réessaye sous Chrome où ça a continué de marcher. J’ai du mal à croire à une coincidence mais je n’ai pas d’explication technique.

    #2375616
    Li-An
    Participant
    Maître WordPress
    28497 contributions

    La seule explication c’est que le serveur est capricieux. Il ne faut pas chercher plus loin.

    #2375637
    hugo38
    Participant
    Initié WordPress
    16 contributions

    En fait j’ai souvent (systématiquement ?) le message d’erreur

    « La mise à jour a échoué. La réponse n’est pas une réponse JSON valide. »

    avant blocage de la mise à jour. De là la mise à jour n’est plus possible et le changement de navigateur est salvateur. Je pense que qqchose demeure en mémoire du navigateur.

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.