[Résolu] Publication échouée : La réponse n’est pas une réponse JSON valide

  • WordPress :5.2
  • Statut : résolu
13 sujets de 16 à 28 (sur un total de 28)
  • Auteur
    Messages
  • #2285462
    ferman
    Participant
    Maître WordPress
    1531 contributions

    mais pour Liokase qui a créé ce sujet il n’a peut être pas de sauvegarde …

    C’est pour ça qu’on demande toujours d’ouvrir un nouveau sujet même si les problèmes semblent identiques: les réponses qui valent pour les uns ne valent pas forcément pour les autres.  Pour vous (donc @Ahote) je supprimerais  tout (fichiers, dossiers , base de données) et referais une installation wordpress fraiche  en 5.2.4. Peut-être que pour @liokase le “downgrade” suffirait ou même une restauration de sauvegarde s’il en a.

    Vous n’êtes pas les seuls: voir ici et ici

    EDIT. écrit (mais ouvert et non envoyé) avant de voir les deux réponses précédentes que je découvre seulement en envoyant.

    • Cette réponse a été modifiée le il y a 3 semaines et 5 jours par ferman.
    #2285490
    Liokase
    Participant
    Initié WordPress
    3 contributions

    Bonjour,

    J’ai donc ré-installer WordPress en 5.2.4 et tout fonctionne correctement.

    Merci a tous pour vos réponses.

    Passez une excellente journée

    #2286104
    Ahote
    Participant
    Initié WordPress
    10 contributions

    bonjour a tous

    pour ma part j’ai réinstallé directement en 5.3 avec une nouvelle bdd

    et ca fonctionne 😉 merci beaucoup

     

    #2286108
    ferman
    Participant
    Maître WordPress
    1531 contributions

    Bonjour

    pour ma part j’ai réinstallé directement en 5.3 avec une nouvelle bdd

    Si vous repartez de zéro (avec une nouvelle bdd) heureusement que ça marche. En vous disant de réinstaller 5.2.4 j’avais déjà oublié que votre site était vierge. Le problème arrive avec des sites ayant déjà du contenu et avec plugins, thèmes. Et ce n’est pas systématique, encore une fois heureusement. Mais il y a un risque de plantage loin d’être nul. Comme c’est une mise à jour majeure de wordpress c’est un peu normal. Cela s’arrangera avec un peu de temps.

    #2286534
    YSATIS
    Participant
    Initié WordPress
    4 contributions

    Bonjour,

    J’ai le même problème (Mise à jour échouée. Message d’erreur : La réponse n’est pas une réponse JSON valide.)

    et aussi quand on modifie ou qu’on continue à écrire une page ou un article, le curseur revient en début de page.

    Moralité : la version WordPress 5.3 comporte des bugs.

    J’ai remis en version 5.2.4 et tout va bien, aucun problème.

    #2286535
    audrasjb
    Participant
    Initié WordPress
    11 contributions

    Bonjour à toutes et à tous,

    Ayant co-dirigé WP 5.3, je suis preneur de ce type de remontée de bugs, merci pour vos messages.

    Nous savons déjà qu’il ne s’agit pas d’un bug directement lié à WP 5.3 mais d’un bug indirect car causé par une extension n’ayant pas suivi le développement du CMS. Le problème, c’est qu’il y a des dizaines de milliers d’extensions gratuites et payantes sur le marché, il est donc difficile d’identifier les extensions fautives pour demander à leur auteur d’apporter des correctifs (ou recommander des extensions alternatives si l’auteur ne met plus son extension à jour).

    Pourriez-vous s’il vous plaît ajouter la liste de vos extensions à vos rapports de bugs ? Cela nous permettrait de pouvoir reproduire les soucis et éventuellement contacter les éditeurs/auteurs d’extensions présentant des bugs vraiment important afin qu’ils puissent corriger leur code.

    Pour obtenir la liste de vos extensions très rapidement, vous pouvez aller dans votre back-office, puis dans Outils > Santé du site > onglet Informations puis copier/coller le contenu de la section “Extensions actives”.

    Merci par avance pour vos contributions 🙂

    Jb Audras

    • Cette réponse a été modifiée le il y a 2 semaines et 5 jours par audrasjb.
    #2286537
    audrasjb
    Participant
    Initié WordPress
    11 contributions

    Oubli de mon dernier message : en plus des extensions activées, le nom de l’hébergeur peut aider.
    En effet, ce n’est pas très courant, mais certains hébergeurs peuvent mettre en place des règles occasionnant des problèmes pour l’API Rest de WordPress.

    Autre piste fréquemment rencontrée : assurez-vous d’avoir mis à jour vos extensions de sécurité. Certaines extensions ont été mises à niveau après WP 5.3 pour autoriser certaines routes Rest API.

    Bonne soirée,
    Jb

    #2287359
    Ahote
    Participant
    Initié WordPress
    10 contributions

    bonjour,

     

    désolé pour la réponse tardive

    pour ma part je n’avais que peu d’extensions (w3 total cache et akismet )

    pour hébergement comme je le disait :

    c’est auto hébergé sur plateforme AMD

    Debian 10 / Nginx / MariaDB / php7.0

     

    #2287377
    YSATIS
    Participant
    Initié WordPress
    4 contributions

    Rebonjour,

    Finalement, le mieux est de mettre à jour le site en version WordPress 5.3 et d’ajouter l’extension Classic Editor.

    Pour ma part, j’avais :

    • le curseur qui revenait toujours en début de page d’où l’impossibilité de modifier ou d’écrire que ce soit dans une page ou un article.
    • le problème de mise à jour —> publication échouée : la réponse n’est pas une réponse json valide.

    Maintenant tout va bien, j’en conclue donc que ce n’est pas la nouvelle version 5.3 qui crée des soucis mais bien l’éditeur Gutenberg qui n’est pas au point.

    YSATIS

    #2287380
    PhiLyon
    Modérateur
    Maître WordPress
    24147 contributions

    Bonjour.

    Il y a une citation qui dit

    Il n’y a pas de mauvais outils, il n’y a que de mauvais ouvriers

    Vus les milliers de sites tournants en WordPress 5.3 et l’éditeur Gutenberg, s’il y avait un problème, tu ne serais pas le seul à t’en plaindre sur ce forum ou un autre.

    🙂

    #2287442
    YSATIS
    Participant
    Initié WordPress
    4 contributions

    Ce lien m’a aidé très fortement à résoudre mon problème justement!

    https://www.dominicdesbiens.com/articles/comment-resoudre-le-probleme-de-mise-a-jour-des-articles-avec-wordpress-5-gutenberg.html

     

    Et comme dirait le proverbe : il n’y a que la vérité qui blesse !

     

    #2289136
    YSATIS
    Participant
    Initié WordPress
    4 contributions

    Waouh ! Je viens de mettre à jour mon site en WordPress 5.3.1 et je vois que mon problème de curseur qui revenait toujours en début de page ou d’article est résolu ! J’avais donc raison, il y avait bien un problème.

    Avant de faire la mise à jour, j’ai pris le soin de bien supprimer le plugin classic editor. Il a eu le mérite quand même que je l’essaie !

    Je vais donc pouvoir réécrire ou modifier d’autres articles ou pages.

     

     

    #2289143
    audrasjb
    Participant
    Initié WordPress
    11 contributions

    Bonjour Ysatis,

    Oui, c’est effectivement un bug issu de WP 5.3 que nous avons corrigé avec WP 5.3.1.

    Cette version mineure de sécurité et de maintenance corrige 4 failles de sécurité et 46 bugs + petites améliorations.

    WordPress 5.3.1 Security and Maintenance Release

    Bonne journée,

    Jb Audras

     

     

13 sujets de 16 à 28 (sur un total de 28)
  • Vous devez être connecté pour répondre à ce sujet.