Protection “mot de passe” inefficace” (Créer un compte)

  • WordPress :5.4
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #2344343
    Dusty38
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    En ouvrant mon site sur le nouvel ordinateur d’un ami, j’ai eu la surprise de ne pas avoir besoin de mes mots de passe. Les pages s’affichent pourtant “protégées”. Sur un autre ordinateur, la protection fonctionne, et même du mon ordinateur personnel tant que je suis pas connecté préalablement en administrateur.

    Si vous avez une idée du problème, en vous remerciant.

    #2344347
    momofr@free.fr
    Modérateur
    Maître WordPress
    3913 contributions

    Salut, sans le contexte il est difficile de savoir de quoi ça peut venir. Tu parles de pages protégées par mot de passe ou de pages Privées ?

    L’ordinateur de ton ami tourne sous quel système/navigateur ? Javascript est il désactivé ?

    #2344352
    Dusty38
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Merci de votre réponse rapide!

    Protection par mot de passe. Système: W10 familial. Javascript désactivé?… euh… je ne sais pas…

    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par Dusty38.
    #2344366
    Dusty38
    Participant
    Initié WordPress
    14 contributions

    Je ne sais pas comment accéder à Javascript. Je lis des tas de trucs sur internet, pas moyen de trouver le rapport avec ce que j’ai.

     

    Sinon, quel rapport? Quoi qu’il en soit, ça veut dire qu’on peut entre dans mon site (presque) comme on veut.

    #2344424
    Li-An
    Modérateur
    Maître WordPress
    24675 contributions

    Bonjour,

    Il y avait un questionnaire affiché, c’est dommage de ne pas l’avoir complété entièrement, car il peut aider à vous aider.
    Alors, merci de le copier-coller et compléter du mieux possible dans votre prochain post :

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hébergeur :
    – Adresse du site :

    Si vous ne savez pas répondre, vous pouvez installer cette extension: https://wordpress.org/plugins/forum-wordpress-fr/ et ensuite, récupérez les informations sur le tableau de bord de l’admin de votre site pour les copier-coller ici.

    Si besoin, consultez cette vidéo : https://youtu.be/XOFGpSbNCmY

    #2344436
    Dusty38
    Participant
    Initié WordPress
    14 contributions

    Excusez-moi pour le contre-temps.
    <div id=”fwf_content”>Ma configuration WP actuelle :

    • – Version de WordPress : 4.9.14
    • – Version de PHP/MySQL : 5.5.9-1ubuntu4.21 / 5.5.55
    • – Thème utilisé : Twenty Seventeen
    • – Thème URI : https://wordpress.org/themes/twentyseventeen/
    • – Extensions en place : Akismet Anti-Spam (4.1.5), All-in-One WP Migration (7.22), Classic Editor (1.5), Forum_wordpress_fr (4.2), WP Content Copy Protection & No Right Click (2.3)
    • – Adresse du site :
    • – Nom de l’hébergeur : Apache/2.4.7

    On peut s’arranger autrement pour le nom de site?

    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par Dusty38.
    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par Dusty38.
    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par Dusty38.
    #2344437
    Li-An
    Modérateur
    Maître WordPress
    24675 contributions

    Vous pouvez le mettre en réponse privée pour le cacher au public (voir case à cocher). Il nous la faut parce que ma prochaine question ça va être : On peut voir un exemple de page problématique ?

    En fait, il y a déjà un premier problème important : vous n’êtes absolument pas à jour aussi bien du point de vue WP que php et ça explique peut-être bien des choses. On peut avoir le nom de l’hébergeur.

    #2344441
    Dusty38
    Participant
    Initié WordPress
    14 contributions
    Cette réponse a été marquée comme privée.
    #2344443
    Li-An
    Modérateur
    Maître WordPress
    24675 contributions

    Vous n’avez pas caché votre URL. Vous voulez que je le fasse ? Si votre hébergeur vous conseille de ne pas mettre à jour, fuyez le comme la peste. C’est un moyen détourné de cacher son incapacité personnelle à améliorer son infrastructure. Et ça vous oblige à utiliser un WP bridé puisque php 7+ augmente la vitesse du moteur de manière significative. C’est Altipiano ? Ils ont l’air très mauvais dans leur champ de compétence puisque j’ai eu du mal à les trouver sur le Web.

    #2344445
    Dusty38
    Participant
    Initié WordPress
    14 contributions
    Cette réponse a été marquée comme privée.
    #2344454
    momofr@free.fr
    Modérateur
    Maître WordPress
    3913 contributions

    L’hébergement est assuré par Coolicehost. Conseiller de ne pas faire les mises à jour de la part d’un hébergeur c’est du jamais vu, à priori une bien mauvaise idée… donc un hébergeur incompétent au minimum. Mon conseil c’est d’en changer si c’est bien vrai.

    Déjà tu as un certificat SSL inclus dans ton abonnement il faut l’activer et passer ton site en HTTPs au minimum, faire les mises à jour, passer en php7.3/7.4 et tester à nouveau.

    Depuis mon Mac, sous Firefox, Chrome ou Safari impossible de voir tes pages protégées.

    Js désactivé c’est pareil. Si tu as fais un accès sur tes pages protégées depuis ce poste les sessions et mot de passes peuvent être enregistrés ce qui explique que l’on peut accéder au pages. Change tes mots de passes et réessaye depuis ce poste, si ça ne passe plus c’est là qu’était le problème.
    Pour tes images il faut supprimer les URL des médias dans le sitemap du site, utilises une extension de SEO qui te permettra de bien paramétrer ton sitemap ou fabrique-le toi-même avec un outil en ligne.

    #2344471
    Dusty38
    Participant
    Initié WordPress
    14 contributions
    Cette réponse a été marquée comme privée.
    #2344473
    Li-An
    Modérateur
    Maître WordPress
    24675 contributions

    Est-ce que les images sont dans les pages protégées ? (ne mettez pas les messages en privé s’ils ne contiennent aucune information sensible svp. C’est un forum public qui doit permettre d’aider tout le monde qui le consulte.

    Apache n’est pas le nom d’un hébergeur mais l’outil utilisé pour le serveur de votre hébergeur. Vous payez bien une société pour votre hébergement ?

    #2344478
    Dusty38
    Participant
    Initié WordPress
    14 contributions

    j’ai mis un WP Content Protection pour la protection des images.

    Je paye en effet une société.

    C’est quoi SEO, et lequel dois-je prendre?

     

    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par Dusty38.
    • Cette réponse a été modifiée le il y a 8 mois et 1 semaine par Dusty38.
    #2344492
    Li-An
    Modérateur
    Maître WordPress
    24675 contributions

    Il faudrait être plus clair, il y a une ambiguité. Qui payez-vous pour votre site et quelles sont ses responsabilités ?

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.