[Résolu] Problèmes formulaire de contact – Utilisateur obligé d’envoyer 2 fois message (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
  • Ce sujet contient 2 réponses, 2 participants et a été mis à jour pour la dernière fois par spip93, le il y a 1 semaine.
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2388674
    spip93
    Participant
    Padawan WordPress
    71 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.21
    • Thème utilisé : TheRatio
    • Extensions en place :
      Async JavaScript Version 2.21.08.31
      Autoptimize Version 2.9.2
      Duplicate Page Version 4.4.5
      Elementor Version 3.4.7
      Elementor Pro Version 3.5.1
      Formidable Forms Version 5.0.12
      Formidable Forms Pro Version 4.10.02
      Formidable Views Version 4.0.03
      Kirki Customizer Framework Version 3.1.9
      Loco Translate Version 2.5.5
      MC4WP: Mailchimp for WordPress Version 4.8.6
      Meta Box Version 5.4.8
      One Click Import Demo Content Version 1.0
      OT Portfolios Version 1.0
      Proxy Cache Purge Version 5.0.3
      reCaptcha by BestWebSoft Version 1.65
      Safe SVG Version 1.9.9
      Slider Revolution Version 6.5.4
      UpdraftPlus – Backup/Restore Version 2.16.63.25
      Wordfence Security Version 7.5.6
      WP Rocket Version 3.9.0.5
      WPS Hide Login Version 1.9.1
      Yoast SEO Version 17.5
      Yoast SEO Premium Version 16.3
    • Nom de l’hébergeur : 02switch
    • Adresse du site : https://www.cjdeco.fr

    Problème(s) rencontré(s) :
    Bonjour à tous et à toutes,

    J’ai un souci avec la page contact du site de ma femme

    Il y a 3 formulaires sur la page contact (et sur la panneau latéral) :

    • Demande de devis
    • Demande de rappel
    • Demande de RDV

    Après avoir fait des tests, je me rends compte qu’il faut que les utilisateurs remplissent 2 fois le formulaire pour qu’il soit (finalement) envoyé.
    Concrètement, ils remplissent le formulaire (peu importe lequel, j’ai le problème sur les 3), ils cliquent sur Envoyer, ça rafraichit la page, mais ça n’envoie pas de mail.
    Pour que ça l’envoie, il faut qu’ils remplissent à nouveau le formulaire et qu’ils cliquent sur Envoyer.
    Là, ça affiche la page Merci qui indique que le message a été envoyé.
    Pour info, j’utilise le plugin Formidable Forms.

    Savez-vous d’où vient le problème et (surtout) comment le résoudre ?

    Je vous remercie d’avance pour vos réponses.

    #2388700
    Li-An
    Modérateur
    Maître WordPress
    25623 contributions

    Bonjour, désactivez les autres extensions, mettez un thème par défaut et testez pour voir. Vous pouvez laisser une extension de maintenance pour ne pas effrayer vos visiteurs et utiliser https://www.echodesplugins.li-an.fr/plugins/widget-importer-exporter/ pour sauvegarder le réglage de vos widgets. Vous pouvez aussi regarder dans Outils>Santé du site s’il n’y a pas un problème important.

    #2388894
    spip93
    Participant
    Padawan WordPress
    71 contributions

    Bonjour Li-An,

    J’ai fini par trouver d’où venait le problème : c’était les formulaires.

    En effet, pour une raison inconnue, quand on cliquait sur Envoyer, les données saisies n’étaient pas envoyées.
    Par conséquent, il y avait un message comme quoi les champs étaient vides.

    J’ai alors désactivé plusieurs extensions, mais sans succès.

    Pour finir, j’ai refait les 3 formulaires en partant de 0.

    J’ai bien fait puisque maintenant ça fonctionne.

    Merci pour votre réponse

     

    Bonne journée 😉

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.