[Résolu] Problème WordPress sur FTP (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
14 sujets de 16 à 29 (sur un total de 29)
  • Auteur
    Messages
  • #2393550
    pasglop
    Participant
    Chevalier WordPress
    437 contributions

    Ah ben là, effectivement, c’est pas top. Donc, télécharge une version propre de WP sur ton ordi, dézippe là et transfère le .htaccess propre via FTP sur son environnement.

    #2393555
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    Je suis désolé avec mes problèmes mais maintenant je ne peux plus entrer dans mon site et j’arrive à ce résultat. Comme j’ai modifié les adresses dans l’onglet général des réglages de mon site, je ne peux plus y entrer. Qqn a une solution?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2393557
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    j’ai téléchargé la 5.8.3 mais pas trace du htaccess

    #2393562
    Flobogo
    Modérateur
    Maître WordPress
    18338 contributions

    Bon, si on pouvait arrêter de tourner en rond …

    Modifier l’adresse dans les réglages WP, ou ajouter les 2 lignes déjà indiquées dans le wp-config.php, c’est pareil

    Donc, on recommence :

    • dans le dossier www, vous placez directement les 3 dossiers wp-admin / wp-content / wp-includes et les 16 fichiers associés + wp-config.php
    • vous ne mettez pas dans ce dossier le fichier .htaccess mais vous le gardez en copie sur votre ordinateur (à télécharger, puis à supprimer)
    • vous supprimez index_OVH.html
    • dans le fichier wp-config.php, vous mettez bien les 2 lignes déjà demandées, surtout avec https et pas http

    A partir de là, l’accueil doit être accessible, les autres pages en erreur 404.
    Quand on en sera là, on rectifiera les URL de l’ensemble du site avec le script d’Interconnectit (tuto)

    Je précise pour le fichier .htaccess → non, il n’existe pas par défaut dans une install’ vierge de WP
    Il se re-créera automatiquement dès que vous aurez accès à l’admin’, en enregistrant les permaliens.

    #2393566
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    J’ai fait tout ce que vous m’avez suggéré mais je tombe dés le départ en 404 The requested URL was not found on this server.

    #2393571
    Flobogo
    Modérateur
    Maître WordPress
    18338 contributions

    je tombe dés le départ en 404 The requested URL was not found on this server.

    Même l’accueil ?

    Parce que là, ce soir, le site est accessible sur l’URL de base, aussi bien en HTTP qu’en HTTPS, mais on règlera ça ensuite. Je vois une image avec le texte « Désolé, nous travaillons actuellement sur le site« , donc vous avez réussi à réimplanter le site. Il n’y a plus de index_OVH.html, ni de listings des dossiers en Index_Of avant d’atteindre le site par l’URL à rallonge !

    Donc, maintenant que vous êtes là, suivez le tuto pour utiliser avec le script d’Interconnectit et changer toutes vos anciennes URL (celle à rallonge avec /site.sc-harmonie.www/wordpress) à remplacer par l’adresse normale en https

    Et dès que vous avez accès à l’admin (ce qui doit être le cas si vous avez mis une extension de maintenance ??), allez à réglages > permaliens, choisissez ce qui vous convient (en général, avec nom de la publication), et enregistrez.

    #2393632
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    j’ai bien regardé le tuto d’interconnectit mais évidemment je suis largué à un moment…

    D’abord téléchargez le et installez le à la racine de votre site en renommant votre dossier. Dans mon cas, je lui ai donné le nom migrer. Vous lancerez le script en utilisant l’URL:

    http://nom-de-mon-site.fr/migrer/
    
    J'ai donc écrit http:// sc-harmonies.com/migrer sur Google mais je tombe sur un fichier txt ou est inscrit bookmark88∞4∫…Ã√Aˇ‹ApplicationsMAMPhtdocsSearch-Replace-DB-master$0@1SàƒJö¡µxàò®A√ #PÄ.
     J'en suis là.
    
    #2393633
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    Ce qui est assez curieux, c’est que ma page d’accueil est en 404, pas le reste.

    #2393685
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    Bonsoir,

    j’ai avancé dans ma galère. J’en suis à l’écran de « search and replace » mais lors du « Dry Run », il m’ajoute ce qui semble être un message d’erreur qui m’indique qu’aucun changement ne sera fait…

    Savez-vous d’ou cela peut venir?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2393693
    Flobogo
    Modérateur
    Maître WordPress
    18338 contributions

    lors du « Dry Run », il (…) m’indique qu’aucun changement ne sera fait…

    C’est normal : comme indiqué dans le tuto, le « dry run« , c’est un test.

    * * * * * * * * * * * * * * *

    Bon, après vérification, votre site est en ligne ce soir. 🙂

    Il reste 2 choses à faire : rediriger toutes les URL HTTP vers celles en HTTPS (pas uniquement celle de l’accueil), et éviter qu’on accède au listing de vos dossiers.

    • pour le passage complet en HTTPS :

    Par FTP ou dans la gestion de fichiers de l’hébergeur, accédez à votre fichier .htaccess et ouvrez-le. Il faut ajouter ces lignes à la suite de ce qui est déjà présent … mais n’oubliez pas de remplacer « monsite.com » par ce qui convient 😉

    # Redirection vers HTTPS 
    RewriteCond %{SERVER_PORT} ^80$ [OR]
    RewriteCond %{HTTPS} =off
    RewriteRule ^(.*)$ https://www.monsite.com/$1 [R=301,L]
    
    # Redirection du non-www vers www en HTTPS
    RewriteCond %{HTTP_HOST} ^monsite.com [NC]
    RewriteRule ^(.*)$ https://www.monsite.com/$1 [R=301,L]

    Merci à wpmarmite pour le code.

    • pour empêchez d’accéder au listing de vos dossiers :

    Toujours dans le même fichier .htaccess, vous ajoutez à la suite :

    Options -Indexes

    Bien sûr, enregistrez le fichier .htaccess et renvoyez-le à la place de l’ancien.

    Et cette fois, tout devrait être bon.

     

     

    #2393709
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    Bonjour,

    c’est super, merci Flobogo, respect à la Bourgogne! j’ai juste Index Of qui apparait toujours sur les résultats des moteurs de recherche au lieu du nom de mon site sc-harmonies. De plus, je remarque que pour accéder à mon site via les moteurs de recherche, il faut taper sc-harmonies.com au lieu de sc-harmonies tout court. Savez-vous comment corriger ce problème?

    Merci encore pour votre aide précieuse.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2393776
    Flobogo
    Modérateur
    Maître WordPress
    18338 contributions

    respect à la Bourgogne!

    🙂

    j’ai juste Index Of qui apparait toujours sur les résultats des moteurs de recherche au lieu du nom de mon site

    Pas d’inquiétude, il faudra patienter quelques jours (ou semaines), le temps que les petits robots de GG et autres viennent se promener sur votre site et voient les nouvelles URL. On peut accélérer ça en demandant à GG de ré-indexer le site, à partir de la « search console », mais je ne suis pas très douée, je ne saurais pas vous en dire plus.

    je remarque que pour accéder à mon site via les moteurs de recherche, il faut taper sc-harmonies.com au lieu de sc-harmonies tout court.

    Probablement pour la même raison que ci-dessus. Pour l’instant, pour les robots, « sc-harmonies tout court », ça renvoie encore à l’ancienne URL (la fameuse URL à rallonge 😉  Si tout va bien, ça devrait rentrer dans l’ordre dans les semaines à venir.

    #2393812
    eriketrock
    Participant
    Initié WordPress
    15 contributions

    Merci pour tout, Flobogo. A bientôt pour d’autres problèmes peut-être!

    #2393862
    Flobogo
    Modérateur
    Maître WordPress
    18338 contributions

    De rien. Bonne continuation, j’espère, avant un éventuel problème. 🙂

    Je passe le sujet en « résolu ».

14 sujets de 16 à 29 (sur un total de 29)
  • Vous devez être connecté pour répondre à ce sujet.