[Résolu] Probleme url WP en local (Créer un compte)

  • WordPress :4.8.2
  • Statut : résolu
12 sujets de 1 à 12 (sur un total de 12)
  • Auteur
    Messages
  • #1932536
    Ethanlog17
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    J’ai installé un site WP en local.

    Quand je clique sur localhost, IE s’ouvre et j’obtiens une erreur 404.

    Je tape l’url http://localhost:8080 et cela fonctionne.

    Je suis donc allé dans les settings WP et en:

    Wordpress address et Site url, j’ai donc noté: http://localhost:8080. Je sauvegarde et relance cela ne fonctionne pas.

    Je me connecte a Php, BDD wordpress, dans wp-options, je fais la meme modification, je sauvegarde. Et toujours la meme erreur.

    Sauriez vous pourquoi ?

    Un grand merci par avance.

    Ps : c’est quoi la différence entre wordpress addresse et site url ?

    Merci!

    #1932541
    JeanSeb – Long Watch Studio
    Participant
    Initié WordPress
    32 contributions

    Bonjour Ethanlog17

    Avant de pouvoir indiquer une réponse appropriée, il nous faut des informations que tu ne fournis pas.

    Tu indiques te connecter à « PHP » … mais quel logiciel utilises-tu ?

    Indique le logiciel que tu utilises pour la partie mise en ligne WEB ( easyphp, IISS, autre … )

    #1932559
    Ethanlog17
    Participant
    Initié WordPress
    5 contributions

    Bonjour JeanSeb,

    Voici les infos, j’utilise Wampserver pour me connecter à « Localhost » puis à Php.

    Cdlt,

    Ethan

    #1932567
    JeanSeb – Long Watch Studio
    Participant
    Initié WordPress
    32 contributions

    Ok

    En cherchant rapidement, il y a déjà un tuto pour installer wordpress avec wampserver :

    http://geekhebdo.com/installer-wordpress-en-local-avec-wamp/

    Il est peut-être utile de s’y référer en premier et check toutes les étapes.

     

    #1932590
    Ethanlog17
    Participant
    Initié WordPress
    5 contributions

    Merci, mais en fait, l’installation s’était bien passée.

    D’ailleurs, j’ai bien mon site en faisant http://localhost:8080

    Surement un problème de paramétrage.. As tu une autre idée?

    #1932592
    strabsquad
    Participant
    Initié WordPress
    8 contributions

    Tu as mis ton install WordPress à la racine du dossier www/ ou tu as bien fais attention à crée un sous répertoire pour y déposer ton install ?

    En dehors de ça, tu peux également rebasculer en http://localhost dans les paramètres de wamp

    #1932610
    Ethanlog17
    Participant
    Initié WordPress
    5 contributions

    Bonjour Strabsquad,

    Ah… De mémoire, il est a la racine du www.

    Je vais créer un sous dossier « wordpress » et copier/ coller les fichiers dedans.

    Quels devraient être les Wordpress address et Site url dans les settings de WP du coup ?

    Devront-ils être identiques à ceux de la BDD ?

    Merci

     

    #1932726
    Ethanlog17
    Participant
    Initié WordPress
    5 contributions

    Re-Slt,

    D’apres ce site:

     

    XXX.benjaminyeurch.com/blog/developpement-web/importer-wordpress-local/

    Il faut effectivement creer un dossier, dans son exemple : nom du dossier « monsite.com » et dans Php:

    Une fois importée, allez dans la table wp_options (si vous n’avez pas touché aux préfixes de vos tables) puis modifier les valeurs de siteurl (ligne 1) et de home (ligne 36) par http://localhost/nomdusite.com 

     

     

     

    #1933072
    Flobogo
    Modérateur
    Maître WordPress
    20160 contributions

    Bonjour,

    Le tuto indiqué par JeanSeb comporte une grosse boulette : il y a confusion entre le nom du dossier et le nom de la base de données. Rien de tel pour que les débutants soient perdus.

    L’excellent tuto de codeblogueur n’est plus accessible, celui d’Openclassrooms est très réduit … Du coup, en attendant mieux, je vous conseille celui-ci, spécifique pour WampServer (mais le site fait un peu sapin de Noël 😕 ).
    Vous pouvez aussi consulter celui-là, mais il est un peu technique. (et l’icône de WAMP ne correspond pas 😕 )

    En tous cas, je vous confirme que l’URL locale avec WAMP sera de la forme : http://localhost/nom-du-dossier –> avec dossier créé dans www (lui-même situé dans wamp pour les versions 32 bits ou wamp64 pour les 64 bits)
    Et oui, il est conseillé de créer un dossier pour y mettre l’installation (attention : pas d’accent ni autre caractère spéciaux, ni espace : ça fout la m***)

    Pour info, la différence entre URL du site et adresse du site, c’est lorsque vous voulez que l’accueil pointe vers un sous-dossier de l’install, par exemple. Mais rien à voir avec l’install’ sous WAMP.

    #1934043
    Ethanlog
    Participant
    Initié WordPress
    2 contributions

    Slt Flobogo,

     

    Ah bah, si meme dans les tutos y’a des erreurs, je vais pas m’en sortir 😉

    Merci pour les liens, j’ai utilisé le 3eme, effectivement plus technique que les autres, mais se cultiver, ca fait pas de mal !

    Merci également pour tes explications sur les URL, j’ai enfin pu résoudre mon problème,

    Je le passe en résolu.

     

    #1934046
    Ethanlog
    Participant
    Initié WordPress
    2 contributions

    Euh, comment on passe en résolu svp ?

    #1934392
    Flobogo
    Modérateur
    Maître WordPress
    20160 contributions

    En déroulant la liste des « états » possibles, en haut à gauche, au-dessus du 1er post ; puis sur le bouton « mettre à jour ».

    Bon, là, c’est mon soir de bonté, je le fais pour vous.  😉

12 sujets de 1 à 12 (sur un total de 12)
  • Vous devez être connecté pour répondre à ce sujet.