Problème URL affichage de l’adresse cluster d’OVH

  • WordPress :4.7
  • Statut : non résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #1632842
    agence.cedicom@gmail.com
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle 4.7.3

    • Version de PHP/MySQL : 7.0
    • Thème utilisé : Regaltheme
    • Extensions en place : Polylang, WP editor
    • Nom de l’hébergeur : OVH
    • Adresse du site : aloha.fr

    Problème(s) rencontré(s) :

    Ayant été en attente du transfert du nom de domaine depuis gandi, j’ai installé le nouveau site via l’adresse ‘…clusting.ovh.net’ de mon serveur d’hébergement.

    Il m’a fallut lors de la mise en place de mon site WP sur l’hébergement (qui n’était alors pas rattaché à un nom de domaine !) indiquer dans : réglages>général >adresse web de WP & adresse web du site -> l’adresse du cluster OVH  : http://…cluster….hosting.ovh.net

    Seulement, maintenant que le transfert a été effectué et les DNS réinitialisés, mon site n’affiche toujours pas l’URL souhaitée. et toujours celle du cluster.

    Je pense qu’il y a des réglages à faire sur mon WP mais je ne vois pas lesquels exactement.

    Les répercussions sur le référencement de mon site risquent d’être désastreuses et malgré le fait que je pratique WP tous les jours, je me retrouve dépassé.

    Je voudrais juste que mon site affiche la bonne URL une bonne fois pour toute !
    Une idée ??????

    Par avance, merci.

     

     

    #1633035
    Yodav
    Participant
    Initié WordPress
    43 contributions

    Ok donc il va falloir lancer quelques requêtes via phpMyadmin :

    Pour commencer on change l’url du site

    UPDATE wp_options SET option_value = replace(option_value, ‘http://www.ton-ancien-domain.com’, ‘http://www.ton-nouveau-domaine.com’) WHERE option_name = ‘home’ OR option_name = ‘siteurl’;

    Ensuite, il va falloir procéder à la répareration des url de vos articles ainsi que de vos pages, les valeurs d’url sont stockées en tant qu’url absolues il est donc nécessaire de le faire en passant par cette requête :

    UPDATE wp_posts SET guid = replace(guid, ‘http://www.ton-ancien-domaine.com’,’http://www.ton-nouveau-domaine.com’);

    Enfin pour terminer, il faut s’occuper des liens internes qui ont été éventuellement créés histoire de ne pas vous retrouver avec des erreurs 404…on lance donc une dernière requête

    UPDATE wp_posts SET post_content = replace(post_content, ‘http://www.ton-ancien-domaine.com’, ‘http://www.ton-nouveau-domaine.com’);

    Maintenant il ne reste plus qu’à contrôler que tout soit bien OK et reprendre votre site là où vous en étiez 😉

    #1633318
    agence.cedicom@gmail.com
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Pour commencer, j’avais été voir du coté de la BDD et changé les infos de la table wp-options.

    Pour l’heure mon problème paraît résolu et je garde précieusement votre réponse pour la suite de mon site.

    Merci pour votre réponse !

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.