[Résolu] Problème upload médias suite changement domaine (Créer un compte)

  • WordPress :4.7
  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 34)
  • Auteur
    Messages
  • #1805660
    juldelf
    Participant
    Initié WordPress
    34 contributions

    Bonjour,

    Ma configuration WP actuelle: WordPress 4.8.1 avec le thème Himmelen.

    • Version de PHP/MySQL : PHP 7.0 / MySQL 5.5
    • Thème utilisé : Himmelen
    • Extensions en place :
    • Nom de l’hébergeur : 1&1
    • Adresse du site : http://www.jareef.fr

    Problème(s) rencontré(s) : Probleme blog suite changement domaine

     

    Bonjour a tous,

    je possédais un blog sous WP sur un nom de domaine que je voulais changer. Mais etant donné que j’avais envie de garder les anciens articles j’ai procédé comme ci dessous, jen esais pas si c’etait la bonne methode, donc:

    • achat du nouveau domaine jareef.fr via 1&1
    • redirection du flux de ancien site vers jareef.fr sur le site 1&1
    • Copie et transfert par ftp du contenu de l’ancien site vers le nouveau
    • achat et changement du théme en accedant sur le WP de jareef.fr
    • Changement de nom du nouveau site ds les réglages entre autres
    • reparamétrage des clés API de certains appli

    Le problème maintenant c’est que je n’arrive plus a uploader des photos?

    les anciens medias sont toujours présent mais qd j’upload une photo elle ne s’affiche pas. Quel pourraient être les problèmes ? Je n’ai rien touché a la base de données, j’ai tout copié, mais peut être faut il le préciser à 1&1?

    merci par avance

    #1805705
    TitouPJMC
    Participant
    Initié WordPress
    2 contributions

    Bonjour,

    La réponse m’intéresse suite à la mise à jour/migration d’un site sous WP.

    Mon Webmaster (en vacances…) a migré une version préprod vers la version prod, depuis, impossible de charger les médias par la boite de dialogue WP mais possibilité par le FTP.

    La boite de dialogue ne semble pas savoir dans quel fichier uploader l’image car il change toujours la date de ce dernier selon par où je cherche à uploader l’image.

    (désolé si je squatte le sujet…)

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #1805790
    PhiLyon
    Modérateur
    Maître WordPress
    26602 contributions

    @ TitouPJMC – Ouvres ton propre sujet que nous ayons les infos sur ta config https://wpfr.net/support/sujet/ouvrir-nouveau-sujet-forum/

    @ Juldelf – Essaies de désactiver tes extensions.

    🙂

    #1805798
    TitouPJMC
    Participant
    Initié WordPress
    2 contributions

    OK je voulais éviter les doublons !

    Je fais ça au plus vite. Merci !

    #1805855
    Li-An
    Modérateur
    Maître WordPress
    24378 contributions

    Changement dans les réglages me parait un peu flou. Vous avez bien mis à jour la base de données avec les modifs ?

    #1805978
    juldelf
    Participant
    Initié WordPress
    34 contributions

    @Li-An:  oui c’est vrai ca peut être tout et n importe quoi mais en gros j’ai juste rechangé le nom du site, mail et le nom admin ds utilisateurs, les api pour akismet et google api pr recaptcha  c’est tout.

    Concernant la base de données je ne sais pas je ne suis pas spécialiste . J’ai juste transféré le site entier via ftp et corrigé les noms donc c’est pour ca que je me dis qu’il est possible que j’ai oublié de transférer un truc de ce coté??

    #1806014
    Li-An
    Modérateur
    Maître WordPress
    24378 contributions

    Il faut absolument que vous fassiez cette manip sur la base de données sinon le déménagement est incomplet. https://wpmarmite.com/migrer-wordpress-manuellement/ chapitre 7

    #1806501
    juldelf
    Participant
    Initié WordPress
    34 contributions

    j’essaye ca je reviens vers vous prochainement mais effectivement j’ai rien fait de tout ca!!

    par ailleurs le blog wpmarmite à l’air vraiment top..

    #1806599
    juldelf
    Participant
    Initié WordPress
    34 contributions

    alors j’ai suivi le tuto et plus rien ne marche j’ai une erreur qui apparait:

     

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/46/d253230641/htdocs/jareef/wp-config.php:1) in /homepages/46/d253230641/htdocs/jareef/wp-includes/pluggable.php on line 1210

    #1806672
    juldelf
    Participant
    Initié WordPress
    34 contributions

    je ne sais pas si vous arrivez a voir la page du blog?

    #1806819
    Flobogo
    Modérateur
    Maître WordPress
    16350 contributions

    Bonjour,

    Pour faire court, demandez à 1&1 si ils ont une sauvegarde récente de votre site pour la réinstaller, et reprenez ensuite le tuto au point indiqué par @li-an.

    Sinon, supprimez la base de données chez 1&1, et reprenez le processus de migration plus en amont du tuto.

    #1808581
    juldelf
    Participant
    Initié WordPress
    34 contributions

    ba en fait quand je remet l’ancien fichier wp-config.php de l’ancien site ca remarche

    mais qd je met les nouvelles données de la nouvelle base dans le fichier wp-config.php et je l’up en ftp sur le blog ca deconne et ca me met le message d’ereeur

    il parle d’un truc avec l’header information???

    #1808841
    Li-An
    Modérateur
    Maître WordPress
    24378 contributions

    Je me doutais que vous n’aviez pas regardé le wp-config. Le message que vous avez donné est un message de conflit d’extension. Désactivez les extensions, mettez un thème par défaut et testez – mais si vous appelez une autre base de données, ça va cafouiller grave. Renommez carrément le répertoire wp-content/plugins (en pluginsxxx) pour désactiver les extensions de cette installation.

    #1846703
    juldelf
    Participant
    Initié WordPress
    34 contributions

    Bon j’ai réussi a regler le probleme du site avec 1&1 qui en fait etait un probleme de base de données que j’avais mal uploader

    Le nouveau site fonctionne mais  j’ai toujours un probleme, je ne peux pas uploader les photos ou divers médias.

    En fait ca upload bien, je vois qua ca a fonctionné mais les photos ne sont pas visibles??

    bizarre

    #1846852
    Li-An
    Modérateur
    Maître WordPress
    24378 contributions

    Mettez les permaliens pas défaut, sauvez, remettez ceux que vous avez choisi, sauvez. Et regardez si ça marche.

15 sujets de 1 à 15 (sur un total de 34)
  • Vous devez être connecté pour répondre à ce sujet.