Problème transfert de base de données

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 40)
  • Auteur
    Messages
  • #446895
    imported_BenKenobi
    Membre
    Padawan WordPress
    93 contributions

    J’ai voulu transférer ma base de donnée de chez Free vers mon nouvel hébergeur 1&1 et j’obtiens ce message après importation :

    requête SQL:
    
    CREATE TABLE IF NOT EXISTS `wp_bas_log` (
    `visit` bigint( 11 ) NOT NULL default ‘0’,
    `stamp` datetime default NULL ,
    `outbound` tinyint( 4 ) default NULL ,
    `page` bigint( 11 ) default NULL ,
    KEY `visit` ( `visit` ) ,
    KEY `page` ( `page` ) ,
    KEY `stamp` ( `stamp` )
    ) ENGINE = MYISAM DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci
    
    MySQL a répondu:Documentation
    #1064 – You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘DEFAULT CHARSET=latin1 COLLATE=latin1_general_ci’ at line 9

    Que dois-je faire car j’avoue être dépassé par les événements là…

    #569263
    damino
    Participant
    Maître WordPress
    1243 contributions

    Et elle vient d’où cette requette ?
    Comment as-tu fais ton transfert ?
    Tes tables de base de donnèes étaient-elles déjà créées sur 1&1 ?

    Et ça tu connais ? ou ça ?.

    #569264
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    En fait ce message d’erreur est apparu aussitôt après le transfert de la base. Tout de suite après avoir cliquer sur le bouton “exécuter”.
    J’ai réalisé celui-ci en copiant le contenu de mon fichier *.sql (créé à l’exportation de la base d’origine) dans le champ prévu à cet effet dans la rubrique SQL de PHPmyAdmin.

    Mes tables étaient déjà créées chez 1&1 puisque j’avais déjà installé WordPress 2.0.

    Quant aux deux liens que tu me donnent ce sont précisément ceux avec lesquels je me suis aidés. 😉

    Je précise que je peux sans aucun problème retenter l’opération d’une manière différente si besoin où même tout effacer (base + blog) puisque pour l’instant c’est mon blog test et qu’il n’y a rien d’important dessus. 😉

    #569265
    z720
    Membre
    Maître WordPress
    579 contributions

    Modifie le fichier SQL avant de le transférer en supprimant les informations d’encodage. Le serveur MySQL de 1&1 ne doit pas être dans la même version…

    Il faut supprimer ça :
    DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci

    (à tous les endroits)

    #569266
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Cette fois j’ai ce message, dois je recréer une table ? ou encore supprimer des choses dans le code ?

    requête SQL:
    
    CREATE TABLE IF NOT EXISTS `wp_bas_log` (
    `visit` bigint( 11 ) NOT NULL default ‘0’,
    `stamp` datetime default NULL ,
    `outbound` tinyint( 4 ) default NULL ,
    `page` bigint( 11 ) default NULL ,
    KEY `visit` ( `visit` ) ,
    KEY `page` ( `page` ) ,
    KEY `stamp` ( `stamp` )
    ) ENGINE = MYISAM —
    — Contenu de la table `wp_bas_log`
    — 
    INSERT INTO `wp_bas_log`
    VALUES ( 1, ‘2005-07-27 14:40:46’, 0, 1 )
    
    MySQL a répondu:Documentation
    #1064 – You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘INSERT INTO `wp_bas_log` VALUES (1, ‘2005-07-27 14:40:46’, 0, 1

    #569267
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Je m’aperçois que la ligne CREATE TABLE IF NOT EXISTS … apparait plusieurs fois dans le fichier SQL pour plusieurs tables en fait.
    L’erreur venant de là, est-ce que je dois supprimer toutes ces lignes ? les modifier ? comment ?

    #569268
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    J’aimerais savoir si d’autres personnes ont tenté le transfert d’une base de données Free vers 1&1 ?

    Suis-je seul à rencontrer tant de problèmes ?

    Le transfert d’une base parait pourtant assez simple à réaliser mais je n’y parviens pas j’ai toujours des erreurs…
    Est-ce que le fait de passer une base de données issue de la version 1.5 de WP vers une version 2.0 de WP déjà en place sur mon nouvel hébergeur peut être une source de problème ?

    #569269
    AmO
    Participant
    Maître WordPress
    4452 contributions

    Lors de l’exportation de la base de données sous free
    dans l’onglet exportation

    cliquer sur Compatibilité de l’exportation
    et metter mysql323, ca résou souvent pas mal de ptit problème…

    #569270
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Bon j’ai fait un premier essai en suivant tes directives et tout semblait aller… en effet aucune erreur ne s’était produite… mais je me suis rendu compte que seuls les commentaires avaient été importé ! Etrange !

    Je décide de recommencer l’opération au cas où quelque chose ne se serait pas passé comme prévu… et cette fois je tombe sur cette erreur :

    requête SQL:
    
    CREATE TABLE IF NOT EXISTS `wp_sem_nodes` (
    `node_id` int( 10 ) unsigned NOT NULL default ‘0’,
    `node_name` tinytext COLLATE latin1_general_ci NOT NULL ,
    `node_content` text COLLATE latin1_general_ci NOT NULL ,
    PRIMARY KEY ( `node_id` ) ,
    FULLTEXT KEY `node` ( `node_name` , `node_content` )
    ) ENGINE = MYISAM DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci
    
    MySQL a répondu:Documentation
    #1064 – You have an error in your SQL syntax.  Check the manual that corresponds to your MySQL server version for the right syntax to use near ‘collate latin1_general_ci NOT NULL,
      `node_content` text coll

    Je viens de me rendre compte qu’il y a eu du nouveau malgré les erreurs mais c’est pas encore bons !
    En fait mes articles sont là mais il manque tous ceux a partir de début décembre 2005 !
    De plus il semble y avoir un problème d’encodage car tous mes caractères accentués sont illisibles…
    Que dois-je faire ? décidémment la poisse est avec moi là (au lieu de la Force !)

    #569271
    Seb
    Membre
    Initié WordPress
    3 contributions
    z720 wrote:
    Modifie le fichier SQL avant de le transférer en supprimant les informations d’encodage. Le serveur MySQL de 1&1 ne doit pas être dans la même version…

    Il faut supprimer ça :
    DEFAULT CHARSET = latin1 COLLATE = latin1_general_ci

    (à tous les endroits)

    Tu as déjà eu la solution à ce problème 😉

    #569272
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Certes mais cela n’avais déjà pas résolu mes problèmes… et comment expliquer que certains articles ne soient pas réapparus.

    #569273
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    Il y a du mieux mais il me manque toujours tous les articles datés d’après le 3 décembre 2005 à aujourd’hui.
    Concernant l’accentuation c’est mieux là aussi mais pas parfait puisque certains caractères accentués tels que le “à” et les apostrophes et d’autres… sont remplacés au choix par des point d’interrogation où des chaines de caractères de ce type “é “…

    De plus un message d’erreur apparait en lieu et place des catégories dans la sidebar.

    On avance on avance…

    Au passage si vous voulez voir de quoi il retourne c’est par là que ça se passe…

    #569274
    Seb
    Membre
    Initié WordPress
    3 contributions
    BenKenobi wrote:
    Il y a du mieux mais il me manque toujours tous les articles datés d’après le 3 décembre 2005 à aujourd’hui.
    Concernant l’accentuation c’est mieux là aussi mais pas parfait puisque certains caractères accentués tels que le “à” et les apostrophes et d’autres… sont remplacés au choix par des point d’interrogation où des chaines de caractères de ce type “é “…

    J’ai exactement le même problème, j’ai hâte de voir si quelqu’un a une solution 🙂

    #569275
    benkenobi
    Gestionnaire du forum
    Maître WordPress
    4080 contributions

    De malchance en malchance… enfin bon vu où j’en étais y a rien de catastrophiques…

    J’ai voulu tenter de modifier un article juste pour voir… Là je tombe sur une page m’indiquant de mettre à jour la Base de données… je le fait… je tombe sur le fichier “upgrade.php”, je continue… et au bout du compte plus rien n’est accessible par le lien donné précédemment (page d ‘accueil de ce blog test)…

    Je crois que la base de données va être bonne à effacer ! :D

    #569276
    z720
    Membre
    Maître WordPress
    579 contributions

    Attention lors d’un transfert, il fautr bien s’assurer que tu as modifié les options d’adresse de ton site. Sinon le script d’upgrade va te renvoyer vers l’ancien site, ne mettant jamais à jour la base du blog que tu viens de transférer…

    Pour les accents c’est clairement un problème d’encodage entre ancien et nouveau hébergeur.

15 sujets de 1 à 15 (sur un total de 40)
  • Vous devez être connecté pour répondre à ce sujet.