Problème Tempera : les menus ne se fixent pas… (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 21)
  • Auteur
    Messages
  • #2367337
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Ma configuration WP actuelle

    Problème(s) rencontré(s) :

    Je viens de changer de nom de domaine. J’ai “transféré” mon hébergement sur le nouveau nom de domaine et modifié la base données avec PhpMyAdmin.

    Depuis, j’ai un souci avec les réglages de Tempera :

    Lorsque je suis sur “Apparence/Menu”, je veux assigner les menus au bon endroit, mais lorsque je valide, ils ne se fixent pas et cela revient au même point.

    J’ai voulu réinstaller Tempera, mais je ne veux pas avoir à refaire les réglages, j’ai donc voulu faire une sauvegarde avant, et le fichier est refusé.

    J’ai donc besoin de votre aide pour me donner des pistes, si vous en avez..

    Merci.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2367916
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    Pour compléter ma demande, voici les dernières news :

    J’ai désinstallé le thème Tempera, et je l’ai réactivé, pensant que cela résoudrait le problème. J’hésitais, car, comme je l’ai dit, j’avais perdu en cours de route le fichier de sauvegarde du thème. Tant pis, j’ai décidé de refaire, ce n’est pas si long.

    Le problème, même en réinstallant le thème, le problème revient (impossible de fixer les menus). Les réglages aussi d’ailleurs. Ce qui me fait dire qu’il y a un fichier de réglages qui n’est pas supprimé lorsqu’on désinstalle le thème. C’est sans doute dans ce fichier qu’il y a le problème.

    Savez-vous quel est ce fichier (je peux le supprimer avec FileZilla) ? est-ce qu’il contient d’autres réglages ?

    Merci pour vos réponses

    #2367920
    Li-An
    Modérateur
    Maître WordPress
    24840 contributions

    Bonjour, vous pouvez essayer avec un des thèmes par défaut mais a priori, la position des menus est gérée directement par WP, pas par le thème. Il y a donc un problème avec votre base de données. Est-ce que vous rencontrez d’autres problèmes si vous changez des réglages de WP (création de nouveau membre, d’étiquette…)

    #2367925
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Non, je viens de tester, pas de souci pour ajouter des étiquettes, ni pour créer un nouveau membre. Je n’ai rien vu de particulier en dehors de ce problème…

    #2367928
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Savez-vous dans quel fichier trouver ce paramètre ?

    #2367939
    Li-An
    Modérateur
    Maître WordPress
    24840 contributions

    Est-ce que vous avez essayé avec un thème par défaut ? En désactivant toutes les extensions ? Le réglage des menus est enregistrée dans la base de données, pas dans un fichier et est indépendante du thème.

    #2367963
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Effectivement, avec le thème Twenty twenty, je peux affecter les menus et ils restent. Si je reviens sur Tempera, pas moyen.

    Si le réglage des menus est enregistré dans la base de données, cela signifie que je n’y ai pas accès avec FileZilla ? Seulement sur mon hébergeur avec PhpMyAdmin ?

    #2367964
    Li-An
    Modérateur
    Maître WordPress
    24840 contributions

    Tout à fait mais les réglages faits sous Twenty Twenty doivent être conservés pour n’importe quel thème. Sauf évidemment qu’ils n’affichent pas toujours les mêmes menus à la même place.

    #2367966
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Merci Li-An pour le temps que vous me consacrez. Je ne comprends pas bien votre dernier message.

    Lorsque je fixe les menus sur Twenty twenty (image 1) et que je bascule à nouveau sur Tempera, ils ne restent pas, et impossible de les remettre (image 2).

    “Sauf évidement qu’ils n’affichent pas toujours les mêmes menus à la même place.” Tous mes menus sont intacts eux, mais mon problème est bien pour assigner mes deux menus (menu principal et menu pied de page) en navigation principale et en navigation du pied de page.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2367969
    PhiLyon
    Modérateur
    Maître WordPress
    27463 contributions

    Bonjour.

    L’extension https://fr.wordpress.org/plugins/cryout-theme-settings/ est activée ?

    🙂

    #2367970
    Li-An
    Modérateur
    Maître WordPress
    24840 contributions

    Vous nous dites que lorsque vous les assignez avec Twenty … ça marche mais pas avec votre thème. C’est que votre thème a un problème de compatibilité. Vous pouvez nous mettre son URL ?

    #2367972
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    oui, Cryout theme settings est activée. Ca pourrait venir d’elle ?

    #2367973
    PhiLyon
    Modérateur
    Maître WordPress
    27463 contributions

    Non, c’est parce que je na vois pas en inspectant le site.

    🙂

    #2367974
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Pour la compatibilité de mon thème, il s’agit de Tempera https://www.cryoutcreations.eu/wordpress-themes/tempera/tempera-1-7-2

    Je l’utilise sur beaucoup d’autres sites (environ 200). Aucun souci…

    #2367975
    Mickkael
    Participant
    Initié WordPress
    14 contributions

    Non, c’est parce que je na vois pas en inspectant le site.

    J’ai essayer de la supprimer et je l’ai ajoutée à nouveau. Pas mieux…

15 sujets de 1 à 15 (sur un total de 21)
  • Vous devez être connecté pour répondre à ce sujet.