Problème pour “embender” une page web dans mon site (Créer un compte)

  • WordPress :5.8
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2388617
    OpenLafa
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 8.0
    • Thème utilisé : Twenty Ten
    • Extensions en place : Jetpack, Google Apps Connexion, Google Doc Embedder, Google Drive Embedder, Table Press, Updraft Plus
    • Nom de l’hébergeur : One.com
    • Adresse du site : https://footdiversifielafa.fr/

    Problème(s) rencontré(s) :

    Bonjour,

    je cherche à récupérer un classement de championnat (ou au moins à afficher la page qui contient ce classement) diffusé sur un site et à l’intégrer dans une page de mon site.

    La page à récupérer est “https://alsace.fff.fr/competitions/?id=389121&poule=1&phase=1&type=ch&tab=ranking”

    Quand je crée un bloc “embed” avec cette adresse, il récupère la page comme si les arguments id, poule, phase, type et tab n’étaient pas présents. Quand on clique sur la page embeddée, une nouvelle page s’ouvre vers le site embeddé.

    Adresse de la page de test que j’ai créée : “https://footdiversifielafa.fr/resultats-foot2000/”

    Merci d’avance pour votre aide

    #2389112
    Thanatos
    Participant
    Initié WordPress
    14 contributions

    Bonsoir,

     

    je viens de faire un test en ajoutant la ligne suivante sur mon site de test et cela fonctionne convenablement:

    <embed type=”text/html” src=”https://alsace.fff.fr/competitions/?id=389121&poule=1&phase=1&type=ch&tab=ranking#8221&#8243; width=”500″ height=”600″>

    j’ai également fait un test sur https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_embed_html en copiant le code suivant:

    <!DOCTYPE html>
    <html>
    <body>

    <h1>The embed element</h1>

    <embed type=”text/html” src=”https://alsace.fff.fr/competitions/?id=389121&poule=1&phase=1&type=ch&tab=ranking#8221&#8243; width=”500″ height=”600″>

    </body>
    </html>

    Cordialement,

    Franck

    #2389153
    OpenLafa
    Participant
    Initié WordPress
    13 contributions

    Bonjour et merci pour ton aide !

    Alors j’ai modifié la page avec le code suivant :

    <embed type=”text/html” src=”https://alsace.fff.fr/competitions/?id=389121&amp;poule=1&amp;phase=1&amp;type=ch&amp;tab=ranking&#8221; width=”800″ height=”500″>

    En mode “modification”, le code est parfaitement interprété (cf. images jointes), mais quand je visualise la page, le code ne semble pas être interprété (voir sur https://footdiversifielafa.fr/resultats-foot2000/)

    Le code sur https://www.w3schools.com/tags/tryit.asp?filename=tryhtml5_embed_html fonctionne bien également.

    Une idées ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2389195
    Thanatos
    Participant
    Initié WordPress
    14 contributions

    Bonsoir,

    ton problème vient du fait que tu l’insert dans un champ de type texte, il faut insérer un champ “HTML personnalisé” puis coller le code dedans, du coup cela fonctionne, je viens de faire un test sur mon site de test et c’est fonctionnel.

    je t’ai mis une copie le fichier exemple.png qui est le mode Edition de la page. Le fichier exemple 2 est le resultat.

    Cordialement,

    Franck

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2389215
    OpenLafa
    Participant
    Initié WordPress
    13 contributions

    Bonjour et encore merci pour ton aide.

    J’avais essayé en bloc “code”, mais ça marchait pas, alors j’ai laissé WP “choisir” le type de bloc lui même d’où le bloc “texte”.

    Là, j’ai bien mis bloc “HTML Personnalisé” et le code est bien interprété (cf. images). Ça ne marche toujours pas : https://footdiversifielafa.fr/resultats-foot2000/

    J’ai vu que tu avais Elementor, je ne vois pas pourquoi mais est-ce que ça pourrait jouer ?

    J’ai mis également la page en mode “Editeur de code” si ça peut aider…

    Cordialement

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2389402
    Thanatos
    Participant
    Initié WordPress
    14 contributions

    Bonsoir,

    je viens de refaire une installation Wordpres 5.8.2 avec les plugins que tu mentionne et je n’arrive pas à reproduire ton problème.

    Pour t’aider, pourrais-tu m’envoyer les tables posts et postmeta ou me donner accès à la création d’une page pour réaliser un test.

     

    Cordialement,

    Franck.

    #2389407
    OpenLafa
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    le plus simple, c’est de te donner un accès au site. Je crée un user et je te l’envoie par MP

    #2389408
    OpenLafa
    Participant
    Initié WordPress
    13 contributions
    Cette réponse a été marquée comme privée.
    #2389532
    Thanatos
    Participant
    Initié WordPress
    14 contributions

    Il ne m’est pas possible de voir les informations, elle sont en privée, tu peut m’envoyer les informations sur

    contact [at] ginkgos.fr

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2389616
    Flobogo
    Modérateur
    Maître WordPress
    17777 contributions

    Bonjour,

    Pour rappel, le forum est un espace d’entraide collective, où les réponses apportées doivent être utiles à tous. Le forum ne doit pas servir à dépanner individuellement.

    Si le problème de @openlafa est résolu par un dépannage individuel, merci de revenir au moins expliquer ici la procédure utilisée.

    #2389631
    OpenLafa
    Participant
    Initié WordPress
    13 contributions

    Bonjour,

    pas de solution pour le moment.

    J’ai juste ouvert un accès au site à @Thanatos pour lui permettre d’analyser le problème, la solution sera bien évidemment publique.

    #2389700
    Thanatos
    Participant
    Initié WordPress
    14 contributions

    Bonjour,

    je viens de corriger le problème sur la page en modifiant le type embed en iframe .

    voici le code que j’avais proposer mais qui ne fonctionne pas sur son site:

    <embed type="text/html" src="https://alsace.fff.fr/competitions/?id=389121&poule=1&phase=1&type=ch&tab=ranking” width="800" height="500">
    embeded

    voici le code que je viens de mettre et qui fonctionne sur la page:

    <div><iframe  src="https://alsace.fff.fr/competitions/?id=389121&poule=1&phase=1&type=ch&tab=ranking” width="800" height="500"></iframe ></div>
    iframe

    Cordialement,

    Franck

    #2389706
    OpenLafa
    Participant
    Initié WordPress
    13 contributions

    Bonjour et vraiment merci pour le temps que tu me consacres !

    En re-testant, le résultat obtenu n’était pas correct (en particulier impossible d’ajuster la largeur et la hauteur. Du coup, j’ai testé sur une nouvelle page et avec un autre site (cette page !) et là, ça marchait nickel : https://footdiversifielafa.fr/test-embed/

    En recopiant le code et en changeant l’url sur ma page d’origine, j’ai enfin obtenu le résultat souhaité : https://footdiversifielafa.fr/resultats-foot2000/. Comportement étrange, mais… Résultat parfait !

    Du coup, j’ai plusieurs commentaires/questions :

    • J’ai lu que WP ne pouvait “embeder” que des sites sur une whitelist, mais je ne sais pas si c’est valable uniquement pour les blocs “contenu embarqué” ou également pour la balise “embed” dans un bloc HTML.
    • Pourquoi la balise “embed” dans un bloc HTLM fonctionne en prévisualisation dans l’éditeur de page WP et pas une fois publié (j’ai fais le test dans la page “https://footdiversifielafa.fr/test-embed/&#8221; en créant un second bloc qui “embed” cette page) ?
    • Je pensais que les “iframe” n’étaient pas/plus recommandés pour des questions de sécurité…

    Merci encore,

    Cordialement

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.