Problème php 7.4

  • WordPress :5.2
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2298288
    ads97129
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.1
    • WordPress 5.3.2
    • Thème utilisé : personnalisé
    • Extensions en place : 3D FlipBook, Advanced Custom Fields, Advanced Excerpt, Black Studio TinyMCE Widget, CC Child Pages, Contact Form 7, Content Blocks, Cookie Notice, Download Manager, Enhanced Text Widget, Feedzy RSS Feeds Lite, Image de menu, MailChimp, MetaSlider, Page Restrict, Page-list, Profile Builder, Responsive Column Widgets, Responsive Lightbox & Gallery, SecuPress, Sitemap, Smash Balloon Instagram Feed, TinyMCE Advanced, WordPress Responsive Thumbnail Carousel Slider, WP Statistics, WP Super Cache, WPDM – Image Button, Zajax
    • Nom de l’hébergeur : PHPNET
    • Adresse du site : https://www.archipel-des-sciences.org

    Problème(s) rencontré(s) :

    Bonsoir,

    J’essaie de passer à la version php 7.4 sur un site en ligne.

    Dès que je passe de la version 7.3 à 7.4, je suis systématiquement déconnecté du site et impossible de se reconnecter. Lorsque je repasse de 7.4 à 7.3, je suis automatiquement reconnecté au site. J’ai désactivé tous les plugins, mis un thème par défaut, mais rien n’y fait, le problème persiste. Ce problème intervient autant pour moi (administrateur) que pour les abonnés du site.

    En local, le site fonctionne parfaitement avec la version 7.4, aucun problème de déconnexion.

    Je ne comprends vraiment pas d’où le problème peut venir.

    Merci pour votre aide.

    Christophe

    #2298313
    PhiLyon
    Modérateur
    Maître WordPress
    24574 contributions

    Bonjour.

    Si ce n’est pas un problème chez ton hébergeur c’est sûrement une de tes extensions, essaie de les désactiver.

    🙂

    #2298329
    Li-An
    Modérateur
    Maître WordPress
    23134 contributions

    Bonjour, même si WP tourne sur les versions récentes de php, je vous conseille de rester sur du plus classique car il y a peu de chance que thèmes et extensions soient à jour de ce côté.

    #2298387
    ads97129
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    J’ai désactivé tous les plugins, le problème persiste. Idem en mettant à thème par défaut (twenty twenty).

    Par ailleurs, le site fonctionne très bien en local avec php 7.4, aucun problème de déconnexion.

    Peut-être un problème chez PHPNET ?

    #2298390
    PhiLyon
    Modérateur
    Maître WordPress
    24574 contributions

    Tu n’es pas en 5.3.2 mais en 5.3.1 fais la mise à jour de WordPress.

    🙂

    #2298411
    ads97129
    Participant
    Initié WordPress
    8 contributions

    Je confirme que je suis bien en 5.3.2.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2298420
    PhiLyon
    Modérateur
    Maître WordPress
    24574 contributions

    Désolé, Sucuri a dû délirer.

    Quels résultats donne “Santé du site ” dans Outils ?

    🙂

    #2298436
    ads97129
    Participant
    Initié WordPress
    8 contributions

    Bonsoir,

    Voici ce que donne “Etat de santé du site” dans Outils (en PJ).

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2298440
    PhiLyon
    Modérateur
    Maître WordPress
    24574 contributions

    Et tu dois faire quoi pour les deux problèmes critiques ?

    🙂

    #2298461
    ads97129
    Participant
    Initié WordPress
    8 contributions

    Les 2 problèmes critiques concernent la sécurité et n’ont jamais posé de problème de fonctionnement. En local, ils ne posent pas de souci avec php 7.4.

    Par contre, c’est le problème de l’API REST que je ne comprends pas. Il n’apparaît pas en local, seulement en ligne.

    #2298598
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    Bonjour,
    Si la même configuration fonctionne en local sous PHP 7.4 comme vous le dites, mais pose problème chez votre hébergeur, alors écrire à  votre hébergeur, il a pu désactiver des fonctions.

    API Reset peut être un accès pour les anonymes, cela peut être dangereux.

    https://wpchannel.com/wordpress/tutoriels-wordpress/desactiver-acces-anonyme-api-rest-wordpress-4-7/
    https://www.wordfence.com/blog/2016/12/wordfence-blocks-username-harvesting-via-new-rest-api-wp-4-7/

    #2298664
    ads97129
    Participant
    Initié WordPress
    8 contributions

    Bonjour,

    Je vais contacter PHPNET concernant mon problème avec PHP 7.4.

    J’ai activé une option sur Secupress réglant le problème d’accès pour les anonymes.

    Concernant le problème de l’API REST dans “Santé du site”, je ne sais toujours pas pourquoi d’où ça peut provenir.

    Merci

    #2298665
    Asuma
    Participant
    Maître WordPress
    31057 contributions

    Bonjour,
    Désolé, je me trompe, tout le temps,  API Rest et non API Reset.
    En PHP 7.3 ou PHP 7.2 le message d’erreur est toujours là ?

    Le problème a été réglé dans cette discussion en utilisant PHP 7.2
    https://wpfr.net/support/sujet/problemes-via-etat-de-sante-du-site/

    Si sous PHP 7.2 plus de message au sujet d’API Rest, une autre question à poser à votre hébergeur pour PHP7.4

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.