[Résolu] Problème mot de passe accès à l’administration de mon blog. (Créer un compte)

  • Statut : résolu
15 sujets de 1 à 15 (sur un total de 38)
  • Auteur
    Messages
  • #540483
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 4.2
    – Version de PHP/MySQL :
    – Thème utilisé : BirdFlat
    – Extensions en place :
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://joseph-isola.info/Sardequin

    Problème(s) rencontré(s) :

    Dans le courant de l’après-midi, impossible de me connecter à l’interface d’administration de mon blog. Le mot de passe n’est plus reconnu du tout. J’ai tenté la réinitialisation à partir de la page de login, j’ai également testé d’autres méthodes trouvées dans le codex wordpress (un fichier emergency.php), mais rien à faire.

    Mon blog est hébergé chez OVH, et comme je l’ai installé à partir d’un module de OVH, je n’arrive pas à accéder à phpMyAdmin (ce qui me permettrait de modifier le mot de passe directement). J’ai laissé un ticket chez OVH, et pour le moment, j’attends leur réponse.

    Quelqu’un pour m’aider. le blog est toujours actif, mais je ne peux rien faire, puisque plus d’accès à l’interface d’administration.

    Merci.

    Joseph

    #964047
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Petit ajout : par mesure de sécurité, je n’utilise pas le login admin crée à l’origine par le module OVH

    #964048
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    Si aucune des solutions proposées par le Codex ne fonctionne, on ne peut pas faire grand chose. As-tu essayé de créer un nouveau compte Administrateur ? Il me semble que ce script le permet.

    #964049
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    J’avais essayé une version de ce script, qui devait permettre de créer un nouveau mot de passe. La version que tu m’as proposée ne fonctionne pas non plus. Je viens de la tester en l’installant sur le FTP.

    Le souci, c’est que je suis arrivé à accéder au phpMyAdmin, et j’ai l’impression que la base de donnée n’est plus là. Il n’y a rien dans l’arborescence à gauche de la page phpMyAdmin…
    Pourtant le blog est toujours actif…

    Je ne sais plus quoi faire ! Je vais attendre la réponse de OVH, mais j’ai bien peur de la réponse.

    #964050
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    La version que tu m’as proposée ne fonctionne pas non plus.

    Tu as des messages d’erreur ?

    Je ne sais plus quoi faire ! Je vais attendre la réponse de OVH, mais j’ai bien peur de la réponse.

    Non, c’est probablement lié au fait que tu utilises le module OVH. La base est certainement ailleurs.

    #964051
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Le souci, c’est que dans l’interface phpMyAdmin, il n’y a pas la base (sur la gauche). Rien, que dalle ! La base est normalement sur OVH. Sur interface web phpMyAdmin, je vois bien le nom de ma base en haut, mais dans le menu de gauche, rien…

    Sinon, quand j’utilise emergency.php, rien ne se passe !

    #964052
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bon, une “réparation” par l’intermédiaire du fichier repair.php confirme que la base de ornée est présente et en bon état. Il faut vraiment que je retrouve comment réinitialiser le mot de passe.

    #964053
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    La base est normalement sur OVH.

    Elle l’est, mais ce n’est pas forcément celle de ton profil qui est utilisée lors d’une installation par le module chez OVH. C’est, je pense, la raison pour laquelle tu as bien des données dans WordPress avec une base de données vide..
    La vérité base de données est ailleurs… 😉

    #964054
    Lumiere de Lune
    Participant
    Maître WordPress
    19377 contributions

    Il faut regarder dans le wp-config les identifiants de la base de données (notamment le serveur) et les remplir dans l’écran de connexion, au lieu de ceux correspondant à la base de donnée qui apparait dans ton compte

    #964055
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Ok, merci. Si je regarde dans le wp-config, j’ai bien au début des infos

    // ** MySQL settings etc…

    avec define (‘DB_USER’ …
    et define (‘DB_PASSWORD’ …

    Donc, je repère comment le serveur et les “identifiants” ? Même si pour les identifiants, j’ai ma petite idée.

    Merci de votre intérêt pour mon problème.

    #964056
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    Il faut vérifier si les DB_USER et DB_NAME correspondent aux identifiants dans ton espace Web OVH ou pas.
    Pour le serveur, il faut regarder la valeur de DB_HOST. À quoi correspond elle ? Localhost ou un nom de serveur ?

    #964057
    Lumiere de Lune
    Participant
    Maître WordPress
    19377 contributions

    db_user
    db_password
    db_name
    db_server (ou db_host) je ne me souvient plus

    Après c’est quand même simple ^^
    db_name c’est le nom de la base de donnée
    db_password le mot de passe
    db_serveur le “serveur” ^^

    #964058
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Pour la valeur DB_HOST, c’est marqué ‘sql6.modules’

    Pour DB_USER et DB_NAME une série de chiffres (les même pour les deux). Et pour DB_PASSWORD une série de lettres et chiffres.

    Pour être honnête, je ne sais pas à quoi ça peut correspondre. En tout cas, pas à mes identifiants de l’espace web d’OVH.

    Si je rentre le username et les “password” dans la fenêtre de connexion, ça peut fonctionner ?

    En fait, je n’arrive plus à me souvenir si je suis passé par le module OVH, ou si j’ai fait une installation directe… Ça remonte à fin 2013, et, bon, j’ai oublié tout ça…
    Ça va me servir de leçon si je n’arrive pas à réparer… En même temps, c’est un blog personnel, rien de dramatique. mais bon, si je peux éviter de repartir à zéro.

    #964059
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Bon, il y a du nouveau, mais pas forcément du mieux.

    J’ai pu accéder à phpmyadmin.ovh.net, et je vois la base de données, avec tous les éléments (les différentes tables).

    J’ai suivi la procédure pour modifier le mot de passe, mais hélas, ça ne fonctionne pas du tout ! Je ne sais plus vraiment quoi faire.

    #964060
    Sardequin
    Participant
    Chevalier WordPress
    198 contributions

    Je viens de tester le script trouvé par Lumière de Lune (sur votre blog), script_user_creation.php

    Avec Firefox, ce massage s’affiche :

    Erreur d’encodage de contenu

    La page que vous essayez de voir ne peut être affichée car elle utilise un type de compression invalide ou non pris en charge.

    Veuillez contacter les propriétaires du site pour les informer de ce problème.

    Si je vais dans phpmyadmin, je constate que l’admin provisoire est bien créé. mais si je veux me connecter, ça ne marche pas non plus.

    Je pense que le problème est bien plus grave que ça.

15 sujets de 1 à 15 (sur un total de 38)
  • Vous devez être connecté pour répondre à ce sujet.