Problème migration site wordpress (Créer un compte)

  • Statut : non résolu
15 sujets de 1 à 15 (sur un total de 22)
  • Auteur
    Messages
  • #516348
    djerbiano
    Participant
    Initié WordPress
    10 contributions

    Bonjour,

    je veut migrer mon site wordpress vers un nouveau hébergeur. J’ai exporter le contenu de ma base de donnée vers la nouvelle base, exporter le contenu de mon ftp vers le nouveau. J’ai modifier le fichier de configuration . Je m’attendais vraiment à ce que sa marche mais en fait non :( quand je veut accéder à mon blog j’ai une page blanche sous firefox et sous chrome j’ai une erruer Erreur HTTP 500 (Internal Server Error) .

    Pouvez vous m’aider svp ?

    #862018
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Avant d’exporter votre base de données sur le nouveau blog, ouvrez toutes les tables avec un traitement de texte ou avec notepad++ et remplacez l’ancienne adresse du site par la nouvelle. Ainsi remplacez http://www.anciene_adresse.fr par http://www.nouvelle-adresse.fr (sans les http://).
    Puis importez cette base dans le nouveau site.
    Via FTP (avec Filezilla, par exemple) placez une copie du dossier wp-content de l’ancien site vers le nouveau

    C’est tout !

    #862019
    djerbiano
    Participant
    Initié WordPress
    10 contributions

    Bonsoir,

    J’ai utilisé le meme demarche que tu as proposé mais j’ai encore une page blanche. Donc j’ai installer wordpress de nouveau sur mon nouveau hébergement et j’ai exporter mon ancien blog avec lextension exporter de wordpress. Mais quand je clique sur outil, importer sur le nouveau site, puis wordpress , et je clique sur installer , je met mes identifiants ftp, il me sort une erreur
    Extension en cours d’installation : WordPress Importer 0.6
    Impossible de localiser le dossier de contenu de WordPress (wp-content).

    Quelqu’un à une idée ? J’ai une piste, je pense que le problème vient du fait que le blog n’est pas dans la racine de mon ftp, quand je me connecte sur ftp , mon host est monsite.fr, après je doit me rendre dans un répertoire www et puis dans un autre, 2010, pour trouver le dossier wp-content … Je pense que le problème vient de là .
    Merci d’avance pour votre aide

    #862020
    luciole135
    Participant
    Maître WordPress
    13714 contributions

    Une fois votre nouveau WordPress créé, avez-vous suivi la procédure que je vous ai indiqué ?

    #862021
    rtlinfo
    Membre
    Padawan WordPress
    56 contributions
    djerbiano wrote:
    Bonsoir,

    …connecte sur ftp , mon host est monsite.fr, après je doit me rendre dans un répertoire www et puis dans un autre, 2010, pour trouver le dossier wp-content … Je pense que le problème vient de là .

    L’arborescence que tu indiques, visible via ftp, est dans sa « première » partie, soit avant 2010 (ou avec 2010), celle que propose ton hébergeur ; dans l’interface d’administration de ton espace web (fourni par ton hébergeur), tu dois avoir quelque part la possibilité de définir pour ton site web, le nom du répertoire où doivent être placés les fichiers / dossiers constituant ton site.

    le dossier « 2010 » me parait toutefois étrange ; es tu sûr qu’il ne correspond pas à un dossier de ton site local ?

    Sinon, en cas de déplacement de site, il faut aussi mettre à jour le fichier .htacess ; soit via l’interface de wordpress (réglages > lecture, vérifier que url du site est la bonne puis valider / enregistrer, soit à la main (édition ftp)

    #862022
    Li-An
    Participant
    Maître WordPress
    28265 contributions

    Recopiez juste le répertoire wp-content. Conservez SOIGNEUSEMENT une ou plusieurs copies de l’ANCIENNE base de données -super hyper important. Essayez ce plugin: http://www.echodesplugins.fr/plugins/complete-update-urls/ et dites nous si ça marche.
    Tant que vous avez une copie valable de votre ancienne base de données vous pouvez faire tous les tests que vous voulez, ça ne sera jamais perdu.

    #862023
    Li-An
    Participant
    Maître WordPress
    28265 contributions

    Oups: si vous n’avez pas modifié l’adresse du site, tout ceci – à part wp-content- ne sert à rien. Faites déjà un test avec une installation WP basique pour voir déjà si ça marche comme ça.

    #862024
    djerbiano
    Participant
    Initié WordPress
    10 contributions

    Merci pour les réponse .
    J’ai modifier l’adresse du site, j’ai ouvert la base de donnée et j’ai changer tout les liens avec l’éditeur de texte … Mais bon j’ai renoncer à cette méthode , je me suis dit que c’est plus propre d’utiliser l’outil EXPORTER et IMPORTER de wordpress.
    Là sur mon nouveau hébergement j’ai installer un tout nouveau wordpress , vierge, et j’ai essayer d’installer le plugin importer , mais comme j’ai déjà expliquer j’ai une erreur avec le dossier wp-content. Après j’ai essayer de remplacer le dossier wp-content avec celui de l’ancien blog. Le site marche toujours mais toujours impossible d’insaller l’outil importer … Je suis vraiment perdu :(

    #862025
    Li-An
    Participant
    Maître WordPress
    28265 contributions

    Personnellement, j’ai préféré travailler avec la base de données, elle est plus fiable dans ses modifs qu’un import qui réécrit tout.
    Plutôt que de tout faire à la main, il y a des tas de soluces plus simples. Tester le plugin par exemple ou ce genre de choses:
    http://codex.wordpress.org/Moving_WordPress avec http://interconnectit.com/124/search-and-replace-for-wordpress-databases/ qui marche très bien.

    Celui-là aussi me paraît bien: http://www.craniumstorm.com/how-to-move-a-wordpress-site/

    #862026
    djerbiano
    Participant
    Initié WordPress
    10 contributions
    Li-An wrote:
    Recopiez juste le répertoire wp-content. Conservez SOIGNEUSEMENT une ou plusieurs copies de l’ANCIENNE base de données -super hyper important. Essayez ce plugin: http://www.echodesplugins.fr/plugins/complete-update-urls/ et dites nous si ça marche.
    Tant que vous avez une copie valable de votre ancienne base de données vous pouvez faire tous les tests que vous voulez, ça ne sera jamais perdu.

    Je viens d’essayer le plugin et j’ai exporter la base et remise dans le nouveau blog fraichement installer et boom , page blanche 😕

    #862027
    Li-An
    Participant
    Maître WordPress
    28265 contributions

    Vous avez essayé l’installation standard pour voir déjà si ça ça marche ?
    Ensuite, est-ce que le fichier wp-config a bien été modifié ?

    #862028
    djerbiano
    Participant
    Initié WordPress
    10 contributions
    Li-An wrote:
    Vous avez essayé l’installation standard pour voir déjà si ça ça marche ?
    Ensuite, est-ce que le fichier wp-config a bien été modifié ?

    Oui oui une installation normale marche parfaitement. Mais quand j’essaye d’importer la base c’est la que ça se complique 😕

    #862029
    Li-An
    Participant
    Maître WordPress
    28265 contributions

    Il y a peut-être un problème avec les plugins… Est-ce que vous avez désactivé les plugins et mis un thème par défaut avant de sauvegarder votre base – on ne sait jamais ? Je cherche 🙂

    #862030
    djerbiano
    Participant
    Initié WordPress
    10 contributions
    Li-An wrote:
    Personnellement, j’ai préféré travailler avec la base de données, elle est plus fiable dans ses modifs qu’un import qui réécrit tout.
    Plutôt que de tout faire à la main, il y a des tas de soluces plus simples. Tester le plugin par exemple ou ce genre de choses:
    http://codex.wordpress.org/Moving_WordPress avec http://interconnectit.com/124/search-and-replace-for-wordpress-databases/ qui marche très bien.

    Celui-là aussi me paraît bien: http://www.craniumstorm.com/how-to-move-a-wordpress-site/

    J’ai suivi le dernier lien à la lettre et toujours rien

    Li-An wrote:
    Il y a peut-être un problème avec les plugins… Est-ce que vous avez désactivé les plugins et mis un thème par défaut avant de sauvegarder votre base – on ne sait jamais ? Je cherche 🙂

    Ah non , ça c’est une bonne idée 🙂 j’essaye tout de suite

    #862031
    djerbiano
    Participant
    Initié WordPress
    10 contributions

    Bon je crois que j’ai fait une connerie :s ça a merder , j’ai voulu le remettre donc j’ai remis la copie de la base de donnée que j’ai faite mais y a un problème avec les liens :s je l’ai modifier sans me rendre compte :( c’est une histoire de lien , elle marche mais il y a des problème j’ai pas vraiment compris quoi … Es que quelqu’un se sent prêt pour y jeter un coup d’oeil ? si oui je lui envoie l’FTP et la base sur dropbox

15 sujets de 1 à 15 (sur un total de 22)
  • Vous devez être connecté pour répondre à ce sujet.