[Résolu] Problème Menu WordPress : SIte one Page avec des articles (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #2360172
    Julia_WP
    Participant
    Initié WordPress
    3 contributions

    Bonjour à tous,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP : 7.2 MYSQL : 5.6
    • Thème utilisé : The 7
    • Extensions en place : Yoast, Akismet, Wordfence, Elementor
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://abelajulia.fr

    Problème(s) rencontré(s) :

    Je suis en pleins test pour mon menu qui n’est pas terminé,

    Le soucis : lorsque qu’on arrive sur mon site mon menu fixe est bleu alors que c’est la couleur de l’item actif, il devrait être vert foncé.

    En revanche quand je clic sur compétences par exemple tout est ok, mais en re cliquant sur mon logo pour retourner en haut ou lorsque je suis sur un article revoir à la page d’accueil idem menu bleu.

    Même soucis pour le menu flottant.

    C’est un site One page donc j’ai utilisé des ancres pour rester sur la page et accéder aux différentes parties jusque là ok.

    Mais j’ai également des articles pour mes projets à la partie “portfolio” du One page, quand je clic ça me redirige donc vers mes articles ok, et je peux ensuite retourner sur mon one page à la partie que je souhaite.

     

    J’espère que c’est pas trop brouillon ce que je dis pas simple d’expliquer :/

    En vous remerciant par avance,

    Julia

     

    #2360352
    momofr@free.fr
    Modérateur
    Maître WordPress
    3759 contributions

    Salut, un menu ancre doit se terminer avec #monancre, je vois des #!/monancre chez toi, le !/ est de trop à mon avis.

    Pour les couleurs ça dépend su thème, la couleur lorsque l’on arrive provient d’une règle personnalisée que tu as dû ajouter :

    .main-nav > li.act:not(.wpml-ls-item) > a .menu-text, .main-nav > li.act:not(.wpml-ls-item) > a .subtitle-text {
    	color: #4c797c;
    }

    Lorsque l’on clique sur un menu/ancre les menus non actifs passent en bleu très sombre avec cette règle :

    .sticky-on .main-nav > li:not(.wpml-ls-item) > a .menu-text, #phantom .main-nav > li:not(.wpml-ls-item) > a .menu-text {
    	color: #1d2b2b;
    }

    Le “bleu” est donc bien là par défaut pour le menu non actif, c’est aussi la couleur en surbrillance des ancres avec une valeur sombre pour les non actifs en cas de position ancrée.

     

    #2360441
    Julia_WP
    Participant
    Initié WordPress
    3 contributions

    Hello,

    Merci pour ta réponse rapide,

    Le soucis est que si je ne mets pas le “!” mes ancres ne fonctionnent pas ce qui est étrange, ce qui me bloque c’est le menu ancre et mes articles extérieurs, je pense que le soucis vient de la navigation je vais vérifier le code et nettoyer ce qui ne vas pas.

    Pour la couleur effectivement je vais regarder de ce côté là, parfois à force d’être dessus on ne va pas au plus logique et au plus simple.

    Merci

    #2360450
    Julia_WP
    Participant
    Initié WordPress
    3 contributions

    J’ai trouvé la solution, j’ai personnalisé mon CSS pour spécifier que je ne souhaitais pas que la couleur du menu/ ancre soit “bleu claire” quand on arrive sur la Home et tout est rentré dans l’ordre.

    Sujet résolu merci.

4 sujets de 1 à 4 (sur un total de 4)
  • Vous devez être connecté pour répondre à ce sujet.