Probleme mémoire sur serveur?, wordpres (erreur HTTP) upload images (Créer un compte)

  • Statut : non résolu
8 sujets de 1 à 8 (sur un total de 8)
  • Auteur
    Messages
  • #553368
    djmisterjon
    Participant
    Padawan WordPress
    63 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress :
    – Version de PHP/MySQL :
    – Thème utilisé :
    – Extensions en place :
    – Nom de l’hebergeur :
    – Adresse du site :

    Problème(s) rencontré(s) :

    Bonjours j’ai un problème, je n’arrive plus a uploader d’image sur ma boutique, j’ai une erreur http, qui est la cause que la limite memory est insuffisante. Si je désinstalle un plugin le problème ce règle mais ce n’est pas mon réel problème.

    Pour tant, si je regarde sur mon vps cloud, ma mémoire est loin d’être saturer.
    Voici un print screen de mon serveur
    R8Y1ib2s.jpg

    Et de ma boutique sur wordpress, j’ai même mis 8 Go pour être sur.
    Même sir je n’ai que 2Go
    define( ‘WP_MEMORY_LIMIT’, ‘8000M’ );
    KfdLke9L.jpg

    Peut être j’ai mal faite ? un configuration.
    http://imgbox.com/KfdLke9L

    J’ai donc plus que suffisant de mémoire si je me fit au information de mon serveur.
    Que ce passe t’il ?
    j’ai remarquer
    Poids Max Post PHP:

    Mais je ne crois pas que ce soir utile ?
    Help please.

    Tanks

    #1017965
    djmisterjon
    Participant
    Padawan WordPress
    63 contributions

    Je up merci

    #1017966
    djmisterjon
    Participant
    Padawan WordPress
    63 contributions

    Personne n’aurai un indice ?

    #1017967
    djmisterjon
    Participant
    Padawan WordPress
    63 contributions

    je up !

    #1017968
    djmisterjon
    Participant
    Padawan WordPress
    63 contributions

    Je up merci

    #1017969
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    Cela ne sert à rien de multiplier les “up” si tu ne remplis pas les informations pour le support. Cela évite de devoir partir à la pêche aux infos, il y a beaucoup de discussion à gérer chaque jour dans ce forum, cela prend beaucoup de temps. Ce n’est pas la même chose en fonction de l’hébergeur et de l’hébergement choisi. Apparemment tu est sur un serveur dédié avec PHP 5.3.

    Commence déjà par passer en version 5.4 ou 5.5, PHP 5.3 n’étant plus supporté depuis plus d’un an. Cela pourra aussi améliorer les performances côté mémoire.

    Si c’est un bien problème de mémoire, c’est au niveau de la configuration PHP qu’il faut agir. Tu peux mettre 60Go dans le wp-config.php si le paramètre est verrouillé dans la configuration PHP cela ne changera pas la valeur.
    Il faut que tu ailles regarder le paramètre

    memory_limit

    dans le fichier php.ini pour voir sa valeur (je ne vois pas le paramètre dans les copies d’écran de l’interface plesk) et la modifier si nécessaire. Sauf configuration exigeante (d’où la question sur les extensions installées) 128Mo ou 256Mo sont suffisants dans la majorité des utilisations.

    Après cela dépend aussi de la taille des images téléchargées. Généralement, cela n’a aucun intérêt pour une boutique (hors vente d’images en ligne) de charger des photos trop lourdes. Quelle est la taille moyenne des photos que tu charges ? Il y a peut-être aussi de l’optimisation à faire de ce côté.

    #1017970
    djmisterjon
    Participant
    Padawan WordPress
    63 contributions
    fge wrote:
    c’est au niveau de la configuration PHP qu’il faut agir. Tu peux mettre 60Go dans le wp-config.php si le paramètre est verrouillé dans la configuration PHP cela ne changera pas la valeur.


    Merci pour votre réponse et comprit pour les UP!

    Merci beaucoup, je n’ai pas trouver comment accéder au fichier php.ini sur plesk ,
    mais a travers les option j’ai trouvé ceci.
    oc1Tl1Rx.jpg

    J’ai procéder au changement, et je vais suivre aussi vos autre indication.
    Je reviendrai pour confirmer que le problème est résolu.

    Merci.

    taille des images téléchargées. Généralement, cela n’a aucun intérêt pour une boutique

    Mes images sont bien toute optimisé au maximum avec photoshop.
    Elle ne dépasse rarement les 28 Ko et de 64 a 256 couleur.
    Ou les gros jpg sont compresser a environs Q(20)
    Les png sont aussi en png8 ou gif

    Mais je ne savait pas que le nombre d’images pouvais jouer sur la mémoire total du site !

    Commence déjà par passer en version 5.4 ou 5.5

    Je vais mi mettre

    #1017971
    Franck (fge)
    Modérateur
    Maître WordPress
    9576 contributions

    Merci beaucoup, je n’ai pas trouver comment accéder au fichier php.ini sur plesk ,
    mais a travers les option j’ai trouvé ceci.

    C’est effectivement, le bon paramètre à vérifier / modifier. Attention toutefois à garder une valeur cohérente avec la configuration système (ne pas allouer toute la mémoire physique à PHP mais en conserver suffisamment pour le système pour éviter les problèmes).

    Mais je ne savait pas que le nombre d’images pouvais jouer sur la mémoire total du site !

    C’est pas le nombre mais la taille des photos. WordPress génère de miniatures notamment lorsqu’on ajoute des photos dans la librairie des médias ce qui consomme de la mémoire. Plus les photos sont grosses plus on a besoin de mémoire pour ce travail.

8 sujets de 1 à 8 (sur un total de 8)
  • Vous devez être connecté pour répondre à ce sujet.