Problème lors du transfert de la boutique WooCommerce de local à OVH (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 1 réponse, 2 participants et a été mis à jour pour la dernière fois par Anonyme, le il y a 9 années et 9 mois.
2 sujets de 1 à 2 (sur un total de 2)
  • Auteur
    Messages
  • #540579
    liliescrap
    Membre
    Initié WordPress
    19 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 3.9.1
    – Version de PHP/MySQL :
    – Thème utilisé : Artificer
    – Extensions en place : WooCommerce, Big Contact
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.liliescrap-boutique.com

    Problème(s) rencontré(s) :

    Bonjour,

    J’ai créé une boutique en local grâce à Wamp.
    Ma boutique étant prête, j’ai acheté un nom de domaine et un hébergement sur OVH.
    -J’ai créé une nouvelle base de donnée MySQL sur OVH puis j’ai suivi cette vidéo pour transférer le site: https://www.youtube.com/watch?v=dh0QTr_AyR8
    -Pour réaliser le transfert j’ai désactivé toutes les extensions puis j’ai changé les adresses URL dans les réglages généraux de WordPress (comme expliqué dans la vidéo).
    -J’ai modifié le fichier wp-config.php afin de mettre le nom de ma base de donnée.
    -Ensuite j’ai utilisé Filezilla afin de procéder au transfert de fichiers. C’est LA que je pense qu’il y a eu un couac. Je crois avoir transféré dans le dossier « / ».
    -Puis je suis allée sur PHPmyadmin en local et j’ai téléchargé toutes les requêtes SQL de la base de donnée WordPress.
    -J’ai ouvert le fichier de requête SQL avec mon éditeur de texte et j’ai modifié le nom la « base de donnée » pour mettre la mienne.
    -J’ai copié-collé le tout et me suis connecté à mon serveur puis coller le tout dans la rubrique SQL. Dans la video, il est indiqué « votre requête SQL à été exécutée avec succès » alors que pour moi il était indiqué  » mySQL à retourné un résultat vide (aucune ligne) ». Pourtant quand j’actualise la base de données je voie toutes les tables…
    -Quand j’ai tapé l’url de ma boutique j’ai trouvé la page « en construction » d’OVH. J’ai vu sur un site qu’il fallait supprimer le dossier « index » sur Filezilla pour ne plus avoir cette page. Du coup je n’ai plus la page en construction mais « erreur de connexion à la base de données ».

    -Après coup je me suis rendue compte qu’il aurait fallu transférer les fichiers dans le dossier « www » sur filezilla pour que ce soit pris en compte par OVH. Ne trouvant pas de dossier « www » je l’ai créé et j’ai tout transféré de nouveau. J’ai répété toutes les étapes suivantes mais je trouve toujours la page « erreur de connexion à la base de données ». J’espère ne pas avoir supprimé des fichiers qu’il ne fallait pas. Voici à quoi ressemble mon filezilla
    boutiq11.jpg

    Si vous avez des idées à propos de mon problème je suis preneuse…

    #964447
    Anonyme
    Invité
    Maître WordPress
    34067 contributions

    Ce message a été supprimé suite à la demande de l’auteur.

2 sujets de 1 à 2 (sur un total de 2)
  • Vous devez être connecté pour répondre à ce sujet.