Problème lors du déplacement de répertoire wordpress (Créer un compte)

  • WordPress :5.5
  • Statut : non résolu
5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #2358384
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : 7.4.11 / 5.5.54
    • Version de WordPress : 5.5.3
    • Thème utilisé : OceanWP
    • Extensions en place : async javascript, autoptimize, elementor, essential addons for elementor, ocean extra, sticky menu on scroll, tablepress, tablepress extension : datatables columnfilterwidgets, zotpress
    • Nom de l’hébergeur : Renater
    • Adresse du site : https://idip-obs.unistra.fr/wordpress

    Problème(s) rencontré(s) :

    Bonjour,

    Lors de la création de mon site, j’ai installé les fichiers wordpress dans un sous dossier /wordpress, afin que les personnes allant sur l’URL « de base » de mon site voient un message affichant « Site en construction ». La construction de mon site étant terminée, je souhaiterais déplacer mes fichiers wordpress afin que le site soit visible à l’adresse https://idip-obs.unistra.fr/, sans la mention /wordpress à la fin.

    Je me suis donc connectée en FTP et ai déplacé tous les fichiers dans le dossier « au dessus » et ai supprimé le dossier /wordpress, j’ai changé le fichier .htaccess, et pour finir, dans wp-config.php,  j’ai défini l’adresse de la page d’accueil en retirant le /wordpress.

    Je pensais avoir effectué toutes les manœuvres nécessaires, mais après avoir fait tout cela, lorsque je me rend à l’adresse https://idip-obs.unistra.fr, je suis automatiquement redirigée vers l’URL avec /wordpress à la fin, et une erreur 404 s’affiche. Avez-vous une idée d’une étape clé que j’aurais pu oublier lors du transfert ?

    Merci par avance pour votre aide.

    Cordialement

    #2358563
    abds69
    Participant
    Padawan WordPress
    62 contributions

    bjr , vous avez fait plein de choses en même temps , du coup vous devez gérer plein de paramètres.

    Le plus simple,

    -remettre les choses dans /wordpress

    -depuis le rep /wordpress copier .htaccess et index.php et les mettre à la racine (au-dessus). J’ai dit copier , pas couper !!

    -editer index.php , pour rajouter /wordpress devant le blogheader  voir dessous
    require( dirname( __FILE__ ) . ‘/wordpress/wp-blog-header.php’

    Si ça démarre pas après , coder en dur ça dans wp-config.php
    define( ‘WP_HOME’, ‘http://example.com’);
    define( ‘WP_SITEURL’, ‘http://example.com/wordpress’);  le même mais /wordpress en plus
    Faudra modifier en accordance dans réglages général, et puis faire sauter ces 2 lignes après.

    -allez dans les permaliens et changer et remettre votre choix pour réecrire .htaccess

    En général on pose wordpress dans un sous-répertoire, c’est plus propre.

    Dans votre cas sur google , les mots clefs seront « moving wordpress », « wordpress subdirectory »

    A+

    • Cette réponse a été modifiée le il y a 3 années et 5 mois par abds69.
    • Cette réponse a été modifiée le il y a 3 années et 5 mois par abds69.
    • Cette réponse a été modifiée le il y a 3 années et 5 mois par abds69.
    #2358577
    floperret
    Participant
    Initié WordPress
    18 contributions

    Bonjour,

    Je vous remercie pour votre réponse mais cela ne fonctionne malheureusement pas. J’ai déjà codé en dur dans wp-config.php en remplaçant le lien et ai modifié le fichier .htaccess.

    Vous me suggérez de rajouter /wordpress/ dans le fichier index.php mais je ne comprends pas pourquoi, puisque je souhaite justement que le site ne soit plus accessible depuis ce dossier mais depuis l’URL. J’ai également essayé de changer tout simplement le lien dans les réglages généraux dans le tableau de bord de wordpress mais cela a fait bugger mon site.

    Dois-je modifier quelque chose dans mon fichier .sql ?

    Merci d’avance pour votre aide

    • Cette réponse a été modifiée le il y a 3 années et 5 mois par floperret.
    #2358692
    abds69
    Participant
    Padawan WordPress
    62 contributions

    Je pense que que vous ne saississez pas comment fonctionne WordPress pour livrer des pages;

    -a la racine du site, vous avez le index.php

    -ce index.php doit accèder où se trouve le fichier wp-blog-header.php, d’où le rajout /wordpress car tous les fichiers se trouve là-bas

    -une fois amorcer, wordpress va composer ces pages en utilisant les permaliens et les réécritures du ficher .htaccess, d’ou le besoin de nettoyer ce fichier et de laisser wordpress le recréer.

    Donc c’est un ménage à trois : .htaccess, index.php modifié, variable WP_home et WP_siteurl<
    Si un seul est incorrect cela ne passe pas. concernant la base mysql, si vous revenez à l’emplacement du site initial, pas de modif

    cdt.

     

    #2358753
    Flobogo
    Modérateur
    Maître WordPress
    20084 contributions

    Bonjour,


    @floperret
    :

    Je vois que vous êtes revenue à la version avec « wordpress »

    Reprenez la manip que vous aviez commencée, sauf la partie entre crochets [ … ] puisqu’elle correspond à ce que vous vouliez obtenir :

    Je me suis donc connectée en FTP et ai déplacé tous les fichiers dans le dossier “au dessus” et ai supprimé le dossier /wordpress,
    [ j’ai changé le fichier .htaccess, et pour finir, dans wp-config.php,  j’ai défini l’adresse de la page d’accueil en retirant le /wordpress. ]

    A partir de là, utilisez le script searchandreplacedb de Interconnectit comme indiqué dans ce tuto. Une fois que ce sera fait, rendez-vous dans les Réglages du site, et ré-enregistrez les permaliens (sans changer d’option, cliquez juste sur « sauvegarder »). Tout devrait rentrer dans l’ordre

     


    @abds69
    :

    ce index.php doit accèder où se trouve le fichier wp-blog-header.php, d’où le rajout /wordpress car tous les fichiers se trouve là-bas

    Non, justement, @floperret avait bien expliqué avoir tout remonté d’un cran

5 sujets de 1 à 5 (sur un total de 5)
  • Vous devez être connecté pour répondre à ce sujet.