[Résolu] Problème lors de la mise à jour de la version 5.6 (Créer un compte)

  • WordPress :5.5
  • Statut : résolu
  • Ce sujet contient 5 réponses, 3 participants et a été mis à jour pour la dernière fois par gsmopige, le il y a 3 mois.
6 sujets de 1 à 6 (sur un total de 6)
  • Auteur
    Messages
  • #2364623
    gsmopige
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Ma configuration WP actuelle

    Version de WordPress : 5.6 après mise à jour aujourd’hui

    Adresse du site : localhost

    PHP 7.2.10 / MySQL 5.7.23

    Thème utilisé : Twenty Sixteen avec un thème enfant

    Thème URI : ?

    Extensions en place : Akismet Anti-Spam/TablePress/UpdraftPlus/WP-Optimize/Yoast SEO

     

    Problème(s) rencontré(s) :

    Tout d’abord, bonne année à toutes et à tous.

    La mise à jour de la version 5.6 effectuée ce matin s’est terminée avec le message suivant:

    Deprecated: add_option_whitelist est obsolète depuis la version 5.5.0 ! Utilisez add_allowed_options() à la place. in E:wamp64wwwcgrisqwp-includesfunctions.php on line 4859

    La ligne 4859 de functions.php (en date d’aujourd’hui, donc mise à jour) contient l’expression suivante : E_USER_DEPRECATED

    Que puis-je faire pour réparer ce problème

    Merci pour vos conseils

    #2364631
    PhiLyon
    Modérateur
    Maître WordPress
    27563 contributions

    Bonjour.

    Passe déjà ton PHP en 7.4 si tu peux.

    Si cela ne change rien désactive tes extensions.

    🙂

    #2364787
    gsmopige
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Merci pour ta réponse rapide à laquelle je réponds un peu tardivement. Ta réponse m’amène à plusieurs questions.

    1/ J’utilise un PC de bureau et un ordinateur portable. Sur ce dernier j’ai installé WordPress pour développer et tester le site en local avec Wampserver 3.1.4 qui contient la version 7.2.10 de PHP.

    Sur le portable, j’ai installé récemment la version 5.6 de WordPress sans avoir le problème que je rencontre sur le PC de bureau qui a les mêmes versions de Wampserver et de PHP.

    Pourquoi la mise à jour génère une erreur sur le PC de bureau et fonctionne sans problème sur le portable?

    2/ Dans ta réponse, tu dis : “Passe déjà ton PHP en 7.4 si tu peux”. Pourquoi “si tu peux”? En fait je ne sais pas comment passer le PHP à la version 7.4. Quand je clique dans Wampserver sur PHP/version, la plus élevée qui s’affiche est 7.2.10. Comment passer à la version 7.4 ?

    3/ Comment est-il possible de désactiver les extensions sans perturber le fonction normal du site ?

    Merci pour ton assistance

    #2364788
    pasglop
    Participant
    Chevalier WordPress
    245 contributions

    Bonjour,

     

    Ici (http://forum.wampserver.com/read.php?1,137154), tu as tout pour les mises à jour de version, dont celle de wampserver 3.2.3 (attention, bien lire concernant les paquetages VCxx) et de php (à minima la 7.4.13)

    #2364789
    PhiLyon
    Modérateur
    Maître WordPress
    27563 contributions

    Bonjour.

    Tu as la dernière version de WAMPP ?

    Comment est-il possible de désactiver les extensions sans perturber le fonction normal du site ?

    Si le site n’est pas en ligne cela ne gène pas trop.

    🙂

    #2365495
    gsmopige
    Participant
    Initié WordPress
    41 contributions

    Bonjour,

    Il suffit de mettre à jour les extensions pour réparer l’erreur

    Merci pour vos conseils

6 sujets de 1 à 6 (sur un total de 6)
  • Vous devez être connecté pour répondre à ce sujet.