Problème installation WordPress (Créer un compte)

  • Statut : non résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #550623
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : wordpress-4.2.2-fr_FR
    – Version de PHP/MySQL : v5.5
    – Thème utilisé : /
    – Extensions en place : /
    – Nom de l’hebergeur : OVH
    – Adresse du site : http://www.lgphotography.fr/WordPress/

    Problème(s) rencontré(s) :

    Bonjour,

    Après une longue hésitation entre WordPress ET Joomla, jê me suis tourné vers WordPress pour refaire mon site photo.

    Ne souhaitant pas que mon ancien site soit hors ligne le temps de la réalisation du nouveau, j’ai pris conseil ici et ai décidé d’installer WordPress dans un sous-répertoire et de créer mon site dans ce sous-répertoire, pour transférer l’ensemble plus tard.

    Je viens de transférer les fichiers d’installation de WordPress dans le répertoire, et lorsque je tente d’y accéder, j’ai le message d’erreur suivant : Parse error: syntax error, unexpected ‘{‘ in /home/lgphotog/www/WordPress/wp-includes/functions.php on line 2678

    J’ai tenté de relancer le transfert des fichiers via FileZilla en choisissant l’option “remplacer si la taille est différente”, au cas où un fichier aurait été mal transféré, mais sans succès…

    Est-ce que c’est parce qu’il est dans un sous-répertoire ?
    Que dois-je faire ?

    Mon hébergeur est OVH, je souhaite effectuer l’installation manuellement et l’adresse que j’ai tapée pour l’installation est http://www.lgphotography.fr/WordPress/wp-admin/install.php
    J’ai aussi essayé http://www.lgphotography.fr/WordPress/ et le message d’erreur est le même.
    En revanche, quand je tape http://www.lgphotography.fr/WordPress/wp-includes/, j’ai la liste des fichiers installés.

    Merci pour votre aide !

    #1008461
    bill57
    Participant
    Maître WordPress
    857 contributions

    salut, as tu crée la base de données dans phpmyadmin

    #1008462
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

    Oui, je l’ai créée hier et elle apparait bien dans mon manager.

    #1008463
    Flobogo
    Modérateur
    Maître WordPress
    16278 contributions

    (re)bonsoir,

    L’idée de relancer les fichiers par FTP est bonne :
    – supprimez tous les fichiers/dossiers qui sont déjà dans le répertoire de votre-site/Wordpress
    – d’ailleurs, profitez-en pour renommer le dossier sans majuscule : votre-site/wordpress
    – relancez à nouveau le transfert complet, dossier par dossier sans oublier les fichiers wp-xxxx situés à la racine (pour vous, à mettre dans votre-site/wordpress).

    #1008464
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

    Bonjour,

    Merci pour votre réponse.
    J’ai mis un peu de temps car j’ai dû avancer sur autre chose…

    J’ai essayé, mais ça ne marche toujours pas, j’ai toujours le même message.
    J’ai aussi essayer de réextraire le fichier functions.php de l’archive téléchargée sur WordPress, mais toujours le même problème…

    #1008465
    C_Lucien
    Modérateur
    Maître WordPress
    4250 contributions

    Bonsoir,

    quand je tape http://www.lgphotography.fr/WordPress/wp-includes/, j’ai la liste des fichiers installés.

    Est-ce normal qu’on puisse lister le contenu de ce répertoire ? Je croyais WordPress conçu pour ne pas laisser lister à quiconque le contenu des répertoires, sauf via ftp.
    Est-ce une porte ouverte aux pirates de tout poil ?

    #1008466
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

    Aucune idée… Peut-être parce qu’il n’est pas encore installé…

    #1008467
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

    Bon, après une période d’inactivité, dernière tentative avant de passer à Joomla, et j’ai finalement trouvé la solution, si ça peut en aider d’autres : http://www.commentcamarche.net/forum/affich-31914864-probleme-parse-error-wordpress-4-2-1-via-filezilla

    #1008468
    Flobogo
    Modérateur
    Maître WordPress
    16278 contributions

    La solution indiquée fait référence à un problème de version PHp trop ancienne. Pourtant, dans la configuration indiquée dans votre 1er message, vous avez mentionné :

    Version de PHP/MySQL : v5.5

    Donc, en principe, c’était déjà une bonne version de PHP …

    Tant mieux si vous avez résolu votre problème, mais du coup, on ne sait pas si c’était vraiment un pb de version PHP

    #1008469
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

    Et le pire, c’est que je ne sais plus d’où j’avais tiré ces informations…
    Je n’avais peut-être pas cherché au bon endroit dans OVH… 😕
    Pas évident sans aucune connaissance informatique !

    Je suis mùaintenant en train d’essayer de personnaliser mon thème, je suis parti sur Snapshot. 😉

    #1008470
    LGphoto
    Membre
    Padawan WordPress
    78 contributions

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.