[Résolu] Problème images produit (version mobile)

  • WordPress :4.9
  • Statut : résolu
11 sujets de 1 à 11 (sur un total de 11)
  • Auteur
    Messages
  • #1993546

    MaxF
    Participant
    Initié WordPress
    5 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL :
    • Thème utilisé : NORTH
    • Extensions en place :
    • Nom de l’hébergeur : OVH
    • Adresse du site : https://newequilibre.com

    Problème(s) rencontré(s) :

    Je viens vers vous en espérant obtenir votre aide.

    Sur la version mobile, les images produits s’affichent les unes en dessous des autres, ce qui fait vraiment désordre. Normalement, elles devraient toutes être regroupées sur une ligne.

    J’utilise le plugin YITH zoom magnifier, et sur la version desktop, l’affichage se fait correctement. J’ai désinstallé, supprimé, ré-installé le plugin, mais le problème persiste sur mobile et tablette.

    Le problème est apparu il y’a deux jours, alors que j’utilise le plugin depuis plusieurs mois et tout fonctionnait correctement.

    Quelqu’un a une idée du problème ?

    Voici un lien vers une page produit de mon site :

    VILLE

    En vous remerciant,

    Maxime

    #2003324

    Antwane
    Participant
    Initié WordPress
    11 contributions

    problème de cache peut être ?

    #2003401

    Joss47
    Participant
    Maître WordPress
    2922 contributions

    Bonjour @maxf,

    Si tu désactives toutes tes extensions sauf woocommerce et le plugin de YiTh, que tu vides le cache est-ce que le soucis est toujours présent ?

    #2003516

    MaxF
    Participant
    Initié WordPress
    5 contributions

    Bonjour Antware et Joss47,

    Merci pour vos réponses.

    En ce qui concerne le cache, je ne sais pas vraiment.. J’utilise des plugins pour gérer l’efficacité du site à travers le cache et en les désactivant le problème persiste. J’ai également essayé en désactivant toutes les extensions sauf woocommerce et le plugin YiTh mais rien ne change..
    Vous voyez le problème sur la version mobile ?
    Ce qui est étrange, c’est que ce midi, en cliquant sur une photo de produit a partir du mobile, j’arrive sur une nouvelle page pour voir la photo seule, en faisant retour, une fois sur 3 la page redevenait dans l’ordre avec la bonne présentation…

    De plus, sur desktop, si l’on réduit la page au format mobile, tout est dans l’ordre. Mais dès que l’on est sur tablette ou mobile, ca ne fonctionne plus.

    • Cette réponse a été modifiée le il y a 2 jours et 6 heures par  MaxF.
    #2003546

    Joss47
    Participant
    Maître WordPress
    2922 contributions

    Oui en responsive ordinateur ça marche, sur mobile non.
    AU clic sur l’image on est redirigé vers un hébergement ou ta photo est, tu n’as pas Jetpack activé ou quelque chose du style pour hébergée tes photos compressées ailleurs ?

    #2003566

    MaxF
    Participant
    Initié WordPress
    5 contributions

    Effectivement, Jetpack jouait un rôle sur ces liens inconnus pour les photos produits. Je l’ai désactivé, mais le problème de presentation persiste.
    Je ne comprend pas car en cliquant sur une image, j’arrive sur la page de l’image seule, puis en revenant à la page précédente, et en actualisant la page, la présentation devient normale de temps en temps mais le site se fige.
    C’est frustrant de ne pas savoir d’ou vient le problème… En plus, ce problème d’affichage en version mobile me fait perdre des clients…

    #2003575

    Joss47
    Participant
    Maître WordPress
    2922 contributions

    Et si tu enlève YITH zoom magnifier le soucis est toujours présent? En prenant bien soin de vider tout tes caches 😉

    Si tu regarde la démo de ton thème, à tout hasard le bug ne serait il pas déjà présent?
    PS : Le nom du dossier de ton thème c’est vraiment pas top comment tu l’as uploadé sur ton FTP :/
    « https://newequilibre.com/wp-content/themes/North v3.4.0 – One Page Parallax WordPress Theme »

    #2003590

    MaxF
    Participant
    Initié WordPress
    5 contributions

    Ca semble re-fonctionner correctement !

    Alors j’ai désactivé le plugin comme tu m’as dis, et vidé le cache. La première fois, rien n’a changé. Mais ensuite, je suis passé par « WP Fastest Cache » et j’ai effacé le cache suivant : « Delete Cache and Minified CSS/JS ». Et là, ca à fonctionné. J’ai ensuite ré-activé « YiTH Zoom magnifier » et tout est ok !
    Donc le problème venait apparemment d’un code CSS ou d’un code JavaScript mais je n’ai aucune idée de comment celui-ci est arrivé. Je n’avais pourtant rien touché à ce niveau.

    Merci beaucoup Joss, c’est grace à toi que ca fonctionne !

    #2003591

    Joss47
    Participant
    Maître WordPress
    2922 contributions

    A mon avis c’est le minification ou compression d’une option de Fastest Cache 😉
    Coche petit à petit et investigue de ce côté !

    N’oublie pas de passer en résolu en haut à gauche.

    #2003592

    MaxF
    Participant
    Initié WordPress
    5 contributions

    Je vais approfondir ma recherche sur ce problème, mais l’important c’est que la version mobile est repris une forme correcte !
    Merci beaucoup pour ton aide, je cloture le sujet 🙂

    Bonne fin de journée Joss !

    #2003598

    Joss47
    Participant
    Maître WordPress
    2922 contributions

    Avec plaisir, pareillement 😉

11 sujets de 1 à 11 (sur un total de 11)
  • Vous devez être connecté pour répondre à ce sujet.