[Résolu] Problème « Il y a eu une erreur critique sur ce site. «  (Créer un compte)

  • WordPress :6.2
  • Statut : résolu
14 sujets de 1 à 14 (sur un total de 14)
  • Auteur
    Messages
  • #2455682
    forbans
    Participant
    Initié WordPress
    16 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Version de PHP/MySQL : PHP 8.1/MySQL 5.7
    • Thème utilisé : Mantra
    • Extensions en place : Advanced Editor Tools, Akismet Anti-Spam: Spam Protection, BackWPup, Classic Editor, Contact Form 7, Cryout Serious Theme Settings, Moteur ImageMagick, Simple:Press, SuitePlugins – Login Widget for Ultimate Member, Ultimate Member, Ultimate Member – reCAPTCHA, WP Fastest Cache
    • Nom de l’hébergeur : ionos
    • Adresse du site : http://www.gambetta-pokerclub.fr

    Problème(s) rencontré(s) :

    Bonjour, Voici mon gros problème lors de la migration de la version PHP je ne peux plus accéder à mon forum, cela me met  »

    Il y a eu une erreur critique sur ce site.

    En apprendre plus sur le débogage de WordPress. »

    Par contre le reste du site marche nikel.

    Merci de votre aide.

     

    Cordialement

    #2455684
    C_Lucien
    Modérateur
    Maître WordPress
    5116 contributions

    Bonjour,

    peut-être une extension incompatible avec PHP 8.1.

    Désactivez-les toutes dans un premier temps, éventuellement en renommant le dossier plugins.

    Si ça tombe en marche, remettez le nom initial, puis activez les extensions une à une, jusqu’à tomber sur la fautive.

    S’il s’agit de Simple:Press, voir leur support si des problèmes sont apparus avec PHP 8.1

    #2455690
    pasglop
    Participant
    Maître WordPress
    687 contributions

    Le thème Mantra n’a pas été mis à jour depuis Mars 2021, ce qui peut (va) poser problème. Est-il compatible avec PHP 8.1 ?

     

    De plus, votre site est accessible en HTTP comme en HTTPS, il vous faudrait interdire l’accès en HTTP.

    • Cette réponse a été modifiée le il y a 10 mois et 3 semaines par pasglop.
    #2455915
    forbans
    Participant
    Initié WordPress
    16 contributions

    J’ai désactivé toutes les extensions ensuite j’ai changé de thème cela ne ressoude pas le problème.

    J’ai vu que plein de personne avait des problème avec la derniere version de WordPress et sans reel solution. Je pense cela peut venir de la.

    #2455919
    Li-An
    Participant
    Maître WordPress
    28383 contributions

    Bonjour, baissez la version de php en 8.0+ pour voir. Je ne sais pas où vous avez vu que SimplePress rencontrait des problèmes avec la dernière version de WP. Il est annoncé comme compatible et le forum officiel ne reflète pas un éventuel dysfonctionnement. Par contre, certaines extensions spécifiques à SimplePress ne sont pas compatibles php 8.1+ et ça peut expliquer vos problèmes.

    #2455936
    forbans
    Participant
    Initié WordPress
    16 contributions

    Bonjour je pense avoir trouvé le problème j’ai une vieille version de simple press  la  5.7.5.3

    Il faudrait que je passe en version supérieur. Savez vous comment faire la mise à jour de simple press par ftp sans perdre le contenu des forums ?

     

    #2455938
    Li-An
    Participant
    Maître WordPress
    28383 contributions

    Si vous avez accès à l’admin, pourquoi ne pas faire la mise à jour à cet endroit ?

    #2455961
    forbans
    Participant
    Initié WordPress
    16 contributions

    Il me propose pas une mise à jour. Il me propose juste uns installation et quand je lance l’installation crla me met un message d’erreur lors de l’activation

     

    #2455964
    C_Lucien
    Modérateur
    Maître WordPress
    5116 contributions

    Bonjour,

    à priori, le rechargement via FTP ne devrait pas affecter les paramètres d’une extension, qui, si je ne me trompe pas, stocke ses infos en base de données.

    Ça devrait donc fonctionner en écrasant simplement le dossier de l’extension, non ? C’est une vraie question, je n’ai pas le souvenir d’avoir tenté cette manip.

    Vous avez une extension de cache, vérifiez ses particularités et peut-être la désactiver pendant les mises à jour.

     

    #2455977
    Li-An
    Participant
    Maître WordPress
    28383 contributions

    Si lorsque vous activez, vous avez le message d’erreur, passer par le FTP ne va rien changer. Vous avez changé la version du php ? Tout est bien à jour dans toutes les extensions ?

    #2455994
    Flobogo
    Modérateur
    Maître WordPress
    20088 contributions

    Bonjour,

    le rechargement via FTP ne devrait pas affecter les paramètres d’une extension, qui, si je ne me trompe pas, stocke ses infos en base de données.
    Ça devrait donc fonctionner en écrasant simplement le dossier de l’extension, non ?

    Je confirme. J’utilise assez souvent cette manip’ pour mettre à jour des sites locaux (copies de mon propre site pour divers tests sur des thèmes ou extensions). Bon, c’est un peu « barbare » (c’est pourquoi je ne le fais qu’en local), et il ne faut peut-être pas sauter dix versions d’un coup, au cas où des réglages indispensables pour la suite apparaîtraient à mi-chemin.

    #2456011
    forbans
    Participant
    Initié WordPress
    16 contributions

    Bonjour j’ai fais la mise à jour par FTP, ce qui a fait tout bugger le site. J’ai ensuite désactivé toutes les extensions pour faire revenir le site. En voulant réactivé simplepress, un message d’erreur est apparu en disant que les fichiers étaient corrompus et qu’il fallait que je fasse une mise une jour de simplepress vers la nouvelle version. Une fois fait, plus aucun problème et plus d’erreur critique. Merci de votre aide à tous.

    #2456125
    Elodie31
    Participant
    Initié WordPress
    2 contributions

    Bonjour

    J’ai un message d’erreur qui s’affiche sur mon site et je n’arrive pas à résoudre le problème. Pouvez-vous m’aider s’il vous plaît

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2456129
    C_Lucien
    Modérateur
    Maître WordPress
    5116 contributions

    Bonjour @elodie31,

    merci d’ouvrir une nouvelle discussion.

    1. décrire votre configuration complète. Cette extension vous sera utile https://github.com/zitezinfo/infosite
    2. décrire votre problème en détail, une capture d’écran ne permet pas les recherches ultérieures
    3. votre site est vraisemblablement destiné à un public adulte et « averti ». Merci de vous référer aux règles du forum.
14 sujets de 1 à 14 (sur un total de 14)
  • Vous devez être connecté pour répondre à ce sujet.