Problème “erreur HTTP” à l’upload de médias après passage en multisite

  • WordPress :5.2
  • Statut : non résolu
13 sujets de 1 à 13 (sur un total de 13)
  • Auteur
    Messages
  • #2257496
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Ma configuration WP actuelle

    Problème(s) rencontré(s) :

    Bonjour à tous ! Après avoir essayé une dizaine “d’astuces” pour régler un problème d’erreur HTTP, je me tourne tout désespéré vers vous : je n’arrive pas à corriger une erreur HTTP lors de l’upload de médias sur mon nouveau site (https://www.thegreatpearler.com/concept-store), mon site principal étant “https://www.thegreatpearler.com”. Je tiens à préciser que cette erreur n’apparaît pas sur ce site là.

    Je tiens à préciser aussi les actions que j’ai déjà essayé, sans succès :

    1. Diminuer la taille de l’image : mon image fait 135 Ko, je ne pense pas que cela soit le problème
    2. Augmenter la mémoire PHP : modifier le .htaccess ou le wp-config.php : dans les deux cas cela me provoque une erreur 500 serveur
    3. Désactiver tous les plugins : déjà fait, aucun résultat
    4. Changer de thème : malheureusement, je ne l’ai pas encore fait, mais j’espère que cela ne vient pas de ça, car je tiens beaucoup à ce thème
    5. Modifier le .htaccess avec le code suivant
    # uploaded files
    
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

     

    Cependant une autre piste qui pourrait être explorée serait de regarder au niveau du chemin d’accès des nouveaux médias ajoutés sur le serveur. Pour le moment, le chemin est le suivant : www>wp-content>uploads (que j’ai d’ailleurs changé en 755 pour les droits d’accès). (Voir plus de détails dans le screen associé).

    Mais je n’ai aucune idée comment intervenir dans le chemin des images uploadées.

     

    Auriez-vous une piste ? Les différents tickets ouverts sur le sujet ne m’ont pas aidé…

     

    Merci d’avance 🙂

    • Ce sujet a été modifié le il y a 3 mois par  Thegreatpearler. Raison: Cliqué sur envoyer trop tôt
    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2257587
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    N’hésitez pas à me dire si j’ai oublié une information qui pourrait être utile pour un début de solution… Bon week end de Pâques à tous!

    #2257588
    ferman
    Participant
    Maître WordPress
    729 contributions

    Bonjour,

    De quelle erreur http voulez-vous parler?

    #2257589
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Alors, c’est une erreur HTTP sans plus de précision qui apparaît lorsque j’envoie un fichier sur mon nouveau site (installé en sous-dossier) (voir la pièce jointe).

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2257593
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    En fait, je suis toujours persuadé que le problème vient du chemin de l’upload des images à partir du nouveau site (www.thegreatpearler.com/concept-store). Mais je ne sais pas comment y remédier.

    1. Le chemin d’accès ?

    Depuis que j’ai installé le multisite, c’est devenu naturellement le gros bordel dans le fichier “uploads”. Le chemin qui s’est naturellement mis pour l’upload des fichiers sur le nouveau site est le suivant :

    www>wp-content>upload>sites>4 (à quoi servent le 2 et le 3 d’ailleurs?)>2019>04 (si j’ai bien compris, chaque mois un dossier est créé pour les uploads du mois en cours).

    Pour le site principal (www.thegreatpearler.com) => www>wp-content>upload>2019>04, ce qui me paraît très normal (et ça marche bien d’ailleurs).

    Que ce soit pour le site principal ou le site secondaire, les droits d’accès de ces dossiers et sous-dossiers sont en 705 (propriétaire : lire/écrire/exécuter; groupe : X/X/X ; publique : lire/X /exécuter). D’ailleurs, j’ai essayé le code 750 mais aussi le 760 (propriétaire : lire/écrire/exécuter; groupe : lire/écrire/X ; publique : X/X/X) mais l’erreur HTTP n’a pas disparue.

    2. L’attaque de WooCommerce

    Je viens aussi de m’apercevoir que Woocommerce essaye tout le temps de m’upload un fichier image sur mon nouveau site (voir en pièce jointe), l’image woocommerce-placeholder.png, et cela en grande quantité. Avant tout de chose, je vais essayer de désinstaller le plugin pour voir si cela répare mon problème http error, mais comme je l’ai déjà dit dans mon premier message, la désactivation de tous mes plugins n’avaient rien changé.

     

    3. Les images fantômes

    Comme vous pouvez le voir également dans mon screen, j’ai des blocs “fichiers” qui soit n’apparaissent pas (mais avec le nom du média quand même) soit rien ne s’affiche non plus. Encore une fois, cela se passe sur mon nouveau site (www.thegreatpearler.com/concept-store) et tout va bien sur mon installation principale.

     

    4. Les erreur HTTP 500

    Depuis peu (je crois que depuis que j’essaye de bidouiller pour l’erreur HTTP de l’upload des images); j’ai régulièrement une erreur HTTP 500 quand j’essaye d’accéder à MES sites (le principal et le secondaire). Pour le coup, je crois que ça vient de mon fichier .htaccess, dont je vous mets la copie du code ici =>

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # redirection HTTPS
    RewriteCond %{HTTPS} !=on
    RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    </IfModule>
    # END WordPress
    .htaccess

     

    Voilà, j’essaye d’avancer point par point tout seul, mais si quelqu’un à une idée sur ce qu’il se passe… En attendant je vais tenter la désactivation de Woocommerce pour voir ce que cela change.

    Merci d’avance

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2257614
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Alors, dernier point.

    Désactiver Woocommerce n’a pas arrangé les choses. Mais quelques nouveaux éléments :

    Malgré l’erreur HTTP lors de l’upload, le fichier est bien téléchargé dans le dossier www>wp-content>upload>sites>4>2019>04, mais avec le droit d’accès 604. Je me suis dit que c’était peut être ça qui foutait la merde, du coup je l’ai remis en 705 comme tous les autres fichiers présents dans le dossier des uploads du site principal.

    Et toujours rien. Il n’y a même pas d’aperçu de l’image dans WordPress (voir screen). Je n’y comprends rien du tout…

     

    A l’aide.

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2257619
    ferman
    Participant
    Maître WordPress
    729 contributions

    Malheureusement, je ne pourrai pas vous aider, je ne suis pas du tout familier des wp multisites et mes .htaccess sont très différents de ce que vous avez. Vous êtes sûr que le .htaccess actuel correspond bien à votre cas (plusieurs possibilités dans le codex). Vous avez sans doute vu ça. Désolé, peut-être qu’un autre participant sera plus compétent dans ce domaine.

    • Cette réponse a été modifiée le il y a 2 mois et 4 weeks par  ferman.
    #2257621
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Merci en tout cas pour votre lien !

    Alors, j’ai essayé l’ensemble des solutions proposées dans ce lien avant de demander de l’aide, à part de supprimer le chemin personnalisé (10) et la désactivation de mod_security (11), que je n’avais pas vu dans les autres “tuto” que j’avais exploré.

    Concernant mon .htaccess, c’est un assemblage de plusieurs codes : une partie provient de ce que l’on doit ajouter pour permettre le multisite (fourni par wordpress lui-même) et une contient les redirections nécessaires à un HTTPS (après pas sûr que j’ai un code parfait, si quelqu’un si connait, ça serait encore mieux).

    Du coup je vais tenter les deux options que j’avais loupé.

    1) Modifier le chemin d’accès : moi, je ne peux pas modifier le chemin de mes médias directement dans les réglages (voir screen), du coup je vais voir si je peux le faire ailleurs, c’est peut être différent avec le multisite

    2) L’ajout du code pour désactiver le mod_security dans le .htaccess me provoque une erreur 500 HTTP internal serveur error. Donc impossible d’essayer quoi que ce soit avec.

     

    EDIT : il y a bien un réglage à faire dans “upload path” dans les réglages des sites. Cependant, ce champ est vide pour mes deux sites (voir screen), si quelqu’un peut me dire si je dois le configurer (sachant qu’il est naturellement bien fait pour le site principal) et semble peut être défectueux pour mon site secondaire, qu’il n’hésite pas 😉

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2257624
    ferman
    Participant
    Maître WordPress
    729 contributions

    Vos redirections fonctionnent donc c’est bon mais normalement on ne les met pas dans ce qui concerne wordpress (entre #begin wordpress et #end wordpress) mais en dehors. Il y a plusieurs versions de cette redirection et chaque hébergeur recommande la sienne pour ovh, c’est plutôt:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.votresite.fr/$1 [R=301,L]

     

    mais bon si ça marche. Vous avez aussi beaucoup de contenu mixte mais ça vous le savez forcément. C’est tout ce que je peux dire.

    #2257629
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Ah tiens, je serais intéressé de savoir comment optimiser ce .htaccess. Le bon code serait alors :

    # redirection HTTPS
    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.thegreatpearler.com/$1 [R=301,L]
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    # Multisite
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    	
    </IfModule>
    # END WordPress

     

    Vous pensez que c’est cela qui peut me provoquer mes erreur HTTP ?

    #2257633
    ferman
    Participant
    Maître WordPress
    729 contributions

    Je ne sais pas, c’était juste une remarque et je ne connais pas toutes ces lignes à base d’expressions régulières (<code class=” code-embed-code language-markup”>^([_0-9a-zA-Z-]+/)? etc.),  j’ai appris aujourd’hui que ça existait en regardant le codex. Mes .htaccess sont beaucoup plus simples et se limitent à la redirection que je vous ai donnée + le htaccess de base de wordpress (+ de nombreuses directives que mon plugin de sécurité met en place automatiquement et dont je ne m’occupe pas). Comme je vous le disais , je ne connais pas wp multisite.

    Vous devriez peut-être quand même corriger votre contenu mixte (tous vos liens sont en http).  Cela a peut être une influence mais je n’en sais rien.

    • Cette réponse a été modifiée le il y a 2 mois et 4 weeks par  ferman.
    #2257649
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Alors avant d’y toucher, je vais attendre de voir si quelqu’un à une solution pour mon problème principal. En tout cas, merci pour vos conseils.

    #2257832
    Thegreatpearler
    Participant
    Initié WordPress
    17 contributions

    Il n’y avait déjà pas foule pour répondre, mais là je désespère d’avoir des débuts de pistes à explorer… Je m’en vais contacter OVH pour mon problème, et si je trouve une solution, je vous la partagerais.

13 sujets de 1 à 13 (sur un total de 13)
  • Vous devez être connecté pour répondre à ce sujet.