[Résolu] Problème enregistrement attributs (produit variable) (Créer un compte)

  • WordPress :6.1
  • Statut : résolu
9 sujets de 1 à 9 (sur un total de 9)
  • Auteur
    Messages
  • #2433144
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Ma configuration WP actuelle :
    – Version de WordPress : 6.1.1
    – Version de PHP / MySQL : 7.4.33 / 10.3.37
    – Thème utilisé : Broussaille theme (slug : storefront-child)
    – Thème parent : Storefront (slug : storefront)
    – Thème URI : https://woocommerce.com/storefront/
    – Extensions activées :

    3D FlipBook : Dflip Lite (1.7.33),

    Advanced Editor Tools (previously TinyMCE Advanced) (5.6.0),

    Boxtal Connect (1.2.14),

    Classic Widgets (0.3),

    Complianz | GDPR/CCPA Cookie Consent (6.3.5),

    Contact Form 7 (5.6.4),

    Email Templates (1.3.2.1),

    Enhanced Media Library (2.8.9),

    everwpvisitcounter (1.2.3),

    Flamingo (2.3),

    Imagify (2.0),

    Infosite (6),

    Lightbox with PhotoSwipe (5.0.18),

    MailPoet (4.0.1), MailPoet Premium (4.0.0),

    Preview E-mails for WooCommerce (2.1.1),

    Rank Math SEO (1.0.102.1), Rank Math SEO PRO (3.0.24),

    Responsive Menu (4.2.0),

    SecuPress Pro — WordPress Security (2.2.3),

    Widget Logic (5.10.4),

    WooCommerce (7.1.0), WooCommerce Payments (5.0.3), WooCommerce PayPal Payments (2.0.0), WooCommerce Stripe Gateway (7.0.1),

    WP Mail Logging (1.10.4), WP Mail SMTP (3.6.1), WP Rocket (3.12.3.2)
    – Adresse du site : https://broussaillestore.fr
    – Hébergeur :o2switch

    Bonjour à toutes et à tous.

    Problème(s) rencontré(s) : Dans Woocommerce, pour un produit variable, lorsque j’enregistre les attributs, il faut que je fasse « la manœuvre » plusieurs fois. Généralement 3 (ou 4 au pire) fois, pour que ces derniers daignent s’enregistrer. Lorsque je fais « enregistrer », cela à l’air de fonctionner, quoique cela se fasse en deux temps : la « petite roue » d’enregistrement tourne, s’arrête et se remet en route une deuxième fois, on peut alors penser qu’ils sont enregistrer.

    Mais si je vais dans les variations, je tombe systématiquement sur « enregistrer les attributs… gnagnagna… gnagnagna… »? Ça m’agace… Et puis, au bout de 3 ou 4 fois, ça fonctionne. Je n’ai rien trouvé sur ce problème, j’imagine donc que c’est lié uniquement à ma configuration, mais je ne vois pas trop quoi faire (bon, à part désactiver toutes les extensions, etc… mais j’ai testé sur un site clone, et ça ne change rien…).

    #2433289
    momofr@free.fr
    Modérateur
    Maître WordPress
    7096 contributions

    Salut, je te prose déjà, puisque tu es chez O2Switch, c’est de passer ton hébergement sous PHP 8.1, et de lui allouer 1024 Mo de ram (la bonne formule avec WooCommerce).

    Si, lorsque tu désactives tes autres extensions sauf WooCommerce, cela fait la même chose il y a effectivement un souci quelque part.

    #2433298
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bonjour momofr@free.fr, et merci de ton retour.

    J’avais tenté il y a quelques temps (environ 8 mois), le passage en PHP 8.1, et le moins que l’on puisse dire, c’est que l’essai n’avait pas été concluant.

    Je vais réessayer, je pense qu’aujourd’hui les extensions sont toutes OK pour supporter ça…

    Pour ce qui est des 1024 de ram, ça m’étonne, je pensais avoir augmenter la dose, je vais donc revérifier.

    Je te tiens informé.

    Bonne journée.

    #2433301
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Bon, ben non. Que ce soit en 8 ou en 8.1, c’est « the damn white screen of death » (ou quelque chose du genre), comme on dit dans certains milieux autorisés… Est-ce que ça peut être dû au fait que j’utilise un thème-enfant ? avec pas mal de fichiers modifiés. Durant un moment j’avias un mu-plugin, qui mettait le dawa, mais je l’ai supprimé, donc maintenant je ne vois pas pourquoi le site ne supporte pas le PHP 8 ou 8.1…

    Pour ce qui est des 1024, je règle ça où ? J’imagine dans mon functions.php (du thème-enfant), ou il y a t-il un fichier spécifique à modifier ?

    Bon, là je tente dans le functions.php, je vais voir ce que ça donne.

    #2433304
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Alors coïncidence (ou bon réglage ?), les 1024 dans le functions.php, ça à l’air de fonctionner. Du moins sur un article test où je n’ai mis qu’un titre, des attributs et les variations correspondantes. Ce qui me donne l’idée, au cas où le problème se représenterait, d’ajouter en premier lieu attributs et variations avant toute autre chose. Sait-on jamais où se cache le p’tit bug ! Bon j’attends un peu de tester de nouveau, avant de mettre le sujet en résolu. En tous cas, MERCI !

    #2433410
    momofr@free.fr
    Modérateur
    Maître WordPress
    7096 contributions

    Salut, sais-tu que chez O2Switch tu peux configurer la ram et les options de PHP ?

    Ça se passe dans version de PHP -> Options.

    #2433457
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Salut Momo. Oui, c’est là où j’ai testé le passage en PHP 8.1, puis 8. Après, pour les réglages de ram, je pense qu’ils sont bons (je t’envoie une capture d’écran). Mais dans l’ensemble, la plupart des réglages de cette section, je ne comprends pas à quoi ils servent, c’est trop technique pour moi…

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2433462
    momofr@free.fr
    Modérateur
    Maître WordPress
    7096 contributions

    Salut, ok, tu parlais du fichier functions.php, je comprenais pas pourquoi. Si on veut déterminer la mémoire cela se fait plutôt dans wp-config.php.

    #2433470
    Broussaille
    Participant
    Chevalier WordPress
    351 contributions

    Ah bon, alors j’ai fait une boulette. J’ai bien « ajouté » de la mémoire dans le functions.php…

    Bon je te joins une capture de mon functions.php… où j’ai déjà augmenter le wp memory limit

    Du coup, ça ne pose pas problème si je fais le changement dans les deux ?

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
9 sujets de 1 à 9 (sur un total de 9)
  • Vous devez être connecté pour répondre à ce sujet.