[Résolu] Problème échappement des caractères spéciaux dans les widgets avec HTML :

  • WordPress :5.2
  • Statut : résolu
3 sujets de 1 à 3 (sur un total de 3)
  • Auteur
    Messages
  • #2273966
    Phil77
    Participant
    Initié WordPress
    43 contributions

    Bonjour,

    Problème(s) rencontré(s) :

    Dans le widget html personnalisé j’ai mis ce code:

    <a href="https://MonSITE.net/blog/><img src="https://MonSITE.net/wp-content/uploads/2019/08/blog.png" alt="blog"></a>

    Je le réécris ici:
    <div data-redactor-wrapper=”1″><span style=”text-decoration: underline;”><a</span> href=”https://MonSITE.net/blog/&gt;” alt=”</span>blog<span style=”text-decoration: underline;”>“></span></div>
    nB: Erreurs signalées <span style=”text-decoration: underline;”>en gras et souligné</span>

    Il me compte 3 erreurs en me disant que les caractères spéciaux doivent être échappés…. oui mais COMMENT ? 🙂

    Merci pour votre aide !

    Phil

    • Ce sujet a été modifié le il y a 1 mois par  Phil77.
    • Ce sujet a été modifié le il y a 1 mois par  Phil77.
    #2273994
    PhiLyon
    Modérateur
    Maître WordPress
    23580 contributions

    Bonjour.

    Ferme les guillemets de ton href

    🙂

    #2274269
    Phil77
    Participant
    Initié WordPress
    43 contributions

    Même avec ca ca marchait pas (le code etait pas le vrai l’erreur du guillemet est du à l’anonymisation de mon NDD) mais j’ai trouvé une solution merci qd meme ! 🙂

3 sujets de 1 à 3 (sur un total de 3)
  • Vous devez être connecté pour répondre à ce sujet.