Problème d’upload d’images sous WordPress 2.6.2 (Créer un compte)

  • Statut : non résolu
  • Ce sujet contient 16 réponses, 7 participants et a été mis à jour pour la dernière fois par myarts, le il y a 10 années.
15 sujets de 1 à 15 (sur un total de 17)
  • Auteur
    Messages
  • #464054
    Neverlight
    Membre
    Initié WordPress
    6 contributions

    Bonjour,

    Ma configuration WP actuelle
    – Version de WordPress : 2.6.2
    – Thème utilisé : Openbook 2.2
    – Plugins en place : Akismet
    – Nom de l’hebergeur : Netim
    – Adresse du site : http://www.cyclismerevue.eu

    Problème(s) rencontré(s) :

    Bonjour à tous,

    J’ai installé récemment wordpress sur mon site et cela fonctionne très bien. Cependant, j’ai un problème concernant l’importation d’images de mon ordinateur jusqu’au serveur. En effet, dés que je veux placer une photo, je vais la chercher sur l’ordinateur et je clique sur “Envoyer” mais après quelques secondes, ce message s’affiche :

    Le fichier n’ a pas pu être déplacé vers /var/www/vhosts/cyclismerevue.eu/httpdocs/wp-content.

    Quelle pourrait être la solution ? J’ai remarqué, en regardant plusieurs problèmes sur ce forum, qu’un dossier “upload” était présent sur le serveur, dossier que je n’ai pas mais que j’ai créé par après, sans plus de succès.

    Je vous remercie de vos réponses et de votre aide.

    #649150
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Bonjour,
    A vue de nez l’adresse qui est prise par défaut par ton wp n’est pas celle du fichier uploads, mais une autre, d’ailleurs un peu bizarroïde…
    Si tu souhaites utiliser ce fichier uploads, il faut aller dans réglages/divers et vérifier que les deux premières lignes sont correctement remplies : la première indiquant wp-content/uploads, chemin relatif, et la deuxième le même mais sous la forme absolue : http://adressedetonblog/wp-content/uploads.
    Si ça ne fonctionnait encore pas, il se peut que ton fichier uploads, créé par toi, ne possède pas les bons droits d’accès : édite-le via un client ftp, clic droit, attributs du fichier, la valeur numérique doit au moins être égale à 755.
    Si ce n’est pas encore ça, heuh… Reviens dire quoi !

    #649151
    Neverlight
    Membre
    Initié WordPress
    6 contributions

    Merci de votre réponse si rapide.
    J’ai testé les différentes possibilités que vous avez évoqué. J’ai même testé plusieurs noms de dossiers que j’ai créé préalablement sur le serveur (uploads puis images). Cela ne fonctionne toujours pas mais un nouveau message s’affiche :

    Impossible de créer le dossier /var/www/vhosts/cyclismerevue.eu/httpdocs/wp-content/images. Son dossier parent est-il accessible en écriture par le serveur ?

    Pourtant, j’ai mis 755 à ce dossier…
    Je ne comprends pas d’où peut provenir le problème…

    #649153
    jessai
    Membre
    Chevalier WordPress
    112 contributions

    Pourquoi ne pas installer un plug d’upload d’image qui permet d’uploader jusqu’a 8 images en meme temps.

    Elles seront hebergées sur imageshack donc ne prendront pas d’espace sur votre serveur.

    http://wordpress.org/extend/plugins/multiupload-imageschack/

    #649152
    Neverlight
    Membre
    Initié WordPress
    6 contributions

    Certes mais cela m’intéresse de disposer d’une bibliothèque d’images afin de réutiliser ces dernières demain ou même dans un an. 😉

    #649154
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Est-ce que ton fichier, parent de celui où tu mets tes images donc, soit wp-content, possède la même autorisation d’écriture ?

    #649155
    Neverlight
    Membre
    Initié WordPress
    6 contributions

    Oui, je viens de le faire et cela ne fonctionne toujours pas.
    J’espère que mon cas n’est pas désespéré..
    Merci pour votre aide !

    #649156
    Maitre Mo
    Participant
    Maître WordPress
    1656 contributions

    Ben, pour l’instant de rien… Bon, c’est jamais désespéré rassure-toi, c’est juste quelque chose que je ne comprends pas, ce qui m’énerve car ça me renvoie à mon ignorance, mais moi ou un autre ça va venir ! Et cette url vers les images téléchargées qui ne me revient pas… Ce htttpdocs notamment… Peux tu indiquer la structure de l’ensemble, c’est à dire comment sont installés les fichiers wp, sous le www ou dans un sous-dossier, etc..? Ca me donne l’impression que le chemin continue à n’être pas correct, mais je ne connais pas du tout ton hébergeur… Sinon, vérifier aussi que tous les fichiers successifs de la longue adresse sont autorisés en écriture ?

    #649157
    jessai
    Membre
    Chevalier WordPress
    112 contributions

    As tu essayer de mettre en 777.

    as tu un hebergement mutualisé ou serveur dedié.

    Si tu n’es pas proprietaire deu repertoire le serveur ne t’autorisera pas a ecrire dedans meme si le chmod est le bon.

    #649158
    Neverlight
    Membre
    Initié WordPress
    6 contributions

    Le dossier httpdocs est le dossier où je dois placer mes fichiers selon Netim. Les fichiers wordpress sont installés dans ce dossier httpdocs.

    Pour le serveur, il s’agit d’un serveur de Netim qui m’est dédié, dont j’ai reçu les accès ftp.

    J’ai déjà essayé de mettre tous les fichiers en chmod 777 mais rien n’y fait.

    J’avoue ne pas être une bête en informatique. Je me débrouille simplement.

    #649159
    jessai
    Membre
    Chevalier WordPress
    112 contributions

    Si tu as un dedié tu dois utiliser des programmes type putty ou Winscp pour gerer ton serveur.

    Winscp est plus conviviale parce qu’il a une interface graphique.

    sous winscp tu vois directement le groupe et le proprietaire du repertoire pour le chmod click droit sur le repertoire puis proprieté dans la fenetre qui s’ouvre en bas tu devrais avoir 0777 ou 0775.

    J’ai eu un souci comme celui ci.
    le chemin /var/www/vhosts/cyclismerevue.eu/httpdocs/wp-content/images n’etait pas reconnu
    j’ai du mettre /var/www/vhosts/cyclismerevue.eu/wp-content/images.

    Autres questions :
    1) as tu un (ou plusieurs) fichier .htaccess

    2) avec quel ftp as tu uploadé wordpress pour l’installer
    – un prog type filezilla
    – le ftp de ton serveur en etant connecté comme root

    3) as tu essayé un script php pour uploader dans wp-content/images. Sans utiliser wordpress
    un truc simple juste un formulaire et un move_uploaded_file.
    a) ca fonctionne c’est un probleme de chemin
    b ) tu as une erreur c’est soit un probleme de chmod soit un probleme de proprietaire.

    #649160
    kama17
    Membre
    Initié WordPress
    1 contributions

    bonjour
    je reprends le fil de la discussion pour savoir si votre problème avait pu être résolu.
    j’ai exactement le même problème et je ne vois pas du tout d’où ça peut venir.
    j’ai bien vérifié les droits sur chaque dossier. J’ai testé en 777 et 775 sur le dossier wp_content et rien n’y fait…
    Autre chose byzarre je ne peux modifier la structure des permaliens. WordPress me demande donc d’intervenir sur le contenu du fichier .hthaccess et de copier coller le code approprié. Chose faite en passant par mon client ftp mais cela ne change rien.
    Existe t-il un bug ou une config spéciale sur certains serveurs qui empecherait ça.
    Ma configuration
    wordpress : 6.2
    plug-in : tous désactivés
    hébergeur : oxalide
    Theme utilisé : fastway2 (personnalisé)

    Un grand merci à tous ceux qui pourraient me conseiller.

    #649161
    jessai
    Membre
    Chevalier WordPress
    112 contributions

    je pens eque ca vient vraiment du groupe et du proprietaire du repertoire.

    Si tu es en dedié ou VPS : connecte toi en root, et regarde le proprietaire et le groupe du repertoire.
    si tu es en mutualisé demande a ton hebergeur de verifier.

    #649162
    Ittb
    Membre
    Initié WordPress
    1 contributions

    J’avais le même soucis, et en fait, j’ai tout simplement virer l’adresse proposée par défaut
    /var/exports/var_www/blablabla.com/blog/img/2009/02

    et ca marche !

    puisque à côté du champ “Stocker les fichiers envoyés dans ce dossier” est inscrit Par défaut, wp-content/uploads

    #649163
    myarts
    Membre
    Initié WordPress
    3 contributions

    Ma configuration WP actuelle
    – Version de WordPress : 2.5.1
    – Thème utilisé : White as Milk
    – Plugins en place : Akismet 2.1.4 Google Analytics 2.4 All in One SEO Pack 1.4.6.9
    – Nom de l’hebergeur : Aztus
    – Adresse du site : http://www.touslesmusees.com/blog

    Problème(s) rencontré(s) :

    Bonjour, j’ai un problème de transfert d’images récurent. Ça fonctionnait trois fois depuis l’installation du blog. Tellement découragé et j’ai abandonné… ou presque. En passant, je suis un nouveau usager ici et j’essaye de “réanimer” le “Ajouter une image” de mon blog. 🙂

    D’ailleurs, j’ai déjà lu les messages archivés et appliqué les suggestions… aucun résultat. Je résume:
    – Répertoires wp-content et uploads à 0777 : oui
    – Utiliser le thème Standard classique : oui
    – Désactiver tous les plugins : oui

    Le problème actuel : le bouton “Choisissez les fichiers à envoyer” sous l’option “Depuis votre ordinateur” ne produit aucune action quand je l’actionne. Aucun message d’erreur.

    J’ai déjà réussi à transférer des images dans le répertoire “wp-content”, aussi dans “wp-content/uploads” mais après quelque temps, tout est à nouveau “gelé”…

    Merci à l’avance!

15 sujets de 1 à 15 (sur un total de 17)
  • Vous devez être connecté pour répondre à ce sujet.