[Résolu] Problème duplication boutique (Créer un compte)

  • WordPress :5.8
  • Statut : résolu
10 sujets de 1 à 10 (sur un total de 10)
  • Auteur
    Messages
  • #2400420
    BERNARD FCMT
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Ma configuration WP actuelle

    • Ma configuration WP actuelle :
      – Version de WordPress : 5.9.3
      – Version de PHP/MySQL : 7.3.25-1+0~20201130.73+debian9~1.gbp042074 / 5.7.32
      – Thème utilisé : themeenfant
      – Extensions en place : Advanced Woo Search (2.52), amr shortcode any widget (4.0), Contact Form 7 (5.5.6), Contact Form 7 Captcha (0.1.0), Cookie Notice & Compliance for GDPR / CCPA (2.2.3), Custom Product Tabs for WooCommerce (1.7.7), Elementor (3.6.4), Elementor Header & Footer Builder (1.6.10), Forum_wordpress_fr (4.2), GA Google Analytics (20220124), Image Hover Effects Ultimate (Photo Gallery, Effects, Lightbox, Comparison or Magnifier) (9.8.1), Mail Bank (4.0.14), Master Slider (3.8.1), Noptin – WordPress Newsletter Plugin (1.7.3), Polylang (3.2.1), Polylang Connect for Elementor (2.0.8), Redirection (5.2.3), UpdraftPlus – Backup/Restore (1.22.11), W3 Total Cache (2.2.1), WebP Converter for Media (4.3.1), WooCommerce (6.4.0), WooLentor – WooCommerce Elementor Addons + Builder (2.2.4), WP-Optimize – Clean, Compress, Cache (3.2.3), Yoast SEO (18.5.1)
      – Adresse du site : https://ids-agri.com
      – Nom de l’hébergeur : Apache

    Problème(s) rencontré(s) :

     

    Bonjour,

    J’ai un soucis au niveau de la page boutique de mon site. Le lien entre la version française et anglaise ne se fait pas. Je vous explique…

    Lorsque j’ai voulu créé la page boutique en anglais, avec le petit +, elle s’est dupliquée mais la page était vide (prévisualiser). En français, la page est créé via wordpress car je ne pouvais pas la modifier sous Elementor  tandis que la version EN j’ai du la passer en Elementor afin d’intégrer titre, texte, et le short code pour afficher les categ woocommerce.

    Sur ma page boutique https://ids-agri.com/revetements-agricole/, lorsque je clique sur le drapeau EN, je n’arrive pas sur ma page créée en EN mais sur la version française avec les categ woocommerce EN.
    (URL page dupliquée EN :https://ids-agri.com/en/ours-agricultural-mats)

    Auriez vous une solution afin que le lien se fasse correctement? ai-je oublié un paramétrage ?

    Le soucis qui se pose surtout est que j’ai du caché mon fil d’ariane en version EN car au lieu d’avoir « home/our agricultural mats/cows/… » j’ai « home/revêtements de sol agricole/cows/… », et je ne peux laisser cela ainsi… 🙁

    Pouvez vous m’aider svp?

    Merci par avance

     

    #2401827
    momofr@free.fr
    Modérateur
    Maître WordPress
    4589 contributions

    Salut, tu sembles avoir résolu ton problème, je viens de visiter ton site et la page anglaise et bien en anglais.

    Par contre tu devrais revoir tes URL car le slug reste en français (…/en/revetements-agricole/).

    #2401861
    BERNARD FCMT
    Participant
    Initié WordPress
    12 contributions

    Bonjour, tout d’abord merci de ton retour.

    non malheureusement mon problème n’est pas résolu et j’attendais d’avoir des retours du forum pour m’aider. 🙁

    Par exemple, sur ce produit https://ids-agri.com/en/revetement-de-sol/individual-mattress-cows-quietaplus/, lorsque tu cliques dans le fil d’ariane sur « agriculture » tu pourras remarquer que la version de la boutique est en français ( l’url tombe sur https://ids-agri.com/revetements-agricole/). J’ai juste pour l’instant mis « agriculture » comme titre (texte qui passe en fr et en, et ainsi je garde mon fil d’ariane EN) et mis aucun texte dans la page boutique pour l’instant (dommage pour SEO).

    Alors petite question vis à vis de la conception de mes pages, c’est peut être une piste mais je ne veux pas tout chambouler pour rien. J’ai créé les categ dans woocommerce et pour mettre en page ces categ j’ai créé une page pour la modifier avec elementor ainsi la categ woocommerce et la page référente ont le même slug. Au niveau des pages j’ai donc la page parente  :

    • Tapis et revêtements de sol pour les vaches — <i class= »eicon-elementor-square » title= »Elementor »></i>
      • Tapis pour le couchage des vaches — <i class= »eicon-elementor-square » title= »Elementor »></i>
      • Tapis pour la circulation des vaches — <i class= »eicon-elementor-square » title= »Elementor »></i>
      • Tapis pour la salle de traite — <i class= »eicon-elementor-square » title= »Elementor »></i>
      • Tapis pour le transport des vaches — <i class= »eicon-elementor-square » title= »Elementor »></i>
      • Accessoires pour le confort des vaches — <i class= »eicon-elementor-square » title= »Elementor »></i>
    • Tapis et revêtements de sol pour les chevaux

      • Tapis pour le box des chevaux ………..

    La page boutique n’est donc pas rattachée aux pages parentes vaches / chevaux, est ce que cela peut avoir un impact justement vis à vis de la traduction EN ? je ne sais pas si je me suis bien exprimé ?? est-ce qu’il faut que la page boutique devienne page parente des categ vaches / chevaux / porcs ?

     

    • Oui je sais également que j’ai un pb de slug. En fait à la base (le site n’était prévu qu’en fr) j’ai mis dans mes réglages de permalien « revetement-de-sol » et je me rend compte que j’ai fait une erreur car impossible de le changer en version anglaise, si tu as une idée je suis preneuse… j’ai essayé avec poedit mais ce ne fonctionne pas 🙁
      Et je me vois mal supprimer ce permalien et faire des redirections d’URL sur toutes mes pages produits. alors comment traduire « revetement-de-sol » ?

    Si vous pouvez m’aider please…. merci d’avance.

     

     

    #2401866
    momofr@free.fr
    Modérateur
    Maître WordPress
    4589 contributions

    Salut, je pense que tes soucis viennent des slugs. Toutes tes pages sont traduites ?

    Normalement quand on traduit avec Polylang, le slug de la page anglaise reprend le titre traduit de la page, là je vois que non.

    Quelque chose n’a pas été fait correctement, ceci dit tu peux revoir le permalien par la suite.

    Si tu utilises unesextension comme Rank Math avec le module de redirection actif et dynamique, Rank Math va créer la redirection automatique au changement du slug.

    Un autre point à vérifier : réenregistre tes permaliens dans les réglages généraux de WordPress.

    #2401867
    BERNARD FCMT
    Participant
    Initié WordPress
    12 contributions

    Oui toutes mes pages sont traduites.

    Pour le slug, j’ai utilisé yoast pour modifier le slug des pages anglaises.

    C’est la première fois que je crée un site wordpress avec woocommerce, j’ai peut être mal paramétré quelque chose?

    Merci pour l’extension RankMath, il n’y aura pas de conflit avec le plugin Redirection?

    J’ai de nouveau enregistré les réglages permalien mais rien ne change (j’ai vidé le cache wordpress et navigateur). Je te met en PJ le screenshot de mes réglages. te faut-il autre chose?

    merci pour ton aide en tout cas.

     

    Fichiers joints :
    Vous devez être connecté pour voir les fichiers joints.
    #2401893
    Lumiere de Lune
    Participant
    Maître WordPress
    20207 contributions

    « ainsi la categ woocommerce et la page référente ont le même slug » c’est pas top

    Je ne connais pas Polylang, mais WPML permet de traduire les taxonomies et les termes, et les slugs

    #2401897
    BERNARD FCMT
    Participant
    Initié WordPress
    12 contributions

    En fait, je devais personnaliser la page catégorie et c’est la seule solution que j’ai trouvé mais je me doutais que ce n’était pas dans la logique des choses. Mais ça fonctionnait. Car si l’URL était différente lorsque l’on clique dans le fil d’ariane d’un produit, impossible de retourner sur la page « personnalisée » que j’avais créé puisqu’on retourne forcément sur la categ woocommerce qui ne correspond pas du tout à ma page personnalisée 🙁
    (après au niveau expérience utilisateur c’est moyen, car du coup quand on est sur un produit les menus ne sont plus actifs, on ne sait plus où on est, sauf fil d’ariane).

    Est-ce que cela peut être la cause que je ne peux pas synchroniser la boutique fr/en? ou faut-il que la page boutique soit parent des autres pages categ personnalisée…je m’interroge?

    Après si vous avez une idée pour personnaliser la categ woocommerce comme je l’ai fait sur ma page ce serait top… j’ai Woolentor d’installer, est ce que le template builder Woolentor/shop permet de remplacer la page boutique ?

    J’ai déjà entendu parlé de WPML, merci Lumiere de Lune, mais si je peux éviter les plugins payants, compliqué en ce moment…

    Je sais plus quoi faire et j’ai l’impression de me mélanger les pinceaux la…. merci encore

    #2401902
    momofr@free.fr
    Modérateur
    Maître WordPress
    4589 contributions

    Salut, lorsque tu passe un site ( ou boutique) en multilingue tu dois :

    • Traduire les catégories
    • Traduire les attributs (produits)
    • Traduire en entrées (articles, produits, CPT…)
    • Traduire les pages fixes
    • Traduire les éléments dynamiques d’Elementor (installer l’extension qui fait le lien entre Polylang et Elementor)

    Si c’est correctement fait pas de souci à noter, slug et fil d’Ariane fonctionnent dans chaque langue.

    Ceci dit, je viens de regarder une boutique que j’ai en 2 langues avec Polylang et effectivement on a acheté la licence du module pour WooCommerce, ça peut venir de là.

    • Cette réponse a été modifiée le il y a 1 semaine et 6 jours par momofr@free.fr.
    #2402014
    BERNARD FCMT
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    Oui ça peut être dû à cela… car il n’y a que quand je suis dans les produits où j’ai un soucis sur le fil d’ariane, sur tout le reste du site tout est traduit correctement et la synchronisation FR/EN fonctionne.

    Donc la il faut acheter le module pour pouvoir avoir la page boutique en anglais si je comprends bien…

    Perso je n’ai pas réellement besoin de la page boutique puisque j’ai créé mes pages categ sous elementor. y’a un moyen de supprimer cette page à tout hasard ? en plus ma page boutique n’est accessible que via le fil d’ariane dans mes produits.

    Merci

    #2402360
    BERNARD FCMT
    Participant
    Initié WordPress
    12 contributions

    Bonjour,

    J’ai trouvé une solution 😉 merci à <span class= »bbp-author-name »>momo pour son aide précieuse.</span>

    En voulant tester le plugin RankMath sur un autre site que j’ai en test, avec à peu près les mêmes config… j’ai eu un Eurêka!! en fait mon fil d’ariane était celui de YoastSeo (via un shortcode) et sur mon site en test celui que je voyais était celui de woocommerce.

    Et donc dans le fil d’ariane de woocommerce, l’URL de la page boutique n’apparait pas ! ce qui résoud mon problème de synchronisation de boutique  FR/EN (puisqu’elle n’est dorénavant plus accessible directement sur mon site). J’ai donc intégré dans mon template « produit », l’élément WL:Breadcrumbs (cf plugin WooLentor – WooCommerce Elementor Addons + Builder) et le tour est joué…

    Bon il me reste mon problème d’URL mais bon, ca c’est autre chose. Un peu peur de passer de Yoast à RankMath vis à vis de la compatibilité avec Polylang… j’ai une inquiétude sur le fait d’avoir d’autres bugs. J’ai vu dans les réglages/woocommerce  de RankMath, l’option « Retirer la base » qui permettrait effectivement d’enlever la base personnalisée de mon permalien. Faut-il juste effectuer cette manip et toutes mes URLs produits seront redirigées correctement ?

    Il m’a l’air pas mal ce plugin car il permet d’avoir une extension au lieu de plusieurs, on gagne en temps de chargement, après j’espère qu’il fera bien son boulot! Je vais le mettre en place sur mon site en espérant que les redirections se fassent correctement…

    Encore merci de votre aide…

10 sujets de 1 à 10 (sur un total de 10)
  • Vous devez être connecté pour répondre à ce sujet.